Subject: [Curdle] is draft-ietf-curdle-ssh-curves-00 dead?

From: "Mark D. Baushke" <[email-masked]>
Date: Sun, 12 Mar 2017 17:37:25 -0700

Hi,

I am about to republish my draft-ietf-curdle-ssh-kex-sha2-05
before it expires.

I am curious if I should remove curve25519-sha256 and curve448-sha512
or not. They reference the expired draft-ietf-curdle-ssh-curves-00
right now.

I can easily remove them. Is there consensus that they are not a good
alternative for a Key Exchange Algorithm?

	Thank you,
	-- Mark

---

From: "denis bider \(Bitvise\)" <[email-masked]>
Date: Mon, 13 Mar 2017 02:04:51 -0600

Bitvise SSH Server, SSH Client, and the FlowSsh library support curve25519-sha256 as an alias for [email-masked].

I would definitely keep them included. There is relatively strong user demand for this algorithm and there’s no reason it should go completely without mention.

If the draft specifying the standard name has expired, that’s more of a testament to the ineffective and glacial nature of the IETF process – where things become “standard” right about the time they’re already obsolete - rather than a deficiency of the draft, or the algorithm.

denis

From: Mark D. Baushke 
Sent: Sunday, March 12, 2017 18:37
To: [email-masked] 
Subject: [Curdle] is draft-ietf-curdle-ssh-curves-00 dead?

Hi,

Thank you,
-- Mark

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 13 Mar 2017 12:10:10 +0000

> I am about to republish my draft-ietf-curdle-ssh-kex-sha2-05 before it
> expires.
> 
> I am curious if I should remove curve25519-sha256 and curve448-sha512 or
> not. They reference the expired draft-ietf-curdle-ssh-curves-00 right now.

Simon and Aris,

Do you have plans to update your draft?  If you are overloaded, would it be helpful if we got a volunteer to co-author to help move it forward?

--  
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz