Subject: [Curdle] draft-ietf-curdle-pkix / Algorithm Identifier for prehash variant

From: Daniel Migault <[email-masked]>
Date: Wed, 22 Mar 2017 18:13:47 -0400

Hi,

As we are moving toward only using the non prehash variant. I would like to
have the WG opinion on whether or not we should keep the following
algorithm Identifiers:

   id-Ed25519ph OBJECT IDENTIFIER ::= { 1 3 101 114 }
   id-Ed448ph   OBJECT IDENTIFIER ::= { 1 3 101 115 }

Yours,

Daniel

---

From: Sean Turner <[email-masked]>
Date: Wed, 22 Mar 2017 18:55:29 -0400

You mean just dropping them from the draft right because once you’ve assigned the # and put ‘em in a draft they’re pretty much out there?

spt

> On Mar 22, 2017, at 18:13, Daniel Migault <[email-masked]> wrote:
> 
> Hi, 
> 
> As we are moving toward only using the non prehash variant. I would like to have the WG opinion on whether or not we should keep the following algorithm Identifiers:
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: Daniel Migault <[email-masked]>
Date: Wed, 22 Mar 2017 19:12:24 -0400

Yes removing them from the draft. OIDs will be re-assigned by the IANA.
Yours,
Daniel

On Wed, Mar 22, 2017 at 6:55 PM, Sean Turner <[email-masked]> wrote:

> You mean just dropping them from the draft right because once you’ve
> assigned the # and put ‘em in a draft they’re pretty much out there?
>
> spt
>
> > As we are moving toward only using the non prehash variant. I would like
> to have the WG opinion on whether or not we should keep the following
> algorithm Identifiers:

---

From: Russ Housley <[email-masked]>
Date: Thu, 23 Mar 2017 10:37:22 -0400

These OIDs are not part of an arc controlled by IANA.  The party that assigned them is free manage their arc as they wish.

Russ

> On Mar 22, 2017, at 7:12 PM, Daniel Migault <[email-masked]> wrote:
> 
> On Wed, Mar 22, 2017 at 6:55 PM, Sean Turner <[email-masked] <mailto:[email-masked]>> wrote:
> > On Mar 22, 2017, at 18:13, Daniel Migault <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi,
> >
> >    id-Ed25519ph OBJECT IDENTIFIER ::= { 1 3 101 114 <tel:1%203%20101%20114> }
> >    id-Ed448ph   OBJECT IDENTIFIER ::= { 1 3 101 115 <tel:1%203%20101%20115> }
> >
> >
> > Yours,
> > Daniel

---

From: Erwann Abalea <[email-masked]>
Date: Thu, 23 Mar 2017 14:56:10 +0000

The 1.3.101 arc is controlled by Symantec/Thawte, and they offered to provide 1.3.101.100+ for EdDSA (it’s unclear if the range is 100-115 or 100-127, needs to be clarified by Rick Andrews).

Cordialement,
Erwann Abalea

Le 23 mars 2017 à 15:37, Russ Housley <[email-masked]<mailto:[email-masked]>> a écrit :

Russ

On Mar 22, 2017, at 7:12 PM, Daniel Migault <[email-masked]<mailto:[email-masked]>> wrote:

On Wed, Mar 22, 2017 at 6:55 PM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:
You mean just dropping them from the draft right because once you’ve assigned the # and put ‘em in a draft they’re pretty much out there?

spt

> On Mar 22, 2017, at 18:13, Daniel Migault <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>
>    id-Ed25519ph OBJECT IDENTIFIER ::= { 1 3 101 114<tel:1%203%20101%20114> }
>    id-Ed448ph   OBJECT IDENTIFIER ::= { 1 3 101 115<tel:1%203%20101%20115> }
>
>
> Yours,
> Daniel
_______________________________________________
Curdle mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/curdle

---

From: Rob Stradling <[email-masked]>
Date: Fri, 24 Mar 2017 10:27:43 +0000

On 22/03/17 23:12, Daniel Migault wrote:
<snip>
> OIDs will be re-assigned by the IANA.

Please don't do that.

The 1.3.101 arc was chosen to avoid OID bloat.  Symantec/thawte 
generously donated a range of OIDs under this arc to be used for 
identifying these algorithms.  Reassigning the OIDs under a different 
arc is not necessary.

> Yours,
> Daniel
>
> On Wed, Mar 22, 2017 at 6:55 PM, Sean Turner wrote:
>
>     > On Mar 22, 2017, at 18:13, Daniel Migault
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>     >
>     > Hi,
>     >
>     > As we are moving toward only using the non prehash variant. I
>     would like to have the WG opinion on whether or not we should keep
>     the following algorithm Identifiers:

-- 
Rob Stradling
Senior Research & Development Scientist
COMODO - Creating Trust Online

---

From: Brian Smith <[email-masked]>
Date: Fri, 24 Mar 2017 00:30:43 -1000

Daniel Migault <[email-masked]> wrote:
> have the WG opinion on whether or not we should keep the following algorithm
> Identifiers:
>

Please remove them. Leaving them in would cause confusion.

Cheers,
Brian
--
https://briansmith.org/

---

From: Ilari Liusvaara <[email-masked]>
Date: Tue, 28 Mar 2017 01:57:27 +0300

On Fri, Mar 24, 2017 at 10:27:43AM +0000, Rob Stradling wrote:
> The 1.3.101 arc was chosen to avoid OID bloat.  Symantec/thawte generously
> donated a range of OIDs under this arc to be used for identifying these
> algorithms.  Reassigning the OIDs under a different arc is not necessary.

+1

And just to ensure that there is no miscommunication, is anyone
suggesting that any of the following OIDs are changed:

- 1.3.101.110 (id-X25519) [2b656e(+en)]
- 1.3.101.111 (id-X448) [2b656f(+eo)]
- 1.3.101.112 (id-Ed25519) [2b6f70(+ep)]
- 1.3.101.113 (id-Ed448) [2b6f71(+eq)]

If so, why are they suggesting changes here (if reasoning is expressed
in prior mail, then pointer to that mail)? AFAIK, all these OIDs are
in part of arc given for specific purpose of containing them.

I don't remember any proposals for any changes to those.

-Ilari

---

From: Russ Housley <[email-masked]>
Date: Mon, 27 Mar 2017 19:10:17 -0400

> On Mar 27, 2017, at 6:57 PM, Ilari Liusvaara <[email-masked]> wrote:
> 

No.

There were two things discussed about OIDs:

1) whether to keep the pre-hash OIDs in the document.

2) how to get the OIDs assigned for draft-ietf-curdle-cms-ecdh-new-curves

Neither of these has any impact in the OIDs on your list.

Russ