Subject: [Curdle] Progressing with draft-ietf-curdle-cms-ecdh-new-curves

From: Russ Housley <[email-masked]>
Date: Mon, 6 Mar 2017 10:58:35 -0500

I do not recall seeing an answer to the question asked in the IANA Considerations:

10.  IANA Considerations

   Three object identifiers for the Key Agreement Algorithm Identifiers
   in Sections 7 are needed.  Are they going to come from an IANA
   registry or from the registry that assigned the object identifiers in
   [ID.curdle-pkix]?

I am fine with either approach; However, some people have wanted short OIDs for the CFRG curves.

I would like to get this wrapped up soon.

Russ

---

From: Russ Housley <[email-masked]>
Date: Thu, 9 Mar 2017 15:18:04 -0500

We really need to sort this issue.  The S/MIME 4.0 specification has a MUST dependency on draft-ietf-curdle-cms-ecdh-new-curves, and it cannot be implemented unless object identifiers are assigned.

Russ

> On Mar 6, 2017, at 10:58 AM, Russ Housley <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 9 Mar 2017 23:13:18 +0000

> We really need to sort this issue.  The S/MIME 4.0 specification has a MUST
> dependency on draft-ietf-curdle-cms-ecdh-new-curves, and it cannot be
> implemented unless object identifiers are assigned.

You want the chairs to just pick an arc?  Or do you have a preference that you'd like the WG to use?  Or the wg-chairs to pressure for?

---

From: Russ Housley <[email-masked]>
Date: Fri, 10 Mar 2017 11:14:29 -0500

> You want the chairs to just pick an arc?  Or do you have a preference that you'd like the WG to use?  Or the wg-chairs to pressure for?

I think we have two choices:

(1) get the OIDs from the same arc that was used in curdle-pkix; or

(2) get the OIDs from the S/MIME arc manages by IANA.

Either one works for me.

Russ

---

From: Daniel Migault <[email-masked]>
Date: Fri, 10 Mar 2017 21:33:07 +0000

Hi, 

Please provide your preference by Tuesday March 14. 

Yours, 
Daniel

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Friday, March 10, 2017 11:14 AM
To: Rich Salz <[email-masked]>
Cc: [email-masked]
Subject: Re: [Curdle] Progressing with draft-ietf-curdle-cms-ecdh-new-curves

Rich:

>> We really need to sort this issue.  The S/MIME 4.0 specification has 
>> a MUST dependency on draft-ietf-curdle-cms-ecdh-new-curves, and it 
>> cannot be implemented unless object identifiers are assigned.
> 

Either one works for me.

Russ

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: Daniel Migault <[email-masked]>
Date: Tue, 14 Mar 2017 23:04:49 +0000

Hi, 

We have seen no support for option 1 and we are missing contact information to move forward with this option. As a result, we chose to go with option 2. 

Yours, 
Rich and Daniel

-----Original Message-----
From: Daniel Migault 
Sent: Friday, March 10, 2017 4:33 PM
To: Russ Housley <[email-masked]>; Rich Salz <[email-masked]>
Cc: [email-masked]
Subject: RE: [Curdle] Progressing with draft-ietf-curdle-cms-ecdh-new-curves

Hi, 

Yours, 
Daniel

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Friday, March 10, 2017 11:14 AM
To: Rich Salz <[email-masked]>
Cc: [email-masked]
Subject: Re: [Curdle] Progressing with draft-ietf-curdle-cms-ecdh-new-curves

Either one works for me.

Russ