Subject: [Curdle] I-D Action: draft-ietf-curdle-ssh-curves-03.txt

From: [email-masked]
Date: Wed, 12 Apr 2017 12:04:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : Secure Shell (SSH) Key Exchange Method using Curve25519 and Curve448
        Authors         : Aris Adamantiadis
                          Simon Josefsson
                          Mark D. Baushke
	Filename        : draft-ietf-curdle-ssh-curves-03.txt
	Pages           : 6
	Date            : 2017-04-12

Abstract:
   This document describes the conventions for using Curve25519 and
   Curve448 key exchange methods in the Secure Shell (SSH) protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-ssh-curves/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-curdle-ssh-curves-03
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-ssh-curves-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-ssh-curves-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Sean Turner <[email-masked]>
Date: Wed, 12 Apr 2017 15:08:00 -0400

Should this be referring to RFC7748 for curves 25519 and 448?

spt

> On Apr 12, 2017, at 15:04, [email-masked] wrote:
> 
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: "Mark D. Baushke" <[email-masked]>
Date: Wed, 12 Apr 2017 14:14:01 -0700

Hi Sean,

> Should this be referring to RFC7748 for curves 25519 and 448?

I think so, and I think it does in section 2.

Page 3 says:

   The methods are based on Curve25519 and Curve448 scalar
   multiplication, as described in [RFC7748].  Private and public keys
   are generated as described therein.  Public keys are defined as
   strings of 32 bytes for Curve25519 and 56 bytes for Curve448.
   Clients and servers MUST fail the key exchange if the length of the
   received public keys are not the expected lengths, or if the derived
   shared secret only consists of zero bits.  No further validation is
   required beyond what is discussed in [RFC7748].  The derived shared
   secret is 32 bytes when Curve25519 is used and 56 bytes when Curve448
   is used.  The encodings of all values are defined in [RFC7748].  The
   hash used is SHA-256 for Curve25519 and SHA-512 for Curve448.

Could you be more specific as to what change(s) you are suggesting?

	-- Mark

---

From: Sean Turner <[email-masked]>
Date: Wed, 12 Apr 2017 18:05:52 -0400

> On Apr 12, 2017, at 17:14, Mark D. Baushke <[email-masked]> wrote:
> 
> Hi Sean,
> 

Sorry for not being more specific.  There’s still references to the other specs.

OLD:

   This document describes how to implement key exchange based on
   [Curve25519] and [Ed448-Goldilocks] in SSH.

NEW:

   This document describes how to implement key exchange based on
   Curve25519 and Ed448-Goldilocks [RFC7748] in SSH.

spt

---

From: "Mark D. Baushke" <[email-masked]>
Date: Wed, 12 Apr 2017 16:25:30 -0700

> A new version of I-D, draft-ietf-curdle-ssh-curves-04.txt
> has been successfully submitted by Mark D. Baushke and posted to the
> IETF repository.
> 
> Name:		draft-ietf-curdle-ssh-curves
> Revision:	04
> Title:		Secure Shell (SSH) Key Exchange Method using Curve25519 and Curve448
> Document date:	2017-04-10
> Group:		curdle
> Pages:		6
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-curdle-ssh-curves-04.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-curdle-ssh-curves/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-curdle-ssh-curves-04
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-curdle-ssh-curves-04
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-ssh-curves-04
> 
> Abstract:

This revision addresses Sean Turner's comments.

	-- Mark