Subject: [Curdle] I-D Action: draft-ietf-curdle-cms-eddsa-signatures-04.txt

From: [email-masked]
Date: Mon, 10 Apr 2017 09:20:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : Use of EdDSA Signatures in the Cryptographic Message Syntax (CMS)
        Author          : Russ Housley
	Filename        : draft-ietf-curdle-cms-eddsa-signatures-04.txt
	Pages           : 8
	Date            : 2017-04-10

Abstract:
   This document specifies the conventions for using Edwards-curve
   Digital Signature Algorithm (EdDSA) for Curve25519 and Curve448 in
   the Cryptographic Message Syntax (CMS).  For each curve, EdDSA
   defines the PureEdDSA and HashEdDSA modes.  However, the HashEdDSA
   mode is not used with the CMS.  In addition, no context string is
   used with the CMS.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-cms-eddsa-signatures/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-curdle-cms-eddsa-signatures-04
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-cms-eddsa-signatures-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-cms-eddsa-signatures-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Russ Housley <[email-masked]>
Date: Mon, 10 Apr 2017 12:21:41 -0400

I believe this resolves the comments that I received during WG Last Call.

Russ

> On Apr 10, 2017, at 12:20 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

---

From: Jim Schaad <[email-masked]>
Date: Mon, 10 Apr 2017 10:50:11 -0700

Except for the issue we discussed over dinner, which I have not seen a
resolution for, I am happy with this document.

Jim

> -----Original Message-----
> From: Curdle [mailto:[email-masked]] On Behalf Of Russ Housley
> Sent: Monday, April 10, 2017 9:22 AM
> To: curdle <[email-masked]>
> Subject: Re: [Curdle] I-D Action:
draft-ietf-curdle-cms-eddsa-signatures-04.txt
> >        Title           : Use of EdDSA Signatures in the Cryptographic
Message
> Syntax (CMS)
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.