Subject: [Curdle] Call for adoption

From: Daniel Migault <[email-masked]>
Date: Wed, 12 Apr 2017 11:40:39 -0400

Hi,

This mail starts a call for adoption for the two following drafts. If you
have any opinion, please raise it by April 26.

    - https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt
    - https://tools.ietf.org/html/draft-kaduk-kitten-des-des-des-
die-die-die-01

Yours,
Daniel

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Apr 2017 11:54:38 -0400

Wouldn’t it be more appropriate for these documents to go through the KITTEN WG?  Their charter (https://datatracker.ietf.org/wg/kitten/about/ <https://datatracker.ietf.org/wg/kitten/about/>) covers GSS-API and Kerberos.

That said, if the Area Director would rather this work come through the CURDLE WG, I can live with it.

Russ

> On Apr 12, 2017, at 11:40 AM, Daniel Migault <[email-masked]> wrote:
> 
> Hi, 
> 
> This mail starts a call for adoption for the two following drafts. If you have any opinion, please raise it by April 26. 
> 
>     - https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt <https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt>
>     - https://tools.ietf.org/html/draft-kaduk-kitten-des-des-des-die-die-die-01 <https://tools.ietf.org/html/draft-kaduk-kitten-des-des-des-die-die-die-01>
> 
> Yours, 
> Daniel

---

From: Simo Sorce <[email-masked]>
Date: Wed, 12 Apr 2017 16:47:12 -0400

On Wed, 2017-04-12 at 11:54 -0400, Russ Housley wrote:
> Wouldn’t it be more appropriate for these documents to go through the
> KITTEN WG?  Their charter
> (https://datatracker.ietf.org/wg/kitten/about/
> <https://datatracker.ietf.org/wg/kitten/about/>) covers GSS-API and
> Kerberos.

Mi draft is strictly related to other drafts[*] in this WG that are
defining transition from SHA-1 to SHA-2 for SSH key exchange. It seemed
like this WG is most appropriate to review that draft to me.
I guess I should have added "SSH" somewhere in the title to make it
clear.

Simo.

[*]
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-ssh-modp-dh-sha2
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-ssh-curves
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-rsa-sha2

> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle

-- 
Simo Sorce
Sr. Principal Software Engineer
Red Hat, Inc

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 12 Apr 2017 19:19:12 -0500

On the other hand, my draft is squarely focused on Kerberos and
the GSS-API ... but I am also co-chair of the kitten WG, and my
co-chair is considering being replaced, so it would be somewhat
difficult for it to move forward in the kitten WG in a timely
manner.  It seems much more likely to advance quickly if progressing
through curdle, and it does seem to be in scope, to me.

-Ben

---

From: Russ Housley <[email-masked]>
Date: Thu, 13 Apr 2017 09:49:33 -0400

Ben:

Thanks for the explanation.  I withdraw my concerns.  Let’s process these promptly.

Russ

> On Apr 12, 2017, at 8:19 PM, Benjamin Kaduk <[email-masked]> wrote:
>

---

From: Daniel Migault <[email-masked]>
Date: Thu, 27 Apr 2017 14:02:13 -0400

Hi,

Regarding the feed backs we received the two drafts are accepted as WG
documents. Benjamin and Simo, please upload your documents as WG documents
that is as  draft-ietf-curdle-gss-keyex-sha2-00
draft-ietf-curdle-des-des-des-die-die-die-00 or equivalent.

Yours,
Daniel

On Thu, Apr 13, 2017 at 9:49 AM, Russ Housley <[email-masked]> wrote:

> >>>> This mail starts a call for adoption for the two following drafts. If
> you have any opinion, please raise it by April 26.
> >>>>
> >>>>    - https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt <
> https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt>
> >>>>    - https://tools.ietf.org/html/draft-kaduk-kitten-des-des-
> des-die-die-die-01 <https://tools.ietf.org/html/
> draft-kaduk-kitten-des-des-des-die-die-die-01>
> >>>>
> >>>> Yours,
> >>>> Daniel

---

From: Simo Sorce <[email-masked]>
Date: Fri, 28 Apr 2017 15:32:41 -0400

Thank you Daniel,I renamed and uploaded the draft which includes the
fedback already received from Mark and others.
Simo.
On Thu, 2017-04-27 at 14:02 -0400, Daniel Migault wrote:
> Hi, 
> 
> Regarding the feed backs we received the two drafts are accepted as
> WG documents. Benjamin and Simo, please upload your documents as WG
> documents that is as  draft-ietf-curdle-gss-keyex-sha2-00 draft-ietf-
> curdle-des-des-des-die-die-die-00 or equivalent.
> 
> Yours, 
> Daniel 
> 
> > >>> That said, if the Area Director would rather this work come
> > through
> > 
> > >>> the CURDLE WG, I can live with it.
> > 
> > >>>
> > 
> > >>> Russ
> > 
> > >>>
> > 
> > >>>
> > 
> > >>>> This mail starts a call for adoption for the two following
> > drafts. If you have any opinion, please raise it by April 26.
> > 
> > >>>>
> > 
> > >>>>    - https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.tx
> > t <https://www.ietf.org/id/draft-ssorce-gss-keyex-sha2-00.txt>
> > 
> > >>>>    - https://tools.ietf.org/html/draft-kaduk-kitten-des-des-de
> > s-die-die-die-01 <https://tools.ietf.org/html/draft-kaduk-kitten-
> > des-des-des-die-die-die-01>
> > 
> > >>>>
> > 
> > >>>> Yours,
> > 
> > >>>> Daniel
> >