Subject: [Curdle] Adam Roach's No Objection on draft-schaad-curdle-oid-registry-02: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Wed, 24 Jan 2018 15:42:17 -0800

Adam Roach has entered the following ballot position for
draft-schaad-curdle-oid-registry-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-schaad-curdle-oid-registry/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I think it would be useful to include explicit entries in the initial IANA
table indicating those values which are currently unassigned (i.e., add a range
for 101-109 and 116-127.) For this use in particular, where overstepping the
bounds of the allocation would impinge on codes retained by Symantec, this
seems even more important than typical.

---

From: Jim Schaad <[email-masked]>
Date: Wed, 24 Jan 2018 15:53:47 -0800

Would adding the following lines be an adequate replacement?

0 - 99  | Retained by Symantec | [This RFC]
128+   | Retained by Symantec | [This RFC]

I think this is more in line with normality that having a list of "this value open for registration".

Jim

> -----Original Message-----
> From: Adam Roach [mailto:[email-masked]]
> Sent: Wednesday, January 24, 2018 3:42 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Daniel Migault
> <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]
> Subject: Adam Roach's No Objection on draft-schaad-curdle-oid-registry-02:
> (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> I think it would be useful to include explicit entries in the initial IANA table
> indicating those values which are currently unassigned (i.e., add a range for
> 101-109 and 116-127.) For this use in particular, where overstepping the

---

From: Adam Roach <[email-masked]>
Date: Wed, 24 Jan 2018 18:00:17 -0600

> 128+   | Retained by Symantec | [This RFC]

Yep, that's good also.

> I think this is more in line with normality that having a list of "this value open for registration".

To be clear, I find your solution above to be fine without any 
additional changes; however, I would like to note that assignable ranges 
are handled both with and without explicit table entries; see the 
following for contrasting approaches:

https://www.iana.org/assignments/http-status-codes/http-status-codes.xhtml
https://www.iana.org/assignments/sip-parameters/sip-parameters.xhtml#sip-parameters-7

/a

---

From: Rob Stradling <[email-masked]>
Date: Thu, 25 Jan 2018 09:37:47 +0000

> 128+   | Retained by Symantec | [This RFC]

Symantec have also allocated a bunch of OIDs under the 1.3.101 arc to 
the TRANS WG, for use in 6962-bis.

Therefore, "Retained by Symantec" seems a bit misleading.  I think 
something along the lines of "Not allocated to CURDLE" would be more 
accurate.

> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle
> 

-- 
Rob Stradling
Senior Research & Development Scientist
COMODO - Creating Trust Online
Office Tel: +44.(0)1274.730505
Office Fax: +44.(0)1274.730909
www.comodo.com

COMODO CA Limited, Registered in England No. 04058690
Registered Office:
   3rd Floor, 26 Office Village, Exchange Quay,
   Trafford Road, Salford, Manchester M5 3EQ

This e-mail and any files transmitted with it are confidential and 
intended solely for the use of the individual or entity to whom they are 
addressed.  If you have received this email in error please notify the 
sender by replying to the e-mail containing this attachment. Replies to 
this email may be monitored by COMODO for operational or business 
reasons. Whilst every endeavour is taken to ensure that e-mails are free 
from viruses, no liability can be accepted and the recipient is 
requested to use their own virus checking software.

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Jan 2018 14:46:39 -0500

I think that "not allocated to IETF" would be better.

Russ

> On Jan 25, 2018, at 4:37 AM, Rob Stradling <[email-masked]> wrote:
> 
> Symantec have also allocated a bunch of OIDs under the 1.3.101 arc to the TRANS WG, for use in 6962-bis.
> 
> Therefore, "Retained by Symantec" seems a bit misleading.  I think something along the lines of "Not allocated to CURDLE" would be more accurate.
> 
> This e-mail and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.  If you have received this email in error please notify the sender by replying to the e-mail containing this attachment. Replies to this email may be monitored by COMODO for operational or business reasons. Whilst every endeavour is taken to ensure that e-mails are free from viruses, no liability can be accepted and the recipient is requested to use their own virus checking software.
>

---

From: Rob Stradling <[email-masked]>
Date: Thu, 25 Jan 2018 21:54:31 +0000

Russ,

But TRANS is an IETF WG!

What is the scope of draft-schaad-curdle-oid-registry?  Does it only 
cover OIDs allocated to CURDLE?  If so, how can it make an assertion 
that OIDs have not been allocated to other IETF WGs?

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Jan 2018 17:32:27 -0500

The point of making the IANA registry is so that other groups, even ones that are not chartered yet, can get short OIDs when they need them.

Russ

> On Jan 25, 2018, at 4:54 PM, Rob Stradling <[email-masked]> wrote:
> 
> Russ,
> 
> But TRANS is an IETF WG!
> 
> What is the scope of draft-schaad-curdle-oid-registry?  Does it only cover OIDs allocated to CURDLE?  If so, how can it make an assertion that OIDs have not been allocated to other IETF WGs?
>

---

From: Jim Schaad <[email-masked]>
Date: Thu, 25 Jan 2018 15:46:50 -0800

I have issued a new version of the document that I believe picks up all of the comments made.  Given that the division for the OID tree has moved from Symantec to Digicert and the desire of Rick to update the text to reflect that I have changed the title of the document as well (also due to the nudge from Mirja).  If there are any issues please let me know.

Jim

> Sent: Wednesday, January 24, 2018 4:00 PM
> To: Jim Schaad <[email-masked]>; 'The IESG' <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: Adam Roach's No Objection on draft-schaad-curdle-oid-registry-
> 02: (with COMMENT)
> 
> To be clear, I find your solution above to be fine without any additional
> changes; however, I would like to note that assignable ranges are handled
> both with and without explicit table entries; see the following for contrasting
> approaches:
>

---

From: Rob Stradling <[email-masked]>
Date: Fri, 26 Jan 2018 12:24:05 +0000

> The point of making the IANA registry is so that other groups, even ones that are not chartered yet, can get short OIDs when they need them.

Oh, so is this document intended to cover all OIDs and OID ranges under 
the 1.3.101 arc that have been donated to the IETF by Symantec/DigiCert?

If so, please could we add to this document the OIDs and OID ranges that 
Symantec/DigiCert have donated to the TRANS WG?

BTW, ISTM that the new document title ("IANA Registration for new 
Cryptographic Algorithm Object Identifier Range") needs to be changed. 
"Cryptographic Algorithm Object Identifier"s is one use of "short OIDs", 
but it's not the only use.  Case in point: TRANS has been allocated some 
OIDs and OID ranges under the 1.3.101 arc for use as certificate 
extension IDs and CT log IDs.

>>> I think that "not allocated to IETF" would be better.
<snip>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Jan 2018 13:01:14 +0000

➢ The point of making the IANA registry is so that other groups, even ones that are not chartered yet, can get short OIDs when they need them.
    
+1.  This is a resource being given to the IETF, not just one working group.

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Jan 2018 10:25:28 -0500

Rob:

> Oh, so is this document intended to cover all OIDs and OID ranges under the 1.3.101 arc that have been donated to the IETF by Symantec/DigiCert?

They reserved 0-99 for themselves.

They offered 100-127 for the IETF.  My understanding is that the desire was to support curves 25519 and 448.

They reserved 128 and up for themselves.

> If so, please could we add to this document the OIDs and OID ranges that Symantec/DigiCert have donated to the TRANS WG?

Was this part of the same arc?

Russ

---

From: Rob Stradling <[email-masked]>
Date: Fri, 26 Jan 2018 15:35:28 +0000

> Was this part of the same arc?

Yes.  Some in the "0-99" range, and some in the "128 and up" range.

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Jan 2018 10:50:21 -0500

> On Jan 26, 2018, at 10:35 AM, Rob Stradling <[email-masked]> wrote:
> 

This document could be adjusted to include other parts of the arc, or the TRANS WG could put forward a document to add to the IANA registry.

Russ

---

From: Ilari Liusvaara <[email-masked]>
Date: Fri, 26 Jan 2018 17:58:39 +0200

> Yes.  Some in the "0-99" range, and some in the "128 and up" range.

Specifically, I find the following ones from the specification:

1.3.101.75          Transparency information X.509 extension.
1.3.101.78          Signed data content type for precertificates.
1.3.101.80.*        Reserved for log IDs
1.3.101.8192-16383  Reserved for log IDs

-Ilari

---

From: Rob Stradling <[email-masked]>
Date: Fri, 26 Jan 2018 16:06:13 +0000

<snip>
> 1.3.101.8192-16383  Reserved for log IDs

.76 and .77 were also allocated.  They were used for the domain label 
redaction mechanism specified in earlier versions of 6962-bis, which was 
subsequently moved to a separate I-D:

https://datatracker.ietf.org/doc/draft-strad-trans-redaction/

---

From: Rob Stradling <[email-masked]>
Date: Fri, 26 Jan 2018 16:11:24 +0000

On 26/01/18 15:50, Russ Housley wrote:
<snip>
> This document could be adjusted to include other parts of the arc, or the TRANS WG could put forward a document to add to the IANA registry.

Anyone have a preference?

I'd be fine with either approach.

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Jan 2018 16:29:18 +0000

I prefer one document.

On 1/26/18, 11:11 AM, "Rob Stradling" <[email-masked]> wrote:

---

From: Daniel Migault <[email-masked]>
Date: Fri, 26 Jan 2018 16:37:36 +0000

I also personally  think one document is preferred.
Yours, 
Daniel

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of Salz, Rich
Sent: Friday, January 26, 2018 11:29 AM
To: Rob Stradling <[email-masked]>; Russ Housley <[email-masked]>
Cc: [email-masked]
Subject: Re: [Curdle] Adam Roach's No Objection on draft-schaad-curdle-oid-registry-02: (with COMMENT)

I prefer one document.