Subject: Re: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn

From: Atle Monrad <[email-masked]>
Date: Wed, 5 Feb 2014 09:38:04 +0000

Keith

Celine is fine with your explanations as is. 

Could you please share your working version of the draft with the public ASAP ??

This holds up finalization of the two cuss-drafts, and even if we now have sorted out all the issues, I would like to see the drafts completed soon.

As you know, 3GPP does not see this work as finalized until also our IETF-dependencies are completed.

/atle

________________________________ 

Atle Monrad
3GPP CT Chairman

Group Function Technology - Standardization and Technical Regulation 
Ericsson

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 24. januar 2014 17:16
To: [email-masked]; [email-masked]
Subject: Re: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn

See below - changes are made to my working version, which I will submit in due course when this dialog is closed. 

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]
> Sent: 16 December 2013 14:57
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: RE: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn
> 
> Hello,
> 
> Thank you for the update of the ISDN draft.
> I have just some comments or questions below on your answers to my 
> previous comments:
> 
> 1/ The text about "isdn-interwork" is in section 8 "UAS requirements" 
> but it is also applicable to other sections, for instance to section 7 
> "UAC requirements" (when UAC receives UUI in responses), so could it 
> be replicated in section 7 "UAC requirements" or only put once in 
> section 11 "Coding requirements" in order to be global, as you prefer?
> Note just an editorial comment: in section 16 about changes, 
> "ISDNinterwork" purpose value should be replaced by "isdn-interwork".
> 
A conformant UAC (i.e. according to this version of the id package) generates "isdn-uui" as the purpose parameter as part of the header field that invokes the service. A non-conformant UAC will not have been implemented according to this specification.

A non-conformant UAS receiving a "isdn-uui" purpose parameter when it expects the "isdn-interwork" purpose parameter will not understand it and therefore presumably will discard. The only previous version that might respond is an implementation that was implemented before the purpose parameter was defined, which is going back a long way. The UAS cannot invoke the service but can only respond to what it receives from a conformant UAC.

Therefore I do not see how a conformant UAC can receive a purpose parameter set to "isdn-interwork".

Change made, but as this part will be discarded on publication not strictly necessary.

> 2/A/ I agree with your comment on "originating user". But I think it 
> would be better to clarify the expected behavior by UAS [respectively 
> by UAC] on reception of User-to-User that is not with the "purpose" 
> parameter to "isdn-uui", or with no "purpose" parameter, in a request 
> [respectively in a response], as follows:
> 
> "When receiving UUI, when a User-to-User header field is received in a 
> request that is not from the originating user with the "purpose" 
> header field parameter to "isdn-uui", or with no "purpose" header 
> field parameter, the UAC MUST discard this header field." => this 
> sentence of the draft is ok but "UAC" should be replaced by "UAS", 
> isn't it? Because it's the UAS that receives the request containing 
> UUI sent by UAC (same comment for sentences beginning by "When 
> receiving UUI, when multiple User-to-User header [...]", it seems to 
> me that "UAS" and "UAC" are inverted).
> 
Two changes UAC to UAS made in section 8.

> "When receiving UUI, when a User-to-User header field is received in a 
> response that is not with the "purpose" header field parameter to 
> "isdn-uui", or with no "purpose" header field parameter, the UAC MUST 
> discard this header field." => this sentence could be added in order 
> to specify the UAC behavior when it receives unexpected UUI in a 
> response from the UAS.
> 
Difficult one this. For the non-inclusion, we have a "SHOULD" on the sending to allow for earlier implementations that do not understand the "purpose" header field parameter. On that basis, reception of the UUI header field without a "purpose" header field parameter should be permitted.

As regards the reception with a different header field parameter value, this could well be destined for a different, as yet undefined package.

In section 9 we say the following which was meant to cover this:

"   Processing for User-to-User header fields sent or received with
   values other than this value are outside the scope of this document,
   and the appropriate package document for that value applies."

On that basis I believe nothing is required to be changed.

> 2/B/ Yes the sentence "When sending UUI for the ISDN package, the UAS 
> SHOULD set the User-to-User "purpose" header field parameter to 
> "isdn-uui".  Non-inclusion of the "purpose"
> [...]" is well present in both sections 7 and 8. 
> But the sentence "When sending UUI for the ISDN package, if the 
> "purpose" header field is included, the UAC MUST set the User-to-User 
> "purpose" header field parameter to "isdn-uui"."
> is only present in section 7 but not in section 8, why? 
> (first sentence aims at recommending to include a purpose parameter 
> using a SHOULD whereas second sentence clarifies the required value 
> using a MUST)
> 
Looks like this is correct. Added.

> Thank you for your clarifications.
> 
> Best regards
>  
> Celine Serrut-Valette
> Orange Labs
> 
> -----Message d'origine-----
> De : DRAGE, Keith (Keith) [mailto:[email-masked]]
> Envoyé : lundi 16 décembre 2013 04:25
> À : SERRUT VALETTE Celine IMT/OLN; Gurbani, Vijay K (Vijay); 
> [email-masked] Objet : RE: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn
> 
> See below.
> 
> I will issue the version without the last two changes, but if the 
> discussion identifies some other text with which the group agrees, a 
> new version can always be issued.
> 
> Regards
> 
> Keith
> 
> > -----Original Message-----
> > From: cuss [mailto:[email-masked]] On Behalf Of 
> > [email-masked]
> > Sent: 28 November 2013 16:01
> > To: Gurbani, Vijay K (Vijay); [email-masked]
> > Subject: Re: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn
> > 
> > Hello,
> > 
> > Please find below some comments:
> > 
> > 1/ About "isdn-interwork" versus "isdn-uui" purpose
> parameter value: 
> > 
> > The discussions on the "[cuss] "isdn-uui" versus
> "isdn-network"" email
> > thread confirmed that there is still support from other cuss 
> > participants for addressing the use of the "isdn-network" parameter 
> > value. So, we don't think the document can be published without 
> > addressing this issue. We also understand that at least one company 
> > would not accept replacing "RECOMMEND" with "MUST", so we
> propose to
> > stick to the initial approach (cf
> > http://www.ietf.org/mail-archive/web/cuss/current/msg00509.htm
> > l ) and add the following text in section 11:
> > 
> > "The 'isdn-interwork' value for purpose parameter was used in 
> > Internet-Drafts that have led to the publication of the present RFC.
> > Although these documents had no other status than "work in
> progress",
> > this value is implemented by some vendors. Therefore, it is 
> > RECOMMENDED to support parsing and interpreting
> 'isdn-interwork' the
> > same way as 'isdn-uui' when receiving."
> > 
> This one has been dealt with in a separate dialog, and the text agreed 
> as a result of that dialog incorporated.
> 
> > 2/ About UAC and UAS procedures:
> > 
> > After having compared the UAC and UAS procedures in sections
> > 7 and 8, I noticed that 2 UAC procedures could be replicated as UAS 
> > procedures as well, so I would suggest to add in section 7:
> > "When receiving UUI, when a User-to-User header field is
> received in a
> > response that is not from the originating user with the "purpose"
> > header field parameter to "isdn-uui", or with no "purpose" header 
> > field parameter, the UAS MUST discard this header field."
> > (this procedure seems not present for UAS)
> > 
> Section 7 is the UAC procedures, and therefore material will never be 
> from the originating user.
> 
> This requirement was drafted because UUS1 in ISDN can only be 
> originated from the originating user and therefore this is a 
> unidirectional requirement.
> 
> Therefore I do not see the need for an equivalent procedure in clause 
> 7.
> 
> > And to add in section 8:
> > "When sending UUI for the ISDN package, if the "purpose" 
> > header field is included, the UAS MUST set the User-to-User
> "purpose" 
> > header field parameter to "isdn-uui"."
> > (this procedure is present for UAS but not so explicitly written)
> > 
> 
> Section 8 includes:
> 
>    The UAS MAY include the User-to-User header field in responses to 
> the
>    initial INVITE request, or the BYE requests or responses for the
>    dialog, only where the original INVITE request included a User-to-
>    User header field with the "purpose" header field parameter to 
> "isdn-
>    uui", or where no "purpose" header field parameter was included.
>    When sending UUI for the ISDN package, the UAS SHOULD set the User-
>    to-User "purpose" header field parameter to "isdn-uui".  Non-
>    inclusion of the "purpose" header field parameter is permitted, but
>    this is primarily to allow earlier implementations to support this
>    package.  The UAS MUST NOT include more than one User-to-User 
> header
>    field for this package in any SIP request or response.
> 
> Does this not effectively say that.
> 
> 
> > It could be worthwhile to add them in order to be symmetric when a 
> > procedure is common to both UAC and UAS, otherwise people
> could wonder
> > if it means that they are just missing or if it means that they are 
> > not applicable.
> > 
> > 
> > We would like these 1/ and 2/ comments to be taken into
> account before
> > the ISDN draft becomes a RFC.
> > Thank you in advance.
> > 
> > Best regards
> > 
> > Celine Serrut-Valette
> > Orange Labs
> > 
> > -----Message d'origine-----
> > De : [email-masked] [mailto:[email-masked]]
> De la part
> > de Vijay K. Gurbani Envoyé : mercredi 13 novembre
> > 2013 20:11 À : [email-masked] Objet : [cuss] WGLC for 
> > draft-ietf-cuss-sip-uui-isdn
> > 
> > Folks: Enrico and I will like to announce a WGLC for the ISDN draft 
> > [1].
> > 
> > The WGLC will run from Wed, Nov 13 2013 to Fri, Nov 29 2013.
> > 
> > We will appreciate your comments on the draft, posted to the list.  
> > All comments are appreciated, even if it is a simple
> one-liner saying
> > that you believe the draft is ready, or conversely, that it is not 
> > ready (and why).
> > 
> > As you review the draft, as part of your WGLC review,
> please identify
> > any issues that may exist in regard to compatibility with 
> > draft-ietf-cuss-uui (the mechanism draft).
> > 
> > Thank you.
> > 
> > [1] http://datatracker.ietf.org/doc/draft-ietf-cuss-sip-uui-isdn/
> > 
> > Vijay K. Gurbani and Enrico Marocco
> > _______________________________________________
> > cuss mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cuss
> > 
> > ______________________________________________________________
> > ___________________________________________________________
> > 
> > Ce message et ses pieces jointes peuvent contenir des informations 
> > confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message 
> > par erreur, veuillez le signaler a l'expediteur et le
> detruire ainsi
> > que les pieces jointes. Les messages electroniques etant
> susceptibles
> > d'alteration, Orange decline toute responsabilite si ce
> message a ete
> > altere, deforme ou falsifie. Merci.
> > 
> > This message and its attachments may contain confidential or 
> > privileged information that may be protected by law; they
> should not
> > be distributed, used or copied without authorisation.
> > If you have received this email in error, please notify the
> sender and
> > delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages
> that have
> > been modified, changed or falsified.
> > Thank you.
> > 
> > _______________________________________________
> > cuss mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/cuss
> > 
> 
> ______________________________________________________________
> ___________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.
> If you have received this email in error, please notify the sender and 
> delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have 
> been modified, changed or falsified.
> Thank you.
> 
> 
_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 14 Feb 2014 20:31:39 +0000

It is obviously difficult to identify what a non-conformant UAC will do, but in my view, if a UAC is set up to receive packages, then it should only respond to the packages it is sent up to receive. Thus it must either ignore the package name or ignore the entire UUI.

Regards

Keith 

> Sent: 27 January 2014 10:51
> To: [email-masked]
> Cc: DRAGE, Keith (Keith); [email-masked]
> Thank you for your answer, yes we can finalize these issues.
> Just for information, the proposal in 1/ was not to address 
> the case where UUS would start within an answer (as you said, 
> not possible), but to address the following case:
> a/ A conformant UAC sends in INVITE a UUI with "isdn-uui" 
> purpose parameter value b/ A non-conformant UAS receives it, 
> either it discards it (as suggested by Keith below) or it 
> accepts the UUI data regardless of the purpose parameter 
> value (behavior not really specified in 
> draft-johnston-sipping-cc-uui-09), let's suppose the latter 
> c/ The non-conformant UAS sends back in answer a UUI with 
> "isdn-interwork" purpose parameter value d/ The conformant 
> UAC will thus receive in answer a purpose parameter set to 
> "isdn-interwork"
> 
> Best regards
> 
> Celine Serrut-Valette
> Orange Labs
> 
> De : [email-masked] [mailto:[email-masked]] Envoyé 
> : vendredi 24 janvier 2014 17:45 À : 
> [email-masked]; SERRUT VALETTE Celine 
> IMT/OLN; [email-masked] Objet : AW: [cuss] WGLC for 
> Hello Celine,
> Hello Keith,
> Hopefully we can finalize these issues, and you are satisfied 
> with the arguments from Keith.
> I see the facts also as Keith it does.
> UUS in PSTN is started with a IAM (See Q.737.1) and the 
> backward direction is based on that "request".
> So UUS will never be started within an answer. Pls. see the 
> regarding itu-t specifications.
> So seen from this fact I would like to see the same behavior 
> within SIP. So I support the arguments from Keith.
> 
> Best Regards
> 
> Roland
> 
> -----Ursprüngliche Nachricht-----
> Von: cuss [mailto:[email-masked]] Im Auftrag von 
> DRAGE, Keith (Keith)
> Gesendet: Freitag, 24. Januar 2014 17:16
> An: [email-masked]; [email-masked]
> Betreff: Re: [cuss] WGLC for draft-ietf-cuss-sip-uui-isdn
> 
> See below - changes are made to my working version, which I 
> will submit in due course when this dialog is closed. 
> 
> Keith
> 
> A conformant UAC (i.e. according to this version of the id 
> package) generates "isdn-uui" as the purpose parameter as 
> part of the header field that invokes the service. A 
> non-conformant UAC will not have been implemented according 
> to this specification.
> 
> A non-conformant UAS receiving a "isdn-uui" purpose parameter 
> when it expects the "isdn-interwork" purpose parameter will 
> not understand it and therefore presumably will discard. The 
> only previous version that might respond is an implementation 
> that was implemented before the purpose parameter was 
> defined, which is going back a long way. The UAS cannot 
> invoke the service but can only respond to what it receives 
> from a conformant UAC.
> 
> Therefore I do not see how a conformant UAC can receive a 
> purpose parameter set to "isdn-interwork".
> 
> Difficult one this. For the non-inclusion, we have a "SHOULD" 
> on the sending to allow for earlier implementations that do 
> not understand the "purpose" header field parameter. On that 
> basis, reception of the UUI header field without a "purpose" 
> header field parameter should be permitted.
> 
> As regards the reception with a different header field 
> parameter value, this could well be destined for a different, 
> as yet undefined package.
> 
> Ce message et ses pieces jointes peuvent contenir des 
> informations confidentielles ou privilegiees et ne doivent 
> donc pas etre diffuses, exploites ou copies sans 
> autorisation. Si vous avez recu ce message par erreur, 
> veuillez le signaler a l'expediteur et le detruire ainsi que 
> les pieces jointes. Les messages electroniques etant 
> susceptibles d'alteration, Orange decline toute 
> responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> should not be distributed, used or copied without authorisation.
> sender and delete this message and its attachments.
> that have been modified, changed or falsified.
> Thank you.
> 
>