Subject: Re: [Dance] Implementation of DANCE and TLS Client Id extension

From: Shumon Huque <[email-masked]>
Date: Wed, 23 Mar 2022 09:17:33 -0400

Wow. Nice work.

Will you be attending the IETF113 DANCE working group session on Friday?

If so, I'm wondering if the chairs would be okay with putting an
implementation status item on the agenda?

And then you could give a brief update on your work. We have 2 hours set
aside, and I suspect plenty
of time available for additional agenda items.

Shumon.

On Wed, Mar 23, 2022 at 9:06 AM Gaël Berthaud-Muller <
[email-masked]> wrote:

> Hello,
>
> In the last weeks I have been working on a Golang implementation of DANCE
> to test the IoT (LoRaWan) use case.
> We finalised the proof of concept implementation during last weekend's
> Hackathon with now support for TLS1.3 and TLS1.2 as per
> [draft-huque-tls-dane-clientid-06] and [draft-huque-dane-client-cert-08].
> The work is based on Shumon's DANE library and the Golang 1.17 TLS library.
>
> Pointers to the repositories:
> * DANCE library, with code example: https://gitlab.rd.nic.fr/dance/dance
> * Fork of the DANE library: https://gitlab.rd.nic.fr/dance/dane
> * Fork of the TLS library: https://gitlab.rd.nic.fr/dance/tls
>
> It would be great to have feedback on this work and extra eyes to review
> the implementation.
>
> Regards,
>
> Gaël Berthaud-Müller
> R&D @ Afnic
>

---

From: Shumon Huque <[email-masked]>
Date: Wed, 23 Mar 2022 10:09:40 -0400

Thanks. And I'll try to find some time to review your implementation before
the meeting
(but if not, hopefully sometime soon after).

Shumon.

On Wed, Mar 23, 2022 at 9:58 AM Gaël Berthaud-Muller <
[email-masked]> wrote:

> Yes I will be there on Friday.
> Sure, I will be happy to give a brief update on the status of this work.
>
> Gaël
>
> ----- Mail original -----
> De: "shuque" <[email-masked]>
> À: "berthaud-muller" <[email-masked]>
> Cc: "dance" <[email-masked]>
> Envoyé: Mercredi 23 Mars 2022 14:17:33
> Objet: Re: Implementation of DANCE and TLS Client Id extension
>
> Wow. Nice work.
>