Subject: Re: [dane] simultaneous use cases (was: Starting WGLC on: draft-ietf-dane-use-cases-02)

From: =JeffH <[email-masked]>
Date: Fri, 13 May 2011 09:33:46 -0700

Jim Schaad mused..
 >
 > Is there a use case where Alice wants to do multiple of these operations at
 > the same time.  That is she wants to do both a CA constraint and a
 > Certificate constraint simultaneously?

this is a good question. Possibly.

Others have thoughts?

=JeffH

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 16 May 2011 09:46:19 -0400

> this is a good question. Possibly.

I had been imagining that these use cases would be "combinable".  The most obvious case that had occurred to me was where you would want to assert your own CA (3.3) and lock to that CA (3.1).

Do we need extra text to clarify this?  Maybe in the intro to Section 3?

--Richard

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 16 May 2011 14:02:19 -0700

I think that it might require some extra text.  There are two cases and they
need to be distinguished.  The first is the combinable case and the second
is the rollover case.  If you want to roll over from specifying the EE cert
to specifying a CA cert this is different than saying that both are to be
enforced.  At a minimum one needs to say that a combinable case exists.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Richard L. Barnes
> Sent: Monday, May 16, 2011 6:46 AM
> To: =JeffH
> Cc: IETF DANE WG list
> Subject: Re: [dane] simultaneous use cases (was: Starting WGLC on: draft-
> ietf-dane-use-cases-02)
> 
> > > Is there a use case where Alice wants to do multiple of these
> > > operations at the same time.  That is she wants to do both a CA
> > > constraint and a Certificate constraint simultaneously?
> >
> I had been imagining that these use cases would be "combinable".  The most
> obvious case that had occurred to me was where you would want to assert
> your own CA (3.3) and lock to that CA (3.1).
> 
> _______________________________________________
> dane mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dane