Subject: [dane] Remote DNS management automation?

From: William Stouder-Studenmund <[email-masked]>
Date: Mon, 22 Jun 2015 13:14:52 -0700

I know I’m about to ask a question which is out of the WG scope, but 1) I expect folks here will be able to point me to the right answers, and 2) the question hits on an issue that I perceive is hindering DANE deployment.

What automation is out there for remotely managing DNS records when the domain owner is using a registrar? I’m very excited by this (DANE) group’s work, but if I’m using a registrar, TLSA records only matter when they get to the registrar correctly.

I know TSIG can update records. Are most registrars using it? Also, how does one add or delete records?

Thanks!

Take care,

Bill

---

From: "John Levine" <[email-masked]>
Date: 22 Jun 2015 22:02:14 -0000

>What automation is out there for remotely managing DNS records when the domain owner is
>using a registrar?

It completely depends on the registrar and the registry.  Some provide
DNS service, some don't.  Some provide a complete API for managing
services, some only provide a web site, some still need to do some
updates (DS records notably) by manual support tickets.

For the large fraction of domains that use a DNS service other than
the one at the registrar, it also completely depends on who's
providing the DNS.

R's,
John