Subject: [dane] DANE / DNSSEC added to IETF 93 Hackathon - anyone else interested?

From: Dan York <[email-masked]>
Date: Fri, 12 Jun 2015 18:59:16 +0000

DANE WG participants,

Are any of you planning to be at the hackathon on the weekend before IETF 93 in Prague?  Allison Mankin and I decided to add "DANE / DNS Privacy / DNSSEC" to the Hackathon wiki (and to commit to being there):

https://www.ietf.org/registration/MeetingWiki/wiki/93hackathon

(More info:  http://www.ietf.org/hackathon/93-hackathon.html )

A couple of others have joined us as "champions" (which means you help introduce the topic and agree to work on it during the event).  If anyone else wants to join us as a "champion", we're certainly glad to add names.

Here's what we wrote in the wiki:
----
• DANE / DNS Privacy / DNSSEC
• Contribute to access of end-systems to new developments in DNS
• Protocols: DANE support for webmail, DNS-over-TLS (application uses), DNS-over-DTLS (stack and uses), TLSA client certs, client privacy election for EDNS client-subnet, getdns language bindings, etc.
• Tools: portable tool for creating and adding DANE RR’s to zones, changes to existing tools to support new crypto algorithms, etc.
• Measurement: New tools or sites for measuring DNSSEC or DANE deployment
• Available open source libraries: https://github.com/verisign/smaug, https://github.com/getdnsapi
• Available environment, support, and diagnostic tools: https://dnssec-tools.org, https://www.opendnssec.org
• Champions
• Dan York, Internet Society [email-masked]<mailto:[email-masked]>
• Allison Mankin, Verisign Labs [email-masked]<mailto:[email-masked]>
• Willem Toorop, NLnet Labs
• Sara Dickinson, Sinodun
• Others, TBA
----

In a hackathon like this, a small team of people agrees to work on (ideally!) a clearly-defined project that can, in theory, be completed in two days and is something that the judges and others might find interesting and useful.  There can be several different teams under this topic working on different projects.  Sunday afternoon at 3pm the teams are supposed to stop and come up with a presentation. Those are given at 4pm and awards are given at 5pm.

You don't have to be there ALL the time (I suspect some people will leave Sunday morning for the IEPG meeting), but obviously the more time you can be there the better.

Lunch and dinner are provided. It's free... but limited to the first 100 attendees.  (Currently at 63 - https://www.ietf.org/registration/ietf93/hackathonattendance.py?sortkey=3&login=%0A<https://www.ietf.org/registration/ietf93/hackathonattendance.py?sortkey=3&login=> )

PLEASE JOIN US!  The more DANE/DNSSEC folks that are there, the more work we can do!

Registration is at: https://www.ietf.org/registration/ietf93/hackathonregistration.py

If you can't join us (or hackathons are just not your thing), please do feel free to SEND IDEAS!

If there's a tool you wish was out there for DANE/DNSSEC/DNS Privacy ... or a service or something... or an existing tool you wish supported DNSSEC or DANE... please let Allison and I know (or just send it back to this list).

I look forward to seeing some of you there!
Dan

P.S. Extra bonus points if the suggestion somehow involves a humorous side...

--
Dan York
Senior Content Strategist, Internet Society
[email-masked]<mailto:[email-masked]>   +1-802-735-1624
Jabber: [email-masked]<mailto:[email-masked]>
Skype: danyork   http://twitter.com/danyork

http://www.internetsociety.org/<http://www.internetsociety.org/deploy360/>

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 12 Jun 2015 21:00:06 +0000

On Fri, Jun 12, 2015 at 06:59:16PM +0000, Dan York wrote:

> In a hackathon like this, a small team of people agrees to work on
> (ideally!) a clearly-defined project that can, in theory, be completed in
> two days and is something that the judges and others might find interesting
> and useful.  There can be several different teams under this topic working
> on different projects.  Sunday afternoon at 3pm the teams are supposed to
> stop and come up with a presentation. Those are given at 4pm and awards
> are given at 5pm.

I am concerned that this sends the message that a trustworthy DANE
implementation is something one can quickly slap together in a very
short time.  This is not true, and the vast majority of implementations
that make this assumption are deeply flawed.

So while I'm all for DANE adoption, I am rather ambivalent about
hackathons at this stage of the game if the output is intended to
implement a trustworthy verifier.

If the project just builds ancilliary tools (for managing zones
and the like) then I am less concerned.

I would very much like to not see yet another non-working DANE
validator on Github, ...

-- 
	Viktor.