Subject: [dane] SMIMEA draft review (was: Deferal of SMIME Draft)

From: "Mankin, Allison" <[email-masked]>
Date: Sun, 19 Jul 2015 11:01:03 +0000

I’ve done a careful read of draft-ietf-dane-smime-08.  I find it to be in very good shape, and on track for publication as an Experimental.

My review surfaced a few minor points, easy to address:

- The NOTE FOR FUTURE DRAFTS was added about a year ago (in the 05 version) and in my view, the WG 
  has in the intervening year fulfilled the request of the note, to discuss all the diverse types of usage of DANE.

- I support modifying the draft to follow OPENPGPKEY on the LHS as the working group has discussed.  Supporting this point, my colleagues implemented the 08 draft exactly as it is
  in our proof of concept DANE provisioning tool [1] and then updated the PoC for this IETF with truncated SHA256. I’d love to see this settle down so that we can support tests and
  experiments with SMIMEA.  Correspondingly, I’d be glad to see the SMIMEA RR assigned.  Currently the PoC uses a number from the Private Use space.

- In addition to matching the approach of OPENPGPKEY on the LHS, it would make sense for this draft to match the other draft's language on the subject of response length.
  I’d like to see the SMIME draft adopt the Security Considerations text about response size from the OPENPGPKEY draft.

Thanks!

Allison

[1] DANE provisioning portal proof of concept:  https://www.dane-provisioning.verisignlabs.com/

---

From: Olafur Gudmundsson <[email-masked]>
Date: Mon, 20 Jul 2015 05:23:21 -0400

> On Jul 19, 2015, at 7:01 AM, Mankin, Allison <[email-masked]> wrote:
> 

Thank you for this review, much appreciated, as chair I encourage others to take few minutes to read and review the document. 

>  has in the intervening year fulfilled the request of the note, to discuss all the diverse types of usage of DANE.

This is for editors to address. 
>  experiments with SMIMEA.  Correspondingly, I’d be glad to see the SMIMEA RR assigned.  Currently the PoC uses a number from the Private Use space.

Getting the code assigned is a simple formality of filing a request as specified in http://tools.ietf.org/html/rfc6895 <http://tools.ietf.org/html/rfc6895> 
appendix A. 

>  I’d like to see the SMIME draft adopt the Security Considerations text about response size from the OPENPGPKEY draft.

In my mind the question is rather than repeat the text how about just reference the text explicitly, same goes for the use of LHS is there need to repeat the definition or is 
should explicit reference be used. 

> Allison

Thank you again for the review, and running code. 

Olafur

---

From: Shumon Huque <[email-masked]>
Date: Mon, 20 Jul 2015 11:34:42 +0200

On Mon, Jul 20, 2015 at 11:23 AM, Olafur Gudmundsson <[email-masked]> wrote:

> I’ve done a careful read of draft-ietf-dane-smime-08.  I find it to be in
> very good shape, and on track for publication as an Experimental.
>
>
> Thank you for this review, much appreciated, as chair I encourage others
> to take few minutes to read and review the document.
>
>
I have also read this draft, and support a plan to continue work on it with
the goal of publishing it as experimental.

Shumon Huque

---

From: Paul Wouters <[email-masked]>
Date: Mon, 20 Jul 2015 06:21:50 -0400 (EDT)

> should explicit reference be used. 

The text is small enough to copy. It is a single small paragraph. Please
copy so both texts can be read and implemented without needing to cross
reference.

Paul