Subject: [dane] Is there some activity for Pointer-to-Server

From: Christian Rößner <[email-masked]>
Date: Wed, 11 Nov 2015 09:05:29 +0100

Hi,

I had written the reference implementation for SMIMA experimental draft. So far that one works very will. I know, one very important discussion was about the local part, which became SHA256/trunc at the moment.

I am also interested about the other path doing the lookup over a pointer to server variant.

If I remember correctly, someone posted a draft for such a mechanism. Something similar to:

_smime.whatever.domain.tld. IN FOO ...https://some.lookup.server.for.smime

Even the same for OpenPGP

I can't remember much more. And even did not find things in my mail archive. So: Are there plans on working on such a draft? Especially the protocol for the https-server? I am very much interested in implementing a proof-of-concept in the current milter that uses SMIMEA already. So developing such a draft could go hand in hand with theory and practice.

Kind regards

Christian

---

From: "John R Levine" <[email-masked]>
Date: 14 Nov 2015 16:40:19 -0500

> _smime.whatever.domain.tld. IN FOO ...https://some.lookup.server.for.smime

That was me.  See draft-levine-dns-mailbox-01, section 6.

Also see  draft-moore-email-addrquery-01 which discusses a method for 
publishing per-address info such as keys using an SMTP extension.  I think 
that's more likely to make progress.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail.

---

From: Peter Gutmann <[email-masked]>
Date: Sun, 15 Nov 2015 07:02:17 +0000

>that's more likely to make progress.

Or you could use RFC 4387, which has been a standards-track RFC for nearly a
decade.

Peter.