Subject: [dane] [Technical Errata Reported] RFC7929 (4796)

From: RFC Errata System <[email-masked]>
Date: Thu, 8 Sep 2016 01:20:56 -0700 (PDT)

The following errata report has been submitted for RFC7929,
"DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGP".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7929&eid=4796

--------------------------------------
Type: Technical
Reported by: Daniel Kahn Gillmor <[email-masked]>

Section: 3

Original Text
-------------
   6.  The domain name (the "right-hand side" of the email address,
       called the "domain" in [RFC5322]) is appended to the result of
       step 2 to complete the prepared domain name.

Corrected Text
--------------
   6.  The domain name (the "right-hand side" of the email address,
       called the "domain" in [RFC5322]) is appended to the result of
       step 5 to complete the prepared domain name.

Notes
-----
Technically, it should be step 5, not step 2: after step 2, there is no _openpgpkey label in the composed domain name.  step 5 adds the _openpgpkey label.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7929 (draft-ietf-dane-openpgpkey-12)
--------------------------------------
Title               : DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGP
Publication Date    : August 2016
Author(s)           : P. Wouters
Category            : EXPERIMENTAL
Source              : DNS-based Authentication of Named Entities
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Wouters <[email-masked]>
Date: Thu, 8 Sep 2016 09:21:07 -0400

> "DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGP".

This errata is correct. The original text did not have the intermediary steps listed as such, and no one spotted referenced number when the numbering changed :(

Paul