Subject: [decade] Open Issue-2 （draft "An HTTP-based DECADE Resource Protocol"）.

From: Wangdanhua <[email-masked]>
Date: Wed, 5 Sep 2012 08:49:33 +0000

Hi all,

The following is another open issue left for “An HTTP-based DECADE Resource Protocol” (draft-wang-drp). We’re looking forward to your opinions and comments.

Since IETF 83rd in Pairs, we received a lot of comments on the defining of “REMOTE_GET_Object Message” from WG as well as mailing list discussion. The main idea includes 1) not introduce new HTTP headers, let alone new message types; 2) leverage the base functionality of a “non-transparent proxy” in DECADE, local DECADE Server to act as a non-transparent proxy when processing a request from a DECADE Client. We adopted WG’s suggestion and already updated the draft (see “Section 8. Remote_Get_Object Message” in the draft). We need more review and comments to see whether we could make further effort.

Thanks!

Best wishes,
Danhua

---

From: Songhaibin <[email-masked]>
Date: Mon, 10 Sep 2012 07:19:02 +0000

Hi Danhua,

That’s a good point. I feel that’s the consensus in the mailing list.

-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Wangdanhua
Sent: Wednesday, September 05, 2012 4:50 PM
To: [email-masked]
Subject: [decade] Open Issue-2 （draft "An HTTP-based DECADE Resource Protocol"）.

Hi all,

Thanks!

Best wishes,
Danhua

---

From: Hongqiang Harry Liu <[email-masked]>
Date: Wed, 12 Sep 2012 10:10:34 -0400

Hi Danhua

I am wondering whether we need to add corresponding HTTP proxy headers
in the REMOTE_GET_Object case.
For example: Via, Proxy-Authorization.

Of course we can use OAuth to replace Proxy-Authorization.
In next version, Section 8 needs more details on message flows.

Thank you very much

Harry

On 09/05/2012 04:49 AM, Wangdanhua wrote:
>
> Hi all,
>
> The following is another open issue left for “An HTTP-based DECADE
> Resource Protocol” (draft-wang-drp). We’re looking forward to your
> opinions and comments.
>
> Since IETF 83^rd in Pairs, we received a lot of comments on the
> defining of “REMOTE_GET_Object Message” from WG as well as mailing
> list discussion. The main idea includes 1) not introduce new HTTP
> headers, let alone new message types; 2) leverage the base
> functionality of a “non-transparent proxy” in DECADE, local DECADE
> Server to act as a non-transparent proxy when processing a request
> from a DECADE Client. We adopted WG’s suggestion and already updated
> the draft (see “Section 8. Remote_Get_Object Message” in the draft).
> We need more review and comments to see whether we could make further
> effort.
>
> Thanks!
>
> Best wishes,
>
> Danhua
>