Subject: [decade] Open Issue-3 (draft "An HTTP-based DECADE Resource Protocol")

From: Wangdanhua <[email-masked]>
Date: Wed, 12 Sep 2012 06:13:24 +0000

Hi all,

The following is the third open issue left for "An HTTP-based DECADE Resource Protocol" (draft-wang-drp). We're looking forward to your opinions and comments.

About the object naming scheme used in DECADE Protocol, we're inclined to adopting the naming scheme proposed in the draft-farrell-decade-ni (Naming Things with Hashes). We thought it's a good scheme and we are planning to have a try and see whether it's workable in the protocol we proposed.

Does anybody have other opinions? And we'd like to hear your voice.

Best wishes,
Danhua Wang

---

From: Zongning <[email-masked]>
Date: Wed, 12 Sep 2012 06:47:38 +0000

Hi, Danhua,

I support adopting the naming scheme proposed in draft-farrell-decede-ni as well.
Thanks.

-Ning

From: [email-masked] [mailto:[email-masked]] On Behalf Of Wangdanhua
Sent: Wednesday, September 12, 2012 2:13 PM
To: [email-masked]
Subject: [decade] Open Issue-3 (draft "An HTTP-based DECADE Resource Protocol")

Hi all,

Best wishes,
Danhua Wang

---

From: Hongqiang Harry Liu <[email-masked]>
Date: Wed, 12 Sep 2012 10:11:40 -0400

Hi Danhua

It sounds good to me.

Harry
On 09/12/2012 02:13 AM, Wangdanhua wrote:
>
> Hi all,
>
> The following is the third open issue left for "An HTTP-based DECADE 
> Resource Protocol" (draft-wang-drp). We're looking forward to your 
> opinions and comments.
>
> About the object naming scheme used in DECADE Protocol, we're inclined 
> to adopting the naming scheme proposed in the draft-farrell-decade-ni 
> (Naming Things with Hashes). We thought it's a good scheme and we are 
> planning to have a try and see whether it's workable in the protocol 
> we proposed.
>

---

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 12 Sep 2012 10:31:06 -0400

Hi Danhua,

Yes, I agree that to make progress on your draft you need to show how to
use a naming scheme as part of your proposal.  And I also agree that
using the draft-farrell-decade-ni should be the starting point.

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Wangdanhua
Sent: Wednesday, September 12, 2012 2:13 AM
To: [email-masked]
Subject: [decade] Open Issue-3 (draft "An HTTP-based DECADE
ResourceProtocol")

Hi all,

About the object naming scheme used in DECADE Protocol, we're inclined
to adopting the naming scheme proposed in the draft-farrell-decade-ni
(Naming Things with Hashes). We thought it's a good scheme and we are
planning to have a try and see whether it's workable in the protocol we
proposed.

Best wishes,

Danhua Wang

---

From: Songhaibin <[email-masked]>
Date: Mon, 17 Sep 2012 09:42:47 +0000

While many people advocate Hashed names, the key point is, shall we allow conflict for the names? If we do not allow, how to solve it.

BR,
-Haibin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Wednesday, September 12, 2012 10:31 PM
To: Wangdanhua
Cc: [email-masked]
Subject: Re: [decade] Open Issue-3 (draft "An HTTP-based DECADE ResourceProtocol")

Hi Danhua,

Yes, I agree that to make progress on your draft you need to show how to use a naming scheme as part of your proposal.  And I also agree that using the draft-farrell-decade-ni should be the starting point.

Sincerely,

Akbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Wangdanhua
Sent: Wednesday, September 12, 2012 2:13 AM
To: [email-masked]
Subject: [decade] Open Issue-3 (draft "An HTTP-based DECADE ResourceProtocol")

Hi all,

Best wishes,
Danhua Wang

---

From: Peng Zhang <[email-masked]>
Date: Tue, 18 Sep 2012 14:09:33 +0800

Hi Haibin,

	I don't quite understand your question. If we are using SHA-256, as suggested in draft-farrell-decade-ni, the probability that two different objects have the same name would be very low. 

BR,

Peng.

On Sep 17, 2012, at 5:42 PM, Songhaibin wrote:

> The following is the third open issue left for “An HTTP-based DECADE Resource Protocol” (draft-wang-drp). We’re looking forward to your opinions and comments.
>  
> About the object naming scheme used in DECADE Protocol, we’re inclined to adopting the naming scheme proposed in the draft-farrell-decade-ni (Naming Things with Hashes). We thought it’s a good scheme and we are planning to have a try and see whether it’s workable in the protocol we proposed.
>  
> Does anybody have other opinions? And we’d like to hear your voice.
>  
> Best wishes,
> Danhua Wang
>

---

From: Songhaibin <[email-masked]>
Date: Tue, 18 Sep 2012 07:08:42 +0000

Hi Peng,

"Low" does not mean no existence. I'm wondering if two different objects are happened to have the same name at the same DECADE server, or at different DECADE servers with different service providers (we require the name to be global unique), we should have a collision avoidance mechanism for it.

-Haibin

From: Peng Zhang [mailto:[email-masked]]
Sent: Tuesday, September 18, 2012 2:10 PM
To: Songhaibin
Cc: Rahman, Akbar; Wangdanhua; [email-masked]
Subject: Re: [decade] Open Issue-3 (draft "An HTTP-based DECADE ResourceProtocol")

Hi Haibin,

BR,

Peng.

BR,
-Haibin

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Wednesday, September 12, 2012 10:31 PM
To: Wangdanhua
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [decade] Open Issue-3 (draft "An HTTP-based DECADE ResourceProtocol")

Hi Danhua,

Sincerely,

Akbar

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Wangdanhua
Sent: Wednesday, September 12, 2012 2:13 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [decade] Open Issue-3 (draft "An HTTP-based DECADE ResourceProtocol")

Hi all,

Best wishes,
Danhua Wang

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Sep 2012 09:34:00 +0100

> "Low" does not mean no existence. I'm wondering if two different objects are happened to have the same name at the same DECADE server, or at different DECADE servers with different service provider…

The existence of SHA256 collisions would be news that would make
CNN and BBC probably (after they picked it up from /.:-). In
this case "low" is practically the same as non-existent if you
use all the bits of SHA256.

S.

---

From: Peng Zhang <[email-masked]>
Date: Tue, 18 Sep 2012 16:48:08 +0800

Exactly, the probability would be negligible. Even if we use the trunked hash, say 32 bit, it would suffice too.

BR,

Peng.

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Sep 2012 09:57:53 +0100

> Exactly, the probability would be negligible. Even if we use the trunked hash, say 32 bit, it would suffice too.

Not sure about that. For collisions you need to think about the
birthday problem, so a 32 bit hash may mean a 2^-16 collision
probability which is probably too high in many cases.

Either don't truncate at all or think deeply about it first is
the right approach I'd say.

S.