Subject: [decade] Open Issue-4 (draft "An HTTP-based DECADE ResourceProtocol")

From: Wangdanhua <[email-masked]>
Date: Thu, 20 Sep 2012 09:08:30 +0000

Hi all,

The following is the forth open issue left for "An HTTP-based DECADE Resource Protocol" (draft-wang-drp).

As to SDT, we'd like to support both push mode and pull mode while DECADE Client gets data object from its DECADE Server. If so, subscription mode has to be introduced
in DECADE.

Do you think it's necessary to include both these two modes or just pull mode is enough? We're looking forward to your opinions and comments.

Thanks!

Best wishes,
Danhua

---

From: zhangyunfei <[email-masked]>
Date: Thu, 20 Sep 2012 17:33:55 +0800

Hi Danhua,
   Could you elaborate your imagination on the use case of the push mode SDT? For me it seems okay to use push mode  for publish/subscribe apps, e.g., the DECADE server, on behalf of DECADE client, subscribes a magazine and only notifies the DECADE client in case of good network condition.

BR
Yunfei

zhangyunfei

From: Wangdanhua
Date: 2012-09-20 17:08
To: [email-masked]
Subject: [decade] Open Issue-4 (draft "An HTTP-based DECADE ResourceProtocol")
Hi all,
 
The following is the forth open issue left for “An HTTP-based DECADE Resource Protocol” (draft-wang-drp). 
 
As to SDT, we’d like to support both push mode and pull mode while DECADE Client gets data object from its DECADE Server. If so, subscription mode has to be introduced
in DECADE. 
 
Do you think it’s necessary to include both these two modes or just pull mode is enough? We’re looking forward to your opinions and comments.
 
Thanks!
 
Best wishes,
Danhua

---

From: Wangdanhua <[email-masked]>
Date: Sat, 22 Sep 2012 09:27:38 +0000

Hi Yunfei,

In my mind, there’re many scenarios that may need push mode/subscription mode, e.g., a customer may just be interested in news or videos on sports and be willing to pay a subscription price to have access to such services. In this kind of scenario, once there’re latest sports news/videos, the customer will be notified and those news/videos will be pushed to the customer.

Best wishes,
Danhua Wang

发件人: zhangyunfei [mailto:[email-masked]]
发送时间: 2012年9月20日 17:34
收件人: Wangdanhua; decade
主题: Re: [decade] Open Issue-4 (draft "An HTTP-based DECADE ResourceProtocol")

Hi Danhua,

BR
Yunfei

________________________________
zhangyunfei

From: Wangdanhua<mailto:[email-masked]>
Date: 2012-09-20 17:08
To: [email-masked]<mailto:[email-masked]>
Subject: [decade] Open Issue-4 (draft "An HTTP-based DECADE ResourceProtocol")
Hi all,

Thanks!

Best wishes,
Danhua