Subject: [Detnet] The road to DetNet

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 9 Apr 2015 08:57:55 +0000

Dear all:

As Jouni pointed out, we have little time to make a compelling case for DetNet. The cutoff forreuesting the BoF is June 5th, but a last minute burst of activity is no great sign for the IESG.

What we have in good state (see my post about the charter today):
- documents (4 major WIP) 
	https://tools.ietf.org/html/draft-finn-detnet-architecture  
	https://tools.ietf.org/html/draft-finn-detnet-problem-statement 
	https://tools.ietf.org/html/draft-gunther-detnet-proaudio-req 
	https://tools.ietf.org/html/draft-wetterwald-detnet-utilities-reqs 
- references (6TiSCH architecture clearly indicates DetNet dependencies, IEEE coordination provides information that Layer2-independent work is needed in the industry)
	https://tools.ietf.org/html/draft-ietf-6tisch-architecture  
	https://tools.ietf.org/html/draft-wang-6tisch-track-use-cases 
- a draft charter

What we seem to be missing:

- an improved gap analysis. Ted Lemon indicated at the BoF that this gap analysis would be crucial to figure if and which work would be needed from the IETF. From the early work on gap analysis, it seems that there is work that has no home, like the overall architecture and coordination, and a number of items that would have a home in different places, including at least PCE, CCAMP, TEAS, MPLS and TSVWG. We must refine this gap analysis and clarify the dependencies.

- an evaluation of the amount of work. Lou indicated that CCAMP has already hosted work in the past. The amount of work would be an indication if DetNet can simply be hosted in an existing WG or should be its own WG. If the proposed charter is any indication, there is a lot that must be done before we are ready to ask for a specification from the groups mentioned above. 

- an industrial automation requirements draft. We have a number of great potential authors, but no one published DetNet work to date. One suggestion could be to use http://tools.ietf.org/html/draft-ietf-roll-rpl-industrial-applicability as a starting point and elaborate on the deterministic flows. Another would be that an external group such as ISA100 publishes its requirements in its own terms and formats, and then we write a short draft that references it. 

- activity on this mailing list. We need reviews and discussions on the drafts and the charter. We need inputs for the gap analysis, considering the scope of the existing WGs versus the work detailed in the charter. We need to demonstrate that we have an active team that is ready to execute on the commitment that we all would take with the IESG by forming a WG. 

- other?

Please indicate if you are willing to contribute to any of the items above and fire discussions at will!

Cheers;

Pascal

---

From: Lou Berger <[email-masked]>
Date: Thu, 09 Apr 2015 06:13:42 -0400

Pascal,

    It looks to me that a portion of this work is already covered by
existing WGs (as you note) ,  but there is also an import portion that
is not.  In particular, how the L2/IEEE defined data plane is carried
across routers. (Encapsulation vs translation, MPLS, IPv4, IPv6 , who
does what, etc.) It seems to me that there isn't a clear WG for such
work (although perhaps PALs) and this and overall solution architecture
should be the focus of the proposed new effort (at least initially).  Of
course this group would also need to provide requirements to, and
collaborate with the the existing control/management plane WGs to
deliver the full solution.

Lou