Subject: Re: [Detnet] DetNet Use Case Statements - 6TiSCH - One-Shot vs Update of paths

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 5 May 2016 00:30:04 +0000

Statement:
6TiCH use case: One-Shot vs Update of paths
Discussion:
The relevant text in the draft is as follows, but some of the material was discussed offline.

"If it appears that a path through the network does not perform as expected, a protocol may be used to update the state in the devices, but in 6TiSCH that flow was not designed and no protocol was selected and it is expected that DetNet will determine the appropriate end-to-end protocols to be used in that case."

So there is a distinction between a protocol that can propagate all path information to the network at once ("one-shot") and one that is also capable of subsequently propagating individual path updates, for example to work around a malfunctioning path or device. It would seem to me that this would be a necessity - am I missing anything or is this clearly within scope for DetNet?

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 5 May 2016 14:55:55 +0000

Hello Ethan:

I do believe it belongs.

I n a TDM / time-triggered domain, if all flows are known in advance, it is possible to program the device in terms of schedule, as actions indexed by time. The notion of track is secondary.

If flows are added and removed individually then they need to be a primary key and we design a different data model.

Regards,

Pascal

Le 5 mai 2016 à 02:30, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> a écrit :

Statement:

“If it appears that a path through the network does not perform as expected, a protocol may be used to update the state in the devices, but in 6TiSCH that flow was not designed and no protocol was selected and it is expected that DetNet will determine the appropriate end-to-end protocols to be used in that case.”

So there is a distinction between a protocol that can propagate all path information to the network at once (“one-shot”) and one that is also capable of subsequently propagating individual path updates, for example to work around a malfunctioning path or device. It would seem to me that this would be a necessity – am I missing anything or is this clearly within scope for DetNet?