Subject: [Detnet] DetNet Use Case Statements - Delay accuracy +/-8ns

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 3 Jun 2016 20:04:38 +0000

Statement:
Delay accuracy +/-8ns (jitter?)

Text from (Cellular Radio) Use Case:
      Delay Accuracy: +-8ns (i.e. +-1/32 Tc, where Tc is the UMTS Chip time of 1/3.84 MHz) resulting in a round trip accuracy of                                 +-16ns. The value is this low to meet the 3GPP Timing Alignment Error (TAE) measurement requirements.

Discussion:
 Jouni replied via email that yes this is a "jitter" value.
The reason I am bringing it up is that 8ns appears to me to be a very small time value compared to other time values that we have been discussing, i.e. mostly in the millisecond range. Is there anything in DetNet architecture that affects anything at this fine of a degree of timing? In other words, does this need to be considered in (or guaranteed by) DetNet, and if not, should this statement be dropped from the use case?

---

From: Jouni Korhonen <[email-masked]>
Date: Fri, 3 Jun 2016 13:13:06 -0700

I practice one would have a jitter buffer at the 'listener' to buffer the
jitter away and relax the requirement a quite bit. I have no good idea now
how to put this into a use case text.. but I would argue against dropping
the entire use case if it happens to have ugly numbers on paper.

- Jouni

On Fri, Jun 3, 2016 at 1:04 PM, Grossman, Ethan A. <[email-masked]> wrote:

> Delay Accuracy: +-8ns (i.e. +-1/32 Tc, where Tc is the UMTS Chip time of
> 1/3.84 MHz) resulting in a round trip accuracy
> of                                 +-16ns. The value is this low to meet
> the 3GPP Timing Alignment Error (TAE) measurement requirements.
>
> Discussion:
>  Jouni replied via email that yes this is a “jitter” value.
> The reason I am bringing it up is that 8ns appears to me to be a very
> small time value compared to other time values that we have been
> discussing, i.e. mostly in the millisecond range. Is there anything in
> DetNet architecture that affects anything at this fine of a degree of
> timing? In other words, does this need to be considered in (or guaranteed
> by) DetNet, and if not, should this statement be dropped from the use case?
>
>
>
>
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>
>

-- 
Jouni Korhonen, Broadcom Ltd.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Fri, 3 Jun 2016 20:22:01 +0000

Thanks Jouni, and I’m not suggesting the whole use case be dropped, I’m saying that I would like the use case to be clear that if this kind of timing requirement exists that it needs to be dealt with by the implementation, for example using buffering as you are describing. Again my point here is to make sure that anything that needs to be considered by DetNet architecture is considered, and those things that don’t directly affect DetNet architecture or implementation be duly noted as such if they are deemed to be really important to the use case, or qualified or dropped entirely if they are not deemed really important to the use case.
But I think you have answered the question, which is that we’d like to keep the number but add a qualifying statement that in an implementation, buffering in the hardware (or lower level software) would be expected to be used to mitigate such fine timing requirements, and thus they are not expected to be addressed or guaranteed directly by DetNet.  Right?
Thanks,
Ethan.
From: Jouni Korhonen [mailto:[email-masked]]
Sent: Friday, June 03, 2016 1:13 PM
To: Grossman, Ethan A.
Cc: [email-masked]
Subject: Re: [Detnet] DetNet Use Case Statements - Delay accuracy +/-8ns

I practice one would have a jitter buffer at the 'listener' to buffer the jitter away and relax the requirement a quite bit. I have no good idea now how to put this into a use case text.. but I would argue against dropping the entire use case if it happens to have ugly numbers on paper.

- Jouni

On Fri, Jun 3, 2016 at 1:04 PM, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> wrote:
Statement:
Delay accuracy +/-8ns (jitter?)

Discussion:

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=CwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=A4hRbrXQc-351q7xsGtFPoHJFJ-D6Y_AJbgn4Id8xhc&s=G-j8pOlbB9U0ygTiCf6ePi33aAz71j5uzb5Vv0TP0L4&e=>

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 7 Jun 2016 13:24:50 -0700

Hi Ethan,

6/3/2016, 1:22 PM, Grossman, Ethan A. kirjoitti:
> Thanks Jouni, and I’m not suggesting the whole use case be dropped, I’m
> saying that I would like the use case to be clear that if this kind of
> timing requirement exists that it needs to be dealt with by the
> implementation, for example using buffering as you are describing. Again
> my point here is to make sure that anything that needs to be considered
> by DetNet architecture is considered, and those things that don’t
> directly affect DetNet architecture or implementation be duly noted as
> such if they are deemed to be really important to the use case, or
> qualified or dropped entirely if they are not deemed really important to
> the use case.
>
> But I think you have answered the question, which is that we’d like to
> keep the number but add a qualifying statement that in an
> implementation, buffering in the hardware (or lower level software)
> would be expected to be used to mitigate such fine timing requirements,
> and thus they are not expected to be addressed or guaranteed directly by
> DetNet.  Right?

Right. I could agree with that.

- Jouni

>
> Thanks,
>
> Ethan.
>
> *From:*Jouni Korhonen [mailto:[email-masked]]
> *Sent:* Friday, June 03, 2016 1:13 PM
> *To:* Grossman, Ethan A.
> *Cc:* [email-masked]
> *Subject:* Re: [Detnet] DetNet Use Case Statements - Delay accuracy +/-8ns
>
>
>
> I practice one would have a jitter buffer at the 'listener' to buffer
> the jitter away and relax the requirement a quite bit. I have no good
> idea now how to put this into a use case text.. but I would argue
> against dropping the entire use case if it happens to have ugly numbers
> on paper.
>
>
>
> - Jouni
>
>
>
> Delay Accuracy:+-8ns (i.e. +-1/32 Tc, where Tc is the UMTS Chip time of
> timing? In other words, does this need to be considered in (or
> guaranteed by) DetNet, and if not, should this statement be dropped from
> the use case?
>
>
>
>
>
>
>
>
>
>
>
>
> [email-masked] <mailto:[email-masked]>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=CwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=A4hRbrXQc-351q7xsGtFPoHJFJ-D6Y_AJbgn4Id8xhc&s=G-j8pOlbB9U0ygTiCf6ePi33aAz71j5uzb5Vv0TP0L4&e=>
>
>
>
>
>
> --
>