Subject: [Detnet] Help wanted in detnet

From: John Dowdell <[email-masked]>
Date: Tue, 15 Nov 2016 14:32:27 +0900

Hi all in mpls and teas groups (consolidating earlier posting only on mpls)

Over in detnet wg we are working on transporting deterministic Ethernet (e.g. from 802.1TSN LANs) across the wide area for applications such as industrial control and audio/video broadcast. One of the key assumptions is that the underlying transport already has sufficient scheduling and queueing support to allow proper extension of time-sensitive (or even time-critical) traffic over, for example, MPLS.

To help us validate that assumption, please can someone volunteer to help us? Feel free to come over to the detnet list. Recommendations on exactly which flavour(s) of MPLS and/or configurations and/or gotchas would be most welcome.

The slides in question are here https://www.ietf.org/proceedings/97/slides/slides-97-detnet-detnet-data-plane-02.pptx <https://www.ietf.org/proceedings/97/slides/slides-97-detnet-detnet-data-plane-02.pptx>, slide 4.

Many thanks in anticipation.

John

---

From: Umut Keten <[email-masked]>
Date: Tue, 15 Nov 2016 05:53:20 +0000

John hi,

To transport the below I wouldn't rely too much on mpls. jitter/pdv is devastating on mpls and ntp is not precise enough (1588v2 is not good enough).

To overcome this I build a DTM cloud over mpls and also do the rsvp-te equivalant (dip-te) over this DTM cloud.

99,999% QoS and 100% bw guarantee.
I can carry clock synchronisation(fase + frequence) 22 hops over mpls below 100ns.

I would advise to leave MPLS for what it is and to use DTM over MPLS for such data.

Krgrds,
Umut

Samsung Galaxy akıllı telefonumdan gönderildi.

[tt_logo_]

Umut Keten

Ürün ve Servis Kıdemli Mimarı
Ürün ve Servis Sunumu Direktörlüğü
Teknoloji Genel Müdür Yardımcılığı

[email-masked]

03125551931
+90 (553) 349 96 69

<http://www.tivibuspor.com.tr/>

Yasal Uyarı :
Bu elektronik posta işbu linki kullanarak ulaşabileceğiniz Koşul ve Şartlar dökümanına tabidir :
www.turktelekom.com.tr/tt/portal/email-yasal-uyari<http://www.turktelekom.com.tr/tt/portal/email-yasal-uyari>

-------- Orijinal mesaj --------
Başlangıç tarihi: John Dowdell <[email-masked]>
Tarih: 15.11.2016 08:33 (GMT+03:00)
Alıcı: [email-masked], [email-masked], [email-masked]
Konu: [DKIM - Gonderici Dogrulama Sorunu] [mpls] Help wanted in detnet

The slides in question are here https://www.ietf.org/proceedings/97/slides/slides-97-detnet-detnet-data-plane-02.pptx, slide 4.

John

---

From: Umut Keten <[email-masked]>
Date: Tue, 15 Nov 2016 06:26:54 +0000

Hereby I am adding some topologies to show what we did at Turk Telekom:

>From A to B with RSVP-TE in MPLS you need to traffic engineer all the hops in between. The problem is that the MPLS network is always dynamic, no matter how much you plan, data from other services and the load of that data will cause jitter/pdv and in some scenarios even packetdrops. You will never be able to guarantee sensitive data such as contribution media or time sensitive data.

Please see Picture 1 (Şekil 1)

To overcome this we created another layer above MPLS (Picture 2/ Şekil 2)

Now from A to B it uses DTM (please see wiki or other sources for DTM details) which is transmission based and the data can be transported 1+1 hitless or dynamic protected (50ms)
The protection path we have automated, SPF algortithm with colour based region tagging so the secondary path automatically builds making sure that a totally different route is used. (son o more RSVP-TE hustle)

Due to the fact that DTM is transmission based there are no spikes in data and the reserved BW is always the same(CBR), from A to B there will be a jitterles data transfer due to FEC (Forwarding Equilavant Class) on MPLS and minimum sampling algorithm of DTM.

100% QoS and BW was achieved for a 1 week stress test. During this week scheduled maintenances where performed in Trabzon and Adana on transmission layer and MPLS layer. There was impact on the MPLS and Transmission layer but no impact on the transported data on the DTM layer.

We are planning to use this DTM layer for LTE Broadcast and possibly also DVB-T2 transport in the future.

Krgrds,
Umut

[tt_logo_]

Umut Keten

03125551931
+90 (553) 349 96 69

Yasal Uyarı :
Bu elektronik posta işbu linki kullanarak ulaşabileceğiniz Koşul ve Şartlar dökümanına tabidir :
www.turktelekom.com.tr/tt/portal/email-yasal-uyari<http://www.turktelekom.com.tr/tt/portal/email-yasal-uyari>
From: Umut Keten
Sent: Tuesday, November 15, 2016 8:53 AM
To: John Dowdell <[email-masked]>; [email-masked]
Subject: YNT: [DKIM - Gonderici Dogrulama Sorunu] [mpls] Help wanted in detnet

John hi,

Krgrds,
Umut

-------- Orijinal mesaj --------
Başlangıç tarihi: John Dowdell <[email-masked]<mailto:[email-masked]>>
Tarih: 15.11.2016 08:33 (GMT+03:00)
Alıcı: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Konu: [DKIM - Gonderici Dogrulama Sorunu] [mpls] Help wanted in detnet

John