Subject: [Detnet] Question about using blockchain as DetNe use case

From: Norman Finn <[email-masked]>
Date: Thu, 16 Nov 2017 02:02:39 +0000

I know little about the applications bitcoin.  I can easily appreciate its need for reliability, but I have a question about bandwidth.

Are bitcoin applications comfortable with the fixed bandwidth aspect of DetNet?

That is, an app cannot exceed the BW of a flow, and unused BW is not available to other DetNet flows.  So, I take it that bitcoin is either not bursty, or can afford wasted bandwidth.

-- Norm

---

From: <[email-masked]>
Date: Thu, 16 Nov 2017 10:41:22 +0800 (CST)

hi Norm, 

bitcoin is actually a public blockchain which is running in the open internet. here we're address specifically the private blockchain.

blockchain runs in a mode of p2mp among its participating nodes while it's actually running p2p in the level of network (L3/L4)  based upon best-effort under current scenario. its consensus mechanism demands strictly every transmission of the data be delivered successfully on each node, otherwise the failed (packet-loss, expiry delivery etc)transmission has to tranported again. 

the unreliability and the latency incurred is especially intolerable in the private blockchain applications.

so far as the fixed bw is concerned, blockchain actullay would not consume too much for its quite limited metadata transmission.

黄光平 huangguangping

预研标准部/有线研究院/有线产品经营部 Standard Preresearch Dept./Wireline Product Operation Division

南京市雨花区软件大道50号中兴通讯1号楼 
R&D Building, ZTE
Corporation Software Road No.50, 
Yuhua District, Nanjing, P..R.China, 210012 
M: +86 13770311052 
E: [email-masked] 
www.zte.com.cn

原始邮件

发件人： <[email-masked]>;
收件人：黄光平10039714; <[email-masked]>;
抄送人： <[email-masked]>;
日 期 ：2017年11月16日 10:03
主 题 ：[Detnet] Question about using blockchain as DetNe use case

 
 
 -- Norm

---

From: John Grant <[email-masked]>
Date: Thu, 16 Nov 2017 12:39:44 +0000

> That is, an app cannot exceed the BW of a flow, and unused BW is not available to other DetNet flows.  So, I take it that bitcoin is either not bursty, or can afford wasted bandwidth.

I guess it's not entirely wasted, but can be used for non-detnet flows. There must be many applications where latency matters but traffic isn't constant bit rate (e.g. where business is lost if web pages don't load quickly) and for those there might be a benefit in making a reservation that is only used sporadically. I'm not sure what the best way to discourage that would be.

John Grant
Nine Tiles, Cambridge, England
+44 1223 862599 and +44 1223 511455
http://www.ninetiles.com

---

From: Norman Finn <[email-masked]>
Date: Fri, 17 Nov 2017 03:05:54 +0000

Guangping,

Thanks for the reply.  Let me explain a little better what and why I'm asking:

It's not possible to guarantee both bounded latency and reliable delivery to an arbitrarily high load with a finite number of buffers in the network.  The way that DetNet can assure reliable delivery to bitcoin is:

  1. Every point-to-point bitcoin connection has a certain bandwidth reserved for its use.
  2. A bitcoin host must not transmit data faster than its reserved bandwidth; any excess packets are discarded.
  3. Unused bandwidth on a bitcoin reservation is NOT available to any other reserved flow, bitcoin or not; it is available only to non-DetNet traffic.
  4. Reservations can never oversubscribe a link.

What this means is that, if a burst of bitcoin activity would exceed the bandwidth of a reservation, the bitcoin application has to buffer its transmissions and meter them out at no more than the contracted rate.  This adds to the latency, of course.  How much it adds would depend on the size of the burst.  It would take some analysis to look at the transmission rate as a function of time and the worst-case acceptable latency, in order to come up with the optimal value for a bandwidth contract.  The bigger the bandwidth, the more expensive the reservation, because of points 3 and 4.

In reading the use cases draft, I understood that reliable delivery is attractive to bitcoin, but the description of the application did not make me confident that the fixed bandwidth aspect would be acceptable.  I'm always glad to find a new application of DetNet, but if the activity of bitcoin is bursty, it might not be a good fit.  I certainly hope it is.

How bursty is bitcoin?

-- Norm

________________________________
From: [email-masked] [[email-masked]]
Sent: Wednesday, November 15, 2017 6:41 PM
To: Norman Finn
Cc: [email-masked]; [email-masked]
Subject: 答复: [Detnet] Question about using blockchain as DetNe use case

hi Norm,

黄光平 huangguangping

南京市雨花区软件大道50号中兴通讯1号楼
R&D Building, ZTE Corporation Software Road No.50,
Yuhua District, Nanjing, P..R.China, 210012
M: +86 13770311052
E: [email-masked]
www.zte.com.cn<http://www.zte.com.cn/>
原始邮件
发件人： <[email-masked]>;
收件人：黄光平10039714; <[email-masked]>;
抄送人： <[email-masked]>;
日 期 ：2017年11月16日 10:03
主 题 ：[Detnet] Question about using blockchain as DetNe use case

-- Norm

---

From: <[email-masked]>
Date: Fri, 17 Nov 2017 11:27:02 +0800 (CST)

Norm,

Thanks for your comment.

I understand the fact the blockchain traffic is bursty would inevitably bring some waste to the reserved bandwith, which would happen in all of the scenarios where the data rate is variate.

but fortunately it's inherent in blockchain the metadata size (both the "transaction" and "blocks") is fixed or could at least be pre-calculated, so in a running blriockchain the bw reserved could be set strictly as the specified datarate rather than a maximum covering a variaty of datarates. 

thanks again.

黄光平 huangguangping

南京市雨花区软件大道50号中兴通讯1号楼 
R&D Building, ZTE

原始邮件

发件人： <[email-masked]>;
收件人：黄光平10039714;
抄送人： <[email-masked]>; <[email-masked]>;
日 期 ：2017年11月17日 11:08
主 题 ：Re: [Detnet] Question about using blockchain as DetNe use case

Guangping,

 

 
 How bursty is bitcoin?
 
 -- Norm

--------------------------------------------------------------------------------

hi Norm, 

 

 

黄光平 huangguangping

 

 南京市雨花区软件大道50号中兴通讯1号楼 
 R&D Building, ZTE Corporation Software Road No.50, 
 Yuhua District, Nanjing, P...R.China, 210012 
 M: +86 13770311052 
 E: [email-masked] 
 www.zte.com.cn

 

 
 
 -- Norm

---

From: Norman Finn <[email-masked]>
Date: Fri, 17 Nov 2017 03:56:50 +0000

Super!  Thanks for the clarification.

-- Norm

________________________________
From: [email-masked] [[email-masked]]
Sent: Thursday, November 16, 2017 7:27 PM
To: Norman Finn
Cc: [email-masked]; [email-masked]
Subject: 答复: Re: [Detnet] Question about using blockchain as DetNe use case

Norm,

Thanks for your comment.

thanks again.

黄光平 huangguangping

南京市雨花区软件大道50号中兴通讯1号楼

Guangping,

How bursty is bitcoin?

-- Norm

hi Norm,

黄光平 huangguangping

南京市雨花区软件大道50号中兴通讯1号楼

-- Norm