Subject: [Detnet] draft-ietf-detnet-use-cases & slices suggestions

From: Toerless Eckert <[email-masked]>
Date: Thu, 16 Nov 2017 04:32:02 +0100

Wrt to my comments on the mike@singapore re. slicing use-case:

First of all i would like to reinforce Stewarts statement that we should
not remove slicing from the use-case draft. My point was different: making
the importance for detnet in slicing clearer - because i think it
is hierarchical and multi-faceted, and that does not well reflect in the current text.

Following suggestions for improvements aside, the existing text of 10. is already
 very nicely enlightening about slices, more so than i have seen in other places.

A) I would not call 10.1 "Use Case Description" but instead "Technology Description"

B) 10.3 up to the the "However" is IMHO the most fundamental use-case for detnet
  in the slicing realm. It should be moved and become e.g.: a new 10.2.1 use-case,
  here is proposed changed paragraphs:

  10.2.1 Hard resource isolation across slices

  |Network slicing aims to provide logical networks with hard resource
  |separation guarantees between those different logical networks.
  |Hard resource separation means that it should be impossible for activity,
  |lack of activity, or changes in activity of one or more slices to have
  |any appreciable effect on the deterministic performance parameters of any
  |other slices.

  |Typical techniques used today (for example in pre-existing logical/virtual
  |network solutions), which share a physical network amongst users, do
  |not offer this kind of insulation.  DetNet can supply point-to-point
  |or point-to-multipoint paths that offer bandwidth and latency
  |guarantees to a slice that cannot be affected by other slices data
  |traffic.

  I hope i did correctly interpret "user" to mean "slice", because, but even
  if not, i think the above is correct: If we want to have strict separation
  guarantees btween different users inside the same clice, that is IMHO a
  separate use case within the slicing technology:

C) I would group existing 10.2.1...10.2.3 under a common use-case, maybe:

   10.2.2 Deterministic services within slices

   Slices need to be able to provide services that require detnet type
   guarantees. These requirements would equally make the use of detnet
   for these services a requirement if the service was not provided via a
   logical network slice but via a separate physcial network (and therefore
   the use-case requirement of 10.2.1 would not exist)

   A 5G bearer network is a typical  ...
   [ Make existing 10.2.1...10.2.3 become eg: 10.2.2.1 ... 10.2.2.3]

D) It would be nice to have more clarifying details 
   about the sentence "A 5G bearer network is a typical
   use case of network slicing, including 3 service scenarios"

   If the answer to my questions are not really clear because 3GPP has not
   make up its mind what exactly is required, then maybe phrase the text
   accordingly (3GPP has not yet decided where or...):

   1. Will 3GPP want to have slices which are NOT 5G bearer networks ?
     if yes, then say this.

   2. For a network slice which is a 5G bearer network, would it have
     only one of the 3 service scenarios, or any subset of the 3 ?

   3. If the answer to 1. is "yes, also slices that are not 3GPP bearers",
      would any or all of the three mentioned service scenarios also
      be required in those non-3GPP slices ?

E) It might be useful to add text stating that use cases for detnet
   mentioned in other sections of the document would likely become
   use cases of slices in the future.

   Possible suggested text: 

   Even though not necesary within the scope of work explicitly charted
   for slices in 5G: Whenever 5G or other network service providers see the
   opportunity to operate services described as use-cases in other sections of
   this document across a shared physcial infrastructure, network slices
   would be the likely preferred approach to provide such services.

   Examples include providing electrical utilities services (section 3.)
   or pro audio services (section 2.) via slices. Use cases like these could become
   more into the focus for network slices when the work for 5G core
   network evolution will include services that are more inclusive of
   even wired access options required in those use-cases.

F) Another likely evolution of slices worthwhile to notice:

   Slices may equally become the preferred mode of providing services that
   are otherwise considered to be out of scope in this document, such as
   those in 12.2. These can easily come into scope when Mobile Edge Compute
   ressources connecting to slices can allow to provide detnet service guarantees
   to these use-cases by eliminating the uncontrolled parts of a path
   between servers and client.

Cheers
    Toerless

On Mon, Nov 13, 2017 at 09:06:40AM +0000, Grossman, Ethan A. wrote:
> Tal does this work for you?
> Ethan.
> 
> On Nov 13, 2017, at 3:48 PM, Norman Finn <[email-masked]<mailto:[email-masked]>> wrote:
> 
> Sounds like Tuesday 16:00.  Right?  Near registration.
> 
> -- Norm
> 
> ________________________________
> From: Grossman, Ethan A. [[email-masked]<mailto:[email-masked]>]
> Sent: Sunday, November 12, 2017 8:16 PM
> To: Das, Subir
> Cc: Patrick Wetterwald (pwetterw); Norman Finn; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Gary Weiner
> Subject: Re: [Detnet] DetNet Security Meet-Up
> 
> I can do Tuesday 16:00. I have a commitment Tuesday at 18:30.
> Ethan.
> 
> On Nov 13, 2017, at 11:27 AM, Das, Subir <[email-masked]<mailto:[email-masked]>> wrote:
> 
> I arrived today but can't  make it on Tuesday at 13:30. Available from 16:00.
> ________________________________
> From: Grossman, Ethan A. [[email-masked]<mailto:[email-masked]>]
> Sent: Sunday, November 12, 2017 10:15 PM
> To: Patrick Wetterwald (pwetterw)
> Cc: Norman Finn; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Gary Weiner
> Subject: Re: [Detnet] DetNet Security Meet-Up
> 
> Yes I was agreeing to Tuesday.
> Ethan.
> 
> On Nov 13, 2017, at 10:46 AM, Patrick Wetterwald (pwetterw) <[email-masked]<mailto:[email-masked]>> wrote:
> 
> On Tuesday. Correct ?
> 
> Patrick
> 
> From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
> Date: Monday, 13 November 2017 at 03:43
> To: Norman Finn <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
> Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Gary Weiner <[email-masked]<mailto:[email-masked]>>
> Subject: Re: [Detnet] DetNet Security Meet-Up
> 
> Meet at 13:30 at IETF Registration?
> Ethan.
> 
> From: Norman Finn [mailto:[email-masked]]
> Sent: Sunday, November 12, 2017 4:52 PM
> To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: Gary Weiner <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Subject: RE: DetNet Security Meet-Up
> 
> Yes, let's get together.  Right now, any time Tuesday after lunch would be fine.
> 
> -- Norm
> ________________________________
> From: Grossman, Ethan A. [[email-masked]<mailto:[email-masked]>]
> Sent: Sunday, November 12, 2017 3:59 AM
> To: [email-masked]<mailto:[email-masked]>
> Cc: Gary Weiner; [email-masked]<mailto:[email-masked]>
> Subject: DetNet Security Meet-Up
> Hello DetNet Security draft authors, (and adding the DetNet list since we are now a WG draft and would like to include anyone who has any interest),
> Tal and I are here in Singapore and would like to know if any of the rest of you might be here in town and might want to meet up over lunch or dinner (or something) to discuss DetNet security, e.g. next steps for the DetNet Security draft. If so, please reply and we can plan something.
> Thanks,
> Ethan.
> Ethan Grossman, DetNet Security Draft editor.
> 
> _______________________________________________
> detnet mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/detnet

> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

-- 
---
[email-masked]

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Thu, 16 Nov 2017 06:18:56 +0000

HI Toerless,

Thanks a lot for your comments. I will read it and try to give some feedback soon.

Best Regards

Xuesong

------------------------------------------------------------------------------------------------------

First of all i would like to reinforce Stewarts statement that we should not remove slicing from the use-case draft. My point was different: making the importance for detnet in slicing clearer - because i think it is hierarchical and multi-faceted, and that does not well reflect in the current text.

Following suggestions for improvements aside, the existing text of 10. is already  very nicely enlightening about slices, more so than i have seen in other places.

   Possible suggested text: 

Cheers
    Toerless

On Mon, Nov 13, 2017 at 09:06:40AM +0000, Grossman, Ethan A. wrote:
> Cc: Patrick Wetterwald (pwetterw); Norman Finn; 
> [email-masked]<mailto:draft-ietf-detnet-security@
> ietf.org>; [email-masked]<mailto:[email-masked]>; Gary Weiner
> Cc: Norman Finn; 
> [email-masked]<mailto:draft-ietf-detnet-security@
> ietf.org>; [email-masked]<mailto:[email-masked]>; Gary Weiner
> From: detnet <[email-masked]<mailto:[email-masked]>> 
> on behalf of "Grossman, Ethan A." 
> <[email-masked]<mailto:[email-masked]>>
> To: Norman Finn 
> <[email-masked]<mailto:[email-masked]>>, 
> "[email-masked]<mailto:draft-ietf-detnet-security
> @ietf.org>" 
> <[email-masked]<mailto:draft-ietf-detnet-security
> @ietf.org>>
> Cc: "[email-masked]<mailto:[email-masked]>" 
> <[email-masked]<mailto:[email-masked]>>, Gary Weiner 
> <[email-masked]<mailto:[email-masked]>>
> To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; 
> [email-masked]<mailto:draft-ietf-detnet-security@
> ietf.org>
> To: 
> [email-masked]<mailto:draft-ietf-detnet-security@
> ietf.org>
> Hello DetNet Security draft authors, (and adding the DetNet list since 
> we are now a WG draft and would like to include anyone who has any interest), Tal and I are here in Singapore and would like to know if any of the rest of you might be here in town and might want to meet up over lunch or dinner (or something) to discuss DetNet security, e.g. next steps for the DetNet Security draft. If so, please reply and we can plan something.
> Thanks,
> Ethan.

--
---
[email-masked]