Subject: Re: [Detnet] Some thoughts on Replication and Elimination

From: Jean-Yves Le Boudec <[email-masked]>
Date: Mon, 13 Nov 2017 05:17:44 +0100

Hi Bala'zs

in draft-ietf-detnet-architecture-04 is mentioned the possibility of a 
flow format:

DetNet-s-flow: specific format of a DetNet flow.  Only requires
       the replication/elimination feature ensured by the DetNet service
       layer.

Does this mean that there can be flows that receive duplication but are 
not receiving 0 congestion loss ? (the word "format" is not clear to me 
in this context).

If this means that indeed some flows can receive packet duplication 
without being subject to reservation, then this may cause congestion 
control issues.

JY

 >Some clarification questions on draft for better understanding: >> 
Similarly one copy of a packet may be subjected to congestion discard 
 >What do You mean here by congestion discard? Detnet flows are assuming 
"zero congestion loss". >See e.g., draft-ietf-detnet-architecture-04, 
chapter 3.2.1. Congestion protection OR >draft-finn-bounded-latency-00, 
chapter 4.2. Achieving zero congestion lo

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 13 Nov 2017 05:49:35 +0000

Hi JY,

I would refer here to Figure2. Replication/elimination is done by the Service layer.
Also "4.2.1. End system" shows the end-system types.
"... End systems with DetNet functionalities may have the same or different transport layer as the
connected DetNet domain.  ... "

So a "DetNet-s-flow" means that the transport layers of the end-system and the detnet domain are different.
For example and Ethernet-TSN-end-host is connected to an MPLS based DetNet domain, however the
end-system is aware of replication/elimination and add seq.num to the originated flow.

I hope that clarifies, that no congestion control issues are caused. Reservation is always a must before sending
any DetNet flows to the network.

Cheers
Bala'zs

From: detnet [mailto:[email-masked]] On Behalf Of Jean-Yves Le Boudec
Sent: 2017. november 13. 12:18
To: [email-masked]
Subject: Re: [Detnet] Some thoughts on Replication and Elimination

Hi Bala'zs

in draft-ietf-detnet-architecture-04 is mentioned the possibility of a flow format:

      layer.

Does this mean that there can be flows that receive duplication but are not receiving 0 congestion loss ? (the word "format" is not clear to me in this context).

If this means that indeed some flows can receive packet duplication without being subject to reservation, then this may cause congestion control issues.

JY

>Some clarification questions on draft for better understanding:

>What do You mean here by congestion discard? Detnet flows are assuming "zero congestion loss".

>See e.g., draft-ietf-detnet-architecture-04, chapter 3.2.1. Congestion protection OR

>draft-finn-bounded-latency-00, chapter 4.2. Achieving zero congestion lo

---

From: Norman Finn <[email-masked]>
Date: Mon, 13 Nov 2017 07:44:30 +0000

Packet replication and bounded latency are two different features, and can be chosen independently.  If you pick neither, then you have no DetNet.  You can pick both (which, in some cases, requires extra buffering).  Replication without bounded latency reservations is the way it's used a lot, today, with IEC 62439-3.

-- Norm

________________________________
From: detnet [[email-masked]] on behalf of Balázs Varga A [[email-masked]]
Sent: Sunday, November 12, 2017 9:49 PM
To: Jean-Yves Le Boudec; [email-masked]
Subject: Re: [Detnet] Some thoughts on Replication and Elimination

Hi JY,

I would refer here to Figure2. Replication/elimination is done by the Service layer.
Also “4.2.1. End system” shows the end-system types.
“… End systems with DetNet functionalities may have the same or different transport layer as the
connected DetNet domain.  … “

So a “DetNet-s-flow” means that the transport layers of the end-system and the detnet domain are different.
For example and Ethernet-TSN-end-host is connected to an MPLS based DetNet domain, however the
end-system is aware of replication/elimination and add seq.num to the originated flow.

Cheers
Bala’zs

Hi Bala'zs

      layer.

JY

---

From: Norman Finn <[email-masked]>
Date: Tue, 14 Nov 2017 06:39:08 +0000

I disagree with your last paragraph, Balazs.  At least in IEEE, and in the Architecture document, PREF without a reservation is allowed.  I know it's true in TSN; if it's not true in the Architecture draft I need to fix it.

-- Norm

Hi JY,

Cheers
Bala’zs

Hi Bala'zs

      layer.

JY

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 14 Nov 2017 09:31:49 +0000

Ack. I wanted to say configuration and not reservation.
Before sending DetNet traffic the network must be prepared.
What DetNet functions are needed depends on the flow and the network scenario.
Sorry about the confusion (and my bad english).
Bala'zs

From: detnet [mailto:[email-masked]] On Behalf Of Norman Finn
Sent: 2017. november 14. 14:39
To: Balázs Varga A <[email-masked]>; Jean-Yves Le Boudec <[email-masked]>; [email-masked]
Subject: Re: [Detnet] Some thoughts on Replication and Elimination

-- Norm
To: Jean-Yves Le Boudec; [email-masked]<mailto:[email-masked]>

Cheers
Bala'zs

From: detnet [mailto:[email-masked]] On Behalf Of Jean-Yves Le Boudec
Sent: 2017. november 13. 12:18
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] Some thoughts on Replication and Elimination

Hi Bala'zs

      layer.

JY