Subject: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

From: János Farkas <[email-masked]>
Date: Wed, 2 May 2018 18:29:32 +0200

Dear All,

This starts a two week Working Group Last Call (WGLC) on 
draft-ietf-detnet-problem-statement-03.

The WGLC ends on May 16.

Please send your comments to the DetNet mailing list.

Positive comments, e.g., "I've reviewed this document and believe it is 
ready for publication", are welcome!
This is useful and important, even from authors.

Thank you,
DetNet Chairs

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 2 May 2018 14:47:31 -0400

I’ve read the problem statement and believe that it is ready for
publication.

Cheers,
Andy

On Wed, May 2, 2018 at 12:29 PM, János Farkas <[email-masked]>
wrote:

> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: Kiran.Makhijani <[email-masked]>
Date: Wed, 2 May 2018 19:50:31 +0000

I have read and reviewed the doc. It is ready for publication. 

Though it will help to clarify use of 'critical flow' in section 2,
   2.  Support for critical packet flows that:
Since it has no previous context or definition. Can we replace with 'deterministic flow'?

editorial nit, last line of section 3.1.
   s/seu th epath up/set up the path

-Kiran
On 5/2/18, 9:31 AM, "detnet on behalf of János Farkas" <[email-masked] on behalf of [email-masked]> wrote:

    Dear All,

    The WGLC ends on May 16.

    
    Thank you,
    DetNet Chairs

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 3 May 2018 15:56:41 +0100

This is basically ready, but I think a few items need attention before 
this goes to the IESG:

    As a result of this work, it will be possible to establish a multi-
    hop path over the IP network,

SB> I think that should be an IP or MPLS network

=============

   The goals of Deterministic Networking are to enable the migration of
    applications that use special-purpose fieldbus technologies (HDMI,
    CANbus, ProfiBus, etc... even RS-232!) to packet technologies in
    general, and the Internet Protocol in particular, and to support both
    these new applications, and existing packet network applications,
    over the same physical network.

SB> I think there should be some text here indicating that DN is
SB> required to support these migrations when there are critical
SB> timing and reliability issues.
SB>
SB> Where such issues are not critical, the Pseudowires or L2TP tunnels
SB> will normally be adequate. Indeed they have proved adequate for TDM
SB> and SDH emulation which are quite fickle services to emulate.
  
==============

        *  Need a packet loss ratio beyond the classical range for a
           particular medium, in the range of 10^-9 to 10^-12, or better,
           on Ethernet, and in the order of 10^-5 in Wireless Sensor Mesh
           Networks;

SB> I am worried whether or not we are setting unreasonable expectations
SB> here.  How many packet copies do we think we need to send
SB> to reduce the BER by 10?

===============

    4.  Robust defenses against misbehaving hosts, routers, or bridges,
SB> s/defenses/defences/
        both in the data and control planes, with guarantees that a
        critical flow within its guaranteed resources cannot be affected
        by other flows whatever the pressures on the network;

=================

These limits may depend in the technology that is used to
    seu th epath up, whether it is centralized or distributed.

SB> Hopefully no my fat fingers in my marked up copy, but it should be:
SB> "set the path"

=================

    3.  The path is installed using RSVP-TE, associated with flow
        identification, per-hop behavior such as replication and
        elimination, blocked resources, and flow timing information.

SB> This is too prescriptive on approach for a problem statement.
SB> There might well be an approach that surfaces from the Segment Routing
SB> or VPN+ work based on use of the IGP.

================

   Security must cover:

SB> I think should be "Security must also cover". If not the dynamic
SB> requirement which is unique to DN should be top of the list.

  o  the protection of the signaling protocol

SB> True, but isn't this currently out of scope (and not sure about the next point)

Best Regards

- Stewart

---

From: Kiran.Makhijani <[email-masked]>
Date: Thu, 3 May 2018 15:45:45 +0000

SB> True, but isn't this currently out of scope (and not sure about the next point)
I had same question, but maybe this section mentions generic signaling relating to detnet (in the current scope SDN signaling from controller to nodes and/or even PCEP).

From: detnet <[email-masked]> On Behalf Of Stewart Bryant
Sent: Thursday, May 3, 2018 7:57 AM
To: János Farkas <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

This is basically ready, but I think a few items need attention before this goes to the IESG:

=============

SB>

==============

          Networks;

===============

SB> s/defenses/defences/

=================

SB> "set the path"

=================

================

  Security must cover:

Best Regards

- Stewart

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 16 May 2018 12:43:50 +0000

Thanks a bunch Kiran:

I saw no opposition so I made the chances in the bitbucket repo.

Take care,

Pascal

> -----Original Message-----
> From: detnet <[email-masked]> On Behalf Of Kiran.Makhijani
> Sent: mercredi 2 mai 2018 21:51
> On 5/2/18, 9:31 AM, "detnet on behalf of János Farkas" <detnet-
> [email-masked] on behalf of [email-masked]> wrote:
> 
>     Dear All,
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 16 May 2018 13:06:58 +0000

Thanks a bunch Stewart ;

Please see below - by OK I mean undisputed agreement and changed made in the repo, to be published with the next version unless opposition shows up;

From: detnet <[email-masked]> On Behalf Of Stewart Bryant
Sent: jeudi 3 mai 2018 16:57
To: János Farkas <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

[PT>] OK

=============

SB>

[PT>] OK

==============

          Networks;

[PT>] I think these numbers are associated with the concept of PRE. If a typical Ethernet gives you 10-5 then PRI should reach 10-10

Arguably this considers only one fault at a time.

===============

SB> s/defenses/defences/

[PT>] UK vs. US. Which do we usually pick?

=================

SB> "set the path"

[PT>] Yes, Kiran spotted it first ; )

=================

[PT>] Yes, but at some point the resources along the path must be blocked.

How is that done? What if the IGP selects a different path?

I guess SR works as long as the SR is strict or the path between routers in the SR cannot change, and resources are aplenty.

What about this:

    The path may be installed using a control protocol such as RSVP-TE,

    associated with flow identification, per-hop behavior such as Packet

    Replication and Elimination, blocked resources, and flow timing information.

    Alternatively, the routing and flow information may be placed in-band in the

    packet, e.g., using Segment Routing, in which case the packet is routed

    along a prescribed source route path following forwarding indications that

     are present in the packet.

================

  Security must cover:

[PT>] What about:

The overall security of a deterministic system must cover:

Thanks again Stewart!

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 16 May 2018 13:08:51 +0000

Yes, Kiran.

We could make that statement broader to the enforcement of the security does not read as a Detnet problem, e.g., by saying;

The overall security of a deterministic system must cover

Works?

Pascal

From: detnet <[email-masked]> On Behalf Of Kiran.Makhijani
Sent: jeudi 3 mai 2018 17:46
To: Stewart Bryant <[email-masked]>; János Farkas <[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Stewart Bryant
Sent: Thursday, May 3, 2018 7:57 AM
To: János Farkas <[email-masked]<mailto:[email-masked]>>; DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

=============

SB>

==============

          Networks;

===============

SB> s/defenses/defences/

=================

SB> "set the path"

=================

================

  Security must cover:

Best Regards

- Stewart

---

From: Kiran.Makhijani <[email-masked]>
Date: Wed, 16 May 2018 13:50:05 +0000

Yes.
Thanks
-Kiran
From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wednesday, May 16, 2018 at 9:09 AM
To: Kiran Makhijani <[email-masked]>, "stewart.bryant" <[email-masked]>, János Farkas <[email-masked]>, DetNet WG <[email-masked]>
Subject: RE: [Detnet] WG Last Call: draft-ietf-detnet-problem-statement-03

Yes, Kiran.

Works?

Pascal

=============

SB>

==============

          Networks;

===============

SB> s/defenses/defences/

=================

SB> "set the path"

=================

================

  Security must cover:

Best Regards

- Stewart