Subject: [Detnet] DetNet Design Team Interim Meeting Notes - MPLS - 29May18

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 29 May 2018 16:09:15 +0000

Hi All
Here are my meeting notes, please correct anything I missed.
Thanks,
Ethan.
-------------------
Date: Tues May 29, 2018
Present on Webex: Stewart, Loa, Janos, Balazs, Vishnu, Jouni, Lou, Ethan.

Summary of conclusions:
Stewart had concerns between terminology alignment between this doc and architecture doc, but nothing else that impacted this doc - but note here with the intent that eventually we will align them through usual review process for consistency of terminology.

Regarding section on time sync: Prefer to strip text to some other new document, but won’t add reference to new doc since out of scope.
Maybe brief mention of two models, but details for time sync out of scope.

Strip local label stuff, have it point to S label where appropriate.
16 or 28 bit sequence numbers only. Value of S label establishes size of sequence number, established by control plane.

Must look at NSP text. Processing of PREF stuff is allowed in NSP.

UDP header in Fig 14:  Don’t say anything about ECMP at this point. UDP not mandatory in this stack.

References to class of service, quality of service – decided to keep it as is for now for education purposes but may be changed or removed eventually.

Sec 10. Management and control considerations – needs to be separate for MPLS vs IP?
10.1.2 Explicit routes – currently empty – need a plan.
Stewart: need to list methods:
RSVP-TE, Segment Routing (whatever flavor) or set up in control plane. Maybe other ways developed in time.
For now just placeholder text. Just these two references should be enough.

Goal to get these changes out by end of next week. Stewart to do this work – then Jouni and Balazs will finalize edits.

Next interim MPLS meeting will be June 5, 8am PDT, 5pm Central European time.
Stewart won’t have done edits by then – then meet June 25 MPLS same time since will have done edits by then and will have feedback to discuss.

Jouni offline for July. Won’t be at IETF.
-------------------

---

From: Lou Berger <[email-masked]>
Date: Wed, 30 May 2018 14:31:46 -0400

Note this was a "working meeting" not a formal WG interim meeting.

Lou

On 5/29/2018 12:09 PM, Grossman, Ethan A. wrote:
> Stewart had concerns between terminology alignment between this doc 
> and architecture doc, but nothing else that impacted this doc - but 
> note here with the intent that eventually we will align them through 
> usual review process for consistency of terminology.
>
> Regarding section on time sync: Prefer to strip text to some other new 
> document, but won’t add reference to new doc since out of scope.
>
> 16 or 28 bit sequence numbers only. Value of S label establishes size 
> of sequence number, established by control plane.
>
> References to class of service, quality of service – decided to keep 
> it as is for now for education purposes but may be changed or removed 
> eventually.
>
> Goal to get these changes out by end of next week. Stewart to do this 
> work – then Jouni and Balazs will finalize edits.
>
> Stewart won’t have done edits by then – then meet June 25 MPLS same 
> time since will have done edits by then and will have feedback to 
> discuss.
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet