Subject: [Detnet] Regarding the model for Active OAM packet

From: Mach Chen <[email-masked]>
Date: Wed, 19 Sep 2018 02:48:04 +0000

Hi Greg,

The MPLS DetNet header is defined as below:

grouping mpls-detnet-header {
    description
        "The MPLS DetNet encapsulation header information.";
    leaf service-label {
      type uint32;
      mandatory true;
      description
        "The service label of the DetNet header.";
    }
    leaf control-word {
      type uint32;
      mandatory true;
      description
        "The control word of the DetNet header.";
    }
  }

Although do not consider Active OAM when design the above mpls-denet-header,  seems that it can cover Active OAM case as well. No matter a normal DetNet packet or an Active OAM packet, there should be a CW field, just as defined above. 

For normal DetNet packets, the CW is the d-CW as defined in the draft-ietf-detnet-dp-sol-mpls. 

For OAM packets, the CW is the "DetNet Associated Channel".

Best regards,
Mach 

> -----Original Message-----
> From: detnet [mailto:[email-masked]] On Behalf Of Greg Mirsky
> Sent: Wednesday, September 19, 2018 3:17 AM
> To: János Farkas <[email-masked]>
> Cc: DetNet WG <[email-masked]>; [email-masked]
> Subject: Re: [Detnet] WG adoption poll draft-geng-detnet-conf-yang
> 
> Hi Janos, et. al,
> the mpls-detnet-header container is based on the solution described in
> draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC OAM in the proposed
> MPLS data plane solution in draft-mirsky-detnet-oam points to the potential
> problem as result the fact that OAM packet doesn't include d-CW. I believe
> that this question should be discussed and, if we agree on the problem
> statement, properly resolved. Until then, I do not support the adoption of
> the model that may not be capable to support active OAM.
> 
> Regards,
> Greg
> On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas <[email-masked]>
> wrote:
> >
> > Dear all,
> >
> > This is start of a two week poll on making
> > draft-geng-detnet-conf-yang-04 a working group document. Please send
> > email to the list indicating "yes/support" or "no/do not support".  If
> > indicating no, please state your reservations with the document.  If
> > yes, please also feel free to provide comments you'd like to see
> > addressed once the document is a WG document.
> >
> > The poll ends Oct 3.
> >
> > Thanks,
> > János and Lou
> >
> > _______________________________________________
> > detnet mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/detnet
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 18 Sep 2018 20:28:41 -0700

Hi Mach,
thank you for your attention to my comment and the most expedient response.
I don't find the DetNet Associated Channel defined in
draft-ietf-detnet-dp-sol-mpls and thus I assumed that OAM packets that
follow the data packet encapsulation defined in that draft use PW ACH as
defined in section 5 RFC 4385: True, it includes 8 bits-long Reserved field
that may be defined as OAM Sequence Number but that had not been discussed.
One is certain, existing nodes do not check the Reserved field. And without
a field to hold the sequence number, PREF will not handle the OAM packets.
Another question, additional processing and amount of state introduced in
the fast path by the fact that OAM's Sequence Number will have different
length and location in d-CW (differentiating cases by the first nibble).
Now, if we step back from DetnNet in MPLS data plane encapsulation, why the
control-word, as I understand, is configurable? I think that the Sequence
Number is not configurable, nor the first nibble. What do you think?

Regards,
Greg

On Tue, Sep 18, 2018 at 7:48 PM Mach Chen <[email-masked]> wrote:

> Although do not consider Active OAM when design the above
> mpls-denet-header,  seems that it can cover Active OAM case as well. No
> matter a normal DetNet packet or an Active OAM packet, there should be a CW
> field, just as defined above.
>
> > On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas <[email-masked]
> >
> > wrote:
> > >
> > > Dear all,
> > >

---

From: Mach Chen <[email-masked]>
Date: Wed, 19 Sep 2018 06:31:15 +0000

Hi Greg,

Indeed, there is no DetNet Associated Channel defined in draft-ietf-detnet-dp-sol-mpls for now, I think there should be.  I also assume that PW ACH will be used for DetNet OAM.

Assume that PW ACH will be used for DetNet OAM and the reserved filed of the PW ACH will be used to carry sequence number for OAM packet. But  for PREF, a tricky way is to treat the “Version”+ “Reserved” + ”Channel type” as the Sequence number, the replication or elimination nodes do not need to differentiate whether it is a d-CW or  a PW ACH . This way, OAM can be supported without additional processing and states.

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |0 0 0 1|Verion |    Reserved   |         Channel Type          |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regarding sequence number, there are two ways to generate the sequence number IMHO:  1) generated by the edge node, but it may need to configure the start number, or 2) copied from the application-flow (if there is). If the WG agree with this, the model can be updated reflect this.

Best regards,
Mach

From: Greg Mirsky [mailto:[email-masked]]
Sent: Wednesday, September 19, 2018 11:29 AM
To: Mach Chen <[email-masked]>
Cc: János Farkas <[email-masked]>; DetNet WG <[email-masked]>; [email-masked]
Subject: Re: Regarding the model for Active OAM packet

Hi Mach,
thank you for your attention to my comment and the most expedient response.
I don't find the DetNet Associated Channel defined in draft-ietf-detnet-dp-sol-mpls and thus I assumed that OAM packets that follow the data packet encapsulation defined in that draft use PW ACH as defined in section 5 RFC 4385: True, it includes 8 bits-long Reserved field that may be defined as OAM Sequence Number but that had not been discussed. One is certain, existing nodes do not check the Reserved field. And without a field to hold the sequence number, PREF will not handle the OAM packets. Another question, additional processing and amount of state introduced in the fast path by the fact that OAM's Sequence Number will have different length and location in d-CW (differentiating cases by the first nibble).
Now, if we step back from DetnNet in MPLS data plane encapsulation, why the control-word, as I understand, is configurable? I think that the Sequence Number is not configurable, nor the first nibble. What do you think?

Regards,
Greg

On Tue, Sep 18, 2018 at 7:48 PM Mach Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Best regards,
Mach

> From: detnet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
> To: János Farkas <[email-masked]<mailto:[email-masked]>>
> Cc: DetNet WG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas <[email-masked]<mailto:[email-masked]>>
> wrote:
> >
> > Dear all,
> >
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 20 Sep 2018 15:21:20 +0800

Mach,

If I understand you correctly this is for an LSP in an MPLS network,
can you help me understand why GAL does not enough. Given that there
might be some minor extensions to GAL because of replication and
elimination.

/Loa

On 2018-09-19 14:31, Mach Chen wrote:
> Hi Greg,
> 
> Indeed, there is no DetNet Associated Channel defined in 
> draft-ietf-detnet-dp-sol-mpls for now, I think there should be.  I also 
> assume that PW ACH will be used for DetNet OAM.
> 
> Assume that PW ACH will be used for DetNet OAM and the reserved filed of 
> the PW ACH will be used to carry sequence number for OAM packet. But 
>   for PREF, a tricky way is to treat the “Version”+ “Reserved” + 
> ”Channel type” as the Sequence number, the replication or elimination 
> nodes do not need to differentiate whether it is a d-CW or  a PW ACH . 
> This way, OAM can be supported without additional processing and states.
> 
>         0                   1                   2                   3
> 
> Regarding sequence number, there are two ways to generate the sequence 
> number IMHO:  1) generated by the edge node, but it may need to 
> configure the start number, or 2) copied from the application-flow (if 
> there is). If the WG agree with this, the model can be updated reflect 
> this.
> 
> Best regards,
> 
> Mach
> 
> *From:*Greg Mirsky [mailto:[email-masked]]
> *Sent:* Wednesday, September 19, 2018 11:29 AM
> *To:* Mach Chen <[email-masked]>
> *Cc:* János Farkas <[email-masked]>; DetNet WG 
> <[email-masked]>; [email-masked]
> *Subject:* Re: Regarding the model for Active OAM packet
> 
> Hi Mach,
> 
> defined in section 5 RFC 4385: True, it includes 8 bits-long Reserved 
> field that may be defined as OAM Sequence Number but that had not been 
> discussed. One is certain, existing nodes do not check the Reserved 
> field. And without a field to hold the sequence number, PREF will not 
> handle the OAM packets. Another question, additional processing and 
> amount of state introduced in the fast path by the fact that OAM's 
> Sequence Number will have different length and location in d-CW 
> (differentiating cases by the first nibble).
> 
> Now, if we step back from DetnNet in MPLS data plane encapsulation, why 
> the control-word, as I understand, is configurable? I think that the 
> Sequence Number is not configurable, nor the first nibble. What do you 
> think?
> 
> Regards,
> 
> Greg
> 
>     mpls-denet-header,  seems that it can cover Active OAM case as well.
>     No matter a normal DetNet packet or an Active OAM packet, there
>     should be a CW field, just as defined above.
> 
>     > From: detnet [mailto:[email-masked] <mailto:[email-masked]>] On Behalf
>     Of Greg Mirsky
>     > To: János Farkas <[email-masked] <mailto:[email-masked]>>
>     > Cc: DetNet WG <[email-masked] <mailto:[email-masked]>>; [email-masked]
>     <mailto:[email-masked]>
>     > On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas <[email-masked] <mailto:[email-masked]>>
>     > wrote:
>     > >
>     > > Dear all,
>     > >
>     > > [email-masked] <mailto:[email-masked]>
>     > [email-masked] <mailto:[email-masked]>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Mach Chen <[email-masked]>
Date: Thu, 20 Sep 2018 09:58:14 +0000

Loa,

GAL is just an OAM indicator, the problem here is that when do DetNet OAM, the d-CW will replaced by ACH or by GAL+ACH. No matter which way is used, to support the replication or elimination, there has to be a sequence number filed. But ACH (as its current defined) does not have such a field. 

My suggestion is to use the reserved field of ACH to carry sequence number of OAM packet,  and for those replication or elimination nodes, they do not have to differentiate whether a packet is OAM packet or a normal packet, they could just treat the right 28 bits of the ACH as the sequence number ( or treat the ACH as the d-CW), then both OAM and replication/elimination can be supported. 

Best regards,
Mach 

> From: detnet [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Thursday, September 20, 2018 3:21 PM
> To: Mach Chen <[email-masked]>; Greg Mirsky
> <[email-masked]>
> Cc: DetNet WG <[email-masked]>; János Farkas
> <[email-masked]>; [email-masked]
> Subject: Re: [Detnet] Regarding the model for Active OAM packet
> 
> Mach,
> 
> If I understand you correctly this is for an LSP in an MPLS network, can you
> help me understand why GAL does not enough. Given that there might be
> some minor extensions to GAL because of replication and elimination.
> 
> /Loa
> 
> > draft-ietf-detnet-dp-sol-mpls for now, I think there should be.  I
> > also assume that PW ACH will be used for DetNet OAM.
> >
> > Assume that PW ACH will be used for DetNet OAM and the reserved filed
> > of the PW ACH will be used to carry sequence number for OAM packet.
> > But
> > follow the data packet encapsulation defined in that draft use PW ACH
> > as defined in section 5 RFC 4385: True, it includes 8 bits-long
> > Reserved field that may be defined as OAM Sequence Number but that
> had
> > not been discussed. One is certain, existing nodes do not check the
> > Reserved field. And without a field to hold the sequence number, PREF
> > will not handle the OAM packets. Another question, additional
> > processing and amount of state introduced in the fast path by the fact
> > that OAM's Sequence Number will have different length and location in
> > d-CW (differentiating cases by the first nibble).
> >
> > Now, if we step back from DetnNet in MPLS data plane encapsulation,
> > why the control-word, as I understand, is configurable? I think that
> > the Sequence Number is not configurable, nor the first nibble. What do
> > you think?
> >
> > Regards,
> >
> > Greg
> >
> >     > On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas
> <[email-masked] <mailto:[email-masked]>>
> >     > wrote:
> >     > >
> >     > > Dear all,
> >     > >

---

From: Loa Andersson <[email-masked]>
Date: Thu, 20 Sep 2018 18:13:41 +0800

Mach,

I'd like Stewart or Matthew to look at this, but as I understand it it 
is possible to define a new ACH-type that can do exactly what you want.

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Thu, 20 Sep 2018 18:14:06 +0800

Mach,

/Loa

--

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 20 Sep 2018 05:55:18 -0700

Hi Loa,
I agree that we can define new ACH Type that will have Sequence Number
immediately following the ACH. But then we'll need to re-define number of
Types, e.g., BFD, RFC 6374, etc. Or I misunderstood your suggestion.

Regards,
Greg

On Thu, Sep 20, 2018 at 3:13 AM Loa Andersson <[email-masked]> wrote:

> > GAL is just an OAM indicator, the problem here is that when do DetNet
> OAM, the d-CW will replaced by ACH or by GAL+ACH. No matter which way is
> used, to support the replication or elimination, there has to be a sequence
> number filed. But ACH (as its current defined) does not have such a field.
> >
> > My suggestion is to use the reserved field of ACH to carry sequence
> number of OAM packet,  and for those replication or elimination nodes, they
> do not have to differentiate whether a packet is OAM packet or a normal
> packet, they could just treat the right 28 bits of the ACH as the sequence
> number ( or treat the ACH as the d-CW), then both OAM and
> replication/elimination can be supported.
> >
> > Best regards,
> > Mach
> >
> can you
> >>>      > Cc: DetNet WG <[email-masked] <mailto:[email-masked]>>;
> detnet-
> >> [email-masked]
> >>>      > MPLS data plane solution in draft-mirsky-detnet-oam points to
> the
> >> potential
> >>>      > problem as result the fact that OAM packet doesn't include
> d-CW. I
> >> believe
> >>>      > statement, properly resolved. Until then, I do not support the
> adoption
> >> of
> >>>      > > draft-geng-detnet-conf-yang-04 a working group document.
> Please
> >> send

---

From: Mach Chen <[email-masked]>
Date: Fri, 21 Sep 2018 06:22:12 +0000

Hi Loa,

Can you clarify how a new ACH-type can address the problem?

Best regards,
Mach

> From: Loa Andersson [mailto:[email-masked]]
> Sent: Thursday, September 20, 2018 6:14 PM
> I'd like Stewart or Matthew to look at this, but as I understand it it is possible
> to define a new ACH-type that can do exactly what you want.
> 
> /Loa
> 
> >>> Assume that PW ACH will be used for DetNet OAM and the reserved
> >>> filed of the PW ACH will be used to carry sequence number for OAM
> packet.
> >>> But
> >>> ”Channel type” as the Sequence number, the replication or
> >>> elimination nodes do not need to differentiate whether it is a d-CW or  a
> PW ACH .
> >>>          0                   1                   2
> >>> 3
> >>>          0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9
> >>> 0
> >>> 1
> >>>
> >>>
> >>> configure the start number, or 2) copied from the application-flow
> >>> (if there is). If the WG agree with this, the model can be updated
> >>> reflect this.
> >>>
> >>> Best regards,
> >>>
> >>> Mach
> >>>
> >>> draft-ietf-detnet-dp-sol-mpls and thus I assumed that OAM packets
> >>> that follow the data packet encapsulation defined in that draft use
> >>> PW ACH as defined in section 5 RFC 4385: True, it includes 8
> >>> bits-long Reserved field that may be defined as OAM Sequence Number
> >>> but that
> >> had
> >>> Reserved field. And without a field to hold the sequence number,
> >>> PREF will not handle the OAM packets. Another question, additional
> >>> processing and amount of state introduced in the fast path by the
> >>> fact that OAM's Sequence Number will have different length and
> >>> location in d-CW (differentiating cases by the first nibble).
> >>>
> >>> the Sequence Number is not configurable, nor the first nibble. What
> >>> do you think?
> >>>
> >>> Regards,
> >>>
> >>> Greg
> >>>
> >>>      > draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC OAM in
> >>> the
> >> proposed
> >>>      > statement, properly resolved. Until then, I do not support
> >>> the adoption
> >> of

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Sep 2018 16:49:28 +0800

Mach,

Admittedly I'm not up to speed on DetNet OAM, but .....

The ACH is specified like this:

     0                   1                   2                   3
     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |0 0 0 1|Version|   Reserved    |         Channel Type          |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

you can define 65k ACH-types, what stops you from defining a ACH channel
type for DetNet OAM, then define that the structure of the following
octets in a way that you see fit (like (yes I'm inventing as I type, 
more thoughts should go into to this):

        0          1          2          3
        0123 45678901 234567890123 45678901
       +----+--------+------------+--------+
       | R  |   LEN  |     relevant info   |
       +----+--------+------------+--------+
       |0000|             d-CW             |
       +----+--------+------------+--------+
       |        more relevant info         |
       +----+--------+------------+--------+

What is that I'm missing?

/Loa

--

---

From: Mach Chen <[email-masked]>
Date: Fri, 21 Sep 2018 10:31:49 +0000

Hi Loa,

New ACH type is fine, this is also needed for DetNet OAM, IMHO.  The crucial here is how to "cheat" the replication/elimination nodes that an OAM packet is a "normal" DetNet packet, then they can replicate/eliminate the OAM packets as normal DetNet packets. Otherwise, it needs to introduce additional replication/elimination processing for the DetNet OAM packets.

To support this, I suggest to use ACH without GAL (of cause, a new ACH-type) for DetNet OAM (as bellow) and the "reserved" field  carries sequence number information, the "ACH" can be considered as the d-CW by the replication/elimination nodes. 
+----------+
|S-Label  |
+----------+
|ACH        |
+----------+
| Payload|
+----------+

If GAL is used ( the stack as below), additional processing has to be introduced at the replication/elimination nodes, because they have to parse GAL+ACH to decide how to process. That means, the OAM packets will have different replication/elimination process from the normal DetNet packets.

+----------+
|S-Label  |
+----------+
|GAL        |
+----------+
|ACH        |
+----------+
| Payload|
+----------+

Best regards,
Mach 

> Sent: Friday, September 21, 2018 4:49 PM
> type for DetNet OAM, then define that the structure of the following octets
> in a way that you see fit (like (yes I'm inventing as I type, more thoughts
> should go into to this):
> 
>         0          1          2          3
> >> I'd like Stewart or Matthew to look at this, but as I understand it
> >> it is possible to define a new ACH-type that can do exactly what you want.
> >>
> >> /Loa
> >>
> >> OAM, the d-CW will replaced by ACH or by GAL+ACH. No matter which
> way
> >> is used, to support the replication or elimination, there has to be a
> >> sequence number filed. But ACH (as its current defined) does not have
> such a field.
> >>>
> >> number of OAM packet,  and for those replication or elimination
> >> nodes, they do not have to differentiate whether a packet is OAM
> >> packet or a normal packet, they could just treat the right 28 bits of
> >> the ACH as the sequence number ( or treat the ACH as the d-CW), then
> >> both OAM and replication/elimination can be supported.
> >>>
> >>> Best regards,
> >>> Mach
> >>>
> >>>> If I understand you correctly this is for an LSP in an MPLS
> >>>> network, can you help me understand why GAL does not enough.
> Given
> >>>> that there might be some minor extensions to GAL because of
> >>>> replication and
> >> elimination.
> >>>>
> >>>> /Loa
> >>>>
> >>>>> that follow the data packet encapsulation defined in that draft
> >>>>> use PW ACH as defined in section 5 RFC 4385: True, it includes 8
> >>>>> bits-long Reserved field that may be defined as OAM Sequence
> >>>>> Number but that
> >>>> had
> >>>>> not been discussed. One is certain, existing nodes do not check
> >>>>> the Reserved field. And without a field to hold the sequence
> >>>>> number, PREF will not handle the OAM packets. Another question,
> >>>>> additional processing and amount of state introduced in the fast
> >>>>> path by the fact that OAM's Sequence Number will have different
> >>>>> Now, if we step back from DetnNet in MPLS data plane
> >>>>> encapsulation, why the control-word, as I understand, is
> >>>>> configurable? I think that the Sequence Number is not
> >>>>> configurable, nor the first nibble. What do you think?
> >>>>>
> >>>>> Regards,
> >>>>>
> >>>>> Greg
> >>>>>
> >>>>> On Tue, Sep 18, 2018 at 7:48 PM Mach Chen
> <[email-masked]
> >>>>> <mailto:[email-masked]>> wrote:
> >>>>>
> >>>>>       Hi Greg,
> >>>>>
> >>>>>       > From: detnet [mailto:[email-masked]
> >>>>> <mailto:detnet-
> >>>> [email-masked]>] On Behalf
> >>>>>       Of Greg Mirsky
> >>>>>       > Subject: Re: [Detnet] WG adoption poll
> >>>>> draft-geng-detnet-conf-
> >> yang
> >>>>>       >
> >>>>>       > Hi Janos, et. al,
> >>>>>       > draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC OAM
> >>>>> in the
> >>>> proposed
> >>>>>       > MPLS data plane solution in draft-mirsky-detnet-oam points
> >>>>> to the
> >>>> potential
> >>>>>       > that this question should be discussed and, if we agree on
> >>>>> the
> >> problem

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Sep 2018 18:44:12 +0800

Greg,

On 2018-09-20 20:55, Greg Mirsky wrote:
> immediately following the ACH. 

OK!

    > But then we'll need to re-define number
> of Types, e.g., BFD, RFC 6374, etc. Or I misunderstood your suggestion.this probably 
> 
This probably the key, why do you need to redefine?

/Loa
> Regards,
> Greg
> 
> On Thu, Sep 20, 2018 at 3:13 AM Loa Andersson <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Mach,
> 
>      > GAL is just an OAM indicator, the problem here is that when do
>     DetNet OAM, the d-CW will replaced by ACH or by GAL+ACH. No matter
>     which way is used, to support the replication or elimination, there
>     has to be a sequence number filed. But ACH (as its current defined)
>     does not have such a field.
>      >
>      > My suggestion is to use the reserved field of ACH to carry
>     sequence number of OAM packet,  and for those replication or
>     elimination nodes, they do not have to differentiate whether a
>     packet is OAM packet or a normal packet, they could just treat the
>     right 28 bits of the ACH as the sequence number ( or treat the ACH
>     as the d-CW), then both OAM and replication/elimination can be
>     supported.
>      >
>      > Best regards,
>      > Mach
>      >
>     <mailto:[email-masked]>] On Behalf Of Loa Andersson
>      >> To: Mach Chen <[email-masked]
>     <mailto:[email-masked]>>; Greg Mirsky
>      >> <[email-masked] <mailto:[email-masked]>>
>      >> Cc: DetNet WG <[email-masked] <mailto:[email-masked]>>; János
>     Farkas
>      >> <[email-masked] <mailto:[email-masked]>>;
>     [email-masked] <mailto:[email-masked]>
>     network, can you
>     filed
>     elimination
>      >>>          0                   1                  
>     2                   3
>      >>>          0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6
>     7 8 9 0
>      >>> 1
>      >>>
>      >>>
>      >>> *From:*Greg Mirsky [mailto:[email-masked]
>     <mailto:[email-masked]>]
>      >>> *To:* Mach Chen <[email-masked]
>     <mailto:[email-masked]>>
>      >>> *Cc:* János Farkas <[email-masked]
>     <mailto:[email-masked]>>; DetNet WG
>      >>> <[email-masked] <mailto:[email-masked]>>;
>     [email-masked] <mailto:[email-masked]>
>      >>> On Tue, Sep 18, 2018 at 7:48 PM Mach Chen <[email-masked]
>     <mailto:[email-masked]>
>      >>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>>
>      >>>      Hi Greg,
>      >>>
>      >>>      For normal DetNet packets, the CW is the d-CW as defined
>     in the
>      >>>      draft-ietf-detnet-dp-sol-mpls.
>      >>>
>      >>>      > -----Original Message-----
>      >>>      > From: detnet [mailto:[email-masked]
>     <mailto:[email-masked]> <mailto:detnet- <mailto:detnet->
>      >> [email-masked] <mailto:[email-masked]>>] On Behalf
>      >>>      Of Greg Mirsky
>      >>>      > Sent: Wednesday, September 19, 2018 3:17 AM
>      >>>      > To: János Farkas <[email-masked]
>     <mailto:[email-masked]>
>      >> <mailto:[email-masked]
>     <mailto:[email-masked]>>>
>      >>>      > Cc: DetNet WG <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>; detnet-
>      >> [email-masked] <mailto:[email-masked]>
>      >>>      <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      >>>      > Subject: Re: [Detnet] WG adoption poll
>     draft-geng-detnet-conf-yang
>      >>>      >
>      >>>      > Hi Janos, et. al,
>      >>>      > the mpls-detnet-header container is based on the
>     solution described in
>      >>>      > draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC
>     OAM in the
>      >> proposed
>      >>>      > MPLS data plane solution in draft-mirsky-detnet-oam
>     points to the
>      >> potential
>      >>>      > problem as result the fact that OAM packet doesn't
>     include d-CW. I
>      >> believe
>      >>>      > that this question should be discussed and, if we agree
>     on the problem
>      >>>      > statement, properly resolved. Until then, I do not
>     support the adoption
>      >> of
>      >>>      > the model that may not be capable to support active OAM.
>      >>>      >
>      >>>      > Regards,
>      >>>      > Greg
>      >>>      > On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas
>      >> <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >>>      > wrote:
>      >>>      > >
>      >>>      > > Dear all,
>      >>>      > >
>      >>>      > > This is start of a two week poll on making
>      >>>      > > draft-geng-detnet-conf-yang-04 a working group
>     document. Please
>      >> send
>      >>>      > > email to the list indicating "yes/support" or "no/do
>     not support".  If
>      >>>      > > indicating no, please state your reservations with the
>     document.  If
>      >>>      > > yes, please also feel free to provide comments you'd
>     like to see
>      >>>      > > addressed once the document is a WG document.
>      >>>      > >
>      >>>      > > The poll ends Oct 3.
>      >>>      > >
>      >>>      > > Thanks,
>      >>>      > > János and Lou
>      >>>      > >
>      >>>      > > _______________________________________________
>      >>>      > > detnet mailing list
>      >>>      > > [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>>      > > https://www.ietf.org/mailman/listinfo/detnet
>      >>>      >
>      >>>      > _______________________________________________
>      >>>      > detnet mailing list
>      >>>      > [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >>>      > https://www.ietf.org/mailman/listinfo/detnet
>      >>>
>      >>>
>      >>>
>     <mailto:[email-masked]>
>     Loa Andersson                        email: [email-masked] <mailto:[email-masked]>
>     Senior MPLS Expert

--

---

From: Loa Andersson <[email-masked]>
Date: Fri, 21 Sep 2018 18:55:25 +0800

Mach,

inline please

> To support this, I suggest to use ACH without GAL (of cause, a new ACH-type) for DetNet OAM (as bellow) and the "reserved" field  carries sequence number information, the "ACH" can be considered as…
what info do a node use to understand that the ACH is an ACH??

/Loa
>>>>> DetNet

--

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 21 Sep 2018 08:23:59 -0700

Hi Loa,
you've asked how a node identifies that the payload is ACH, not CW. As I
understand RFC 4385, it is by the value of the first nibble that follows
BoS label. ACH assigned value 0b0001, PW CW - 0b0000. 0b0100 defines IPv4,
and 0b0110 - IPv6.

Regards,
Greg

On Fri, Sep 21, 2018 at 3:55 AM Loa Andersson <[email-masked]> wrote:

> > New ACH type is fine, this is also needed for DetNet OAM, IMHO.  The
> crucial here is how to "cheat" the replication/elimination nodes that an
> OAM packet is a "normal" DetNet packet, then they can replicate/eliminate
> the OAM packets as normal DetNet packets. Otherwise, it needs to introduce
> additional replication/elimination processing for the DetNet OAM packets.
> >
> > To support this, I suggest to use ACH without GAL (of cause, a new
> ACH-type) for DetNet OAM (as bellow) and the "reserved" field  carries
> sequence number information, the "ACH" can be considered as the d-CW by the
> replication/elimination nodes.
> > +----------+
> > |S-Label  |
> > +----------+
> > |ACH        |
> > +----------+
> > | Payload|
> > +----------+
> >
> > If GAL is used ( the stack as below), additional processing has to be
> introduced at the replication/elimination nodes, because they have to parse
> GAL+ACH to decide how to process. That means, the OAM packets will have
> different replication/elimination process from the normal DetNet packets.
> >
> > +----------+
> > |S-Label  |
> > +----------+
> > |GAL        |
> > +----------+
> > |ACH        |
> > +----------+
> > | Payload|
> > +----------+
> >
> > Best regards,
> > Mach
> >
> octets
> >>>>>>>        mpls-denet-header,  seems that it can cover Active OAM case
> as
> >> well.
> >>>>>>>        For normal DetNet packets, the CW is the d-CW as defined in
> the

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 21 Sep 2018 08:30:14 -0700

Hi Loa,
DetNet OAM, in my view, is not another OAM function but includes FM and PM
OAM functions we have in any networking layer, e.g., IP or MPLS. I believe
we must have on-demand and proactive Fault Management OAM, as well as
Performance Monitoring OAM tool(s). Also, because of PREF, on-demand OAM
must be extended. Hence, my thought that BFD, RFC 6374, etc. ACH types may
be re-used on DetNet layer.

Regards,
Greg

On Fri, Sep 21, 2018 at 3:44 AM Loa Andersson <[email-masked]> wrote:

> it
> >      >>> thank you for your attention to my comment and the most
> expedient
> >      >> response.
> >      >>>
> encapsulation,
> >      >>>      > To: János Farkas <[email-masked]
> >      >>>      > Cc: DetNet WG <[email-masked] <mailto:[email-masked]>
> >      >>>      > draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC
> >     OAM in the
> >      >> proposed
> >      >>>      > MPLS data plane solution in draft-mirsky-detnet-oam
> >     points to the
> >      >> potential
> >      >>>      > problem as result the fact that OAM packet doesn't
> >     include d-CW. I
> >      >> believe
> >      >>>      > statement, properly resolved. Until then, I do not
> >     support the adoption
> >      >> of
> >     <mailto:[email-masked] <mailto:[email-masked]
> >>>
> >      >>>      > wrote:
> >      >>>      > >
> >      >>>      > > Dear all,
> >      >>>      > >
> >      >>>      > > draft-geng-detnet-conf-yang-04 a working group
> >     document. Please
> >      >> send

---

From: Loa Andersson <[email-masked]>
Date: Sat, 22 Sep 2018 12:49:26 +0800

Greg,

If ACH is self-identifying, why do we ever need the GAL?

/Loa

On 2018-09-21 23:23, Greg Mirsky wrote:
> BoS label. ACH assigned value 0b0001, PW CW - 0b0000. 0b0100 defines 
> IPv4, and 0b0110 - IPv6.
> 
> Regards,
> Greg
> 
> On Fri, Sep 21, 2018 at 3:55 AM Loa Andersson <[email-masked] 
>      > New ACH type is fine, this is also needed for DetNet OAM, IMHO. 
>     The crucial here is how to "cheat" the replication/elimination nodes
>     that an OAM packet is a "normal" DetNet packet, then they can
>     replicate/eliminate the OAM packets as normal DetNet packets.
>     Otherwise, it needs to introduce additional replication/elimination
>     processing for the DetNet OAM packets.
>      >
>      > To support this, I suggest to use ACH without GAL (of cause, a
>     new ACH-type) for DetNet OAM (as bellow) and the "reserved" field 
>     carries sequence number information, the "ACH" can be considered as
>     the d-CW by the replication/elimination nodes.
>      > +----------+
>      > |S-Label  |
>      > +----------+
>      > |ACH        |
>      > +----------+
>      > | Payload|
>      > +----------+
>      >
>      > If GAL is used ( the stack as below), additional processing has
>     to be introduced at the replication/elimination nodes, because they
>     have to parse GAL+ACH to decide how to process. That means, the OAM
>     packets will have different replication/elimination process from the
>     normal DetNet packets.
>      >
>      > +----------+
>      > |S-Label  |
>      > +----------+
>      > |GAL        |
>      > +----------+
>      > |ACH        |
>      > +----------+
>      > | Payload|
>      > +----------+
>      >
>      > Best regards,
>      > Mach
>      >
>      >> From: Loa Andersson [mailto:[email-masked] <mailto:[email-masked]>]
>      >>>> From: Loa Andersson [mailto:[email-masked] <mailto:[email-masked]>]
>     János Farkas
>      >>>> <[email-masked]
>     <mailto:[email-masked]>>; [email-masked]
>     sequence
>     János Farkas
>      >>>>>> <[email-masked]
>     <mailto:[email-masked]>>; [email-masked]
>      >>>>>>> This way, OAM can be supported without additional
>     processing and
>      >>>> states.
>      >>>>>>>
>      >>>>>>>            0                   1                   2
>      >>>>>>> 3
>      >>>>>>>
>      >>>>>>>            0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3
>     4 5 6 7
>      >>>>>>> 8 9
>      >>>>>>> 0
>      >>>>>>> 1
>      >>>>>>>
>      >>>>>>>
>      >>>>>>>
>      >>>>>>>           |0 0 0 1|Verion |    Reserved   |         Channel
>     Type
>      >>>>>>> |
>      >>>>>>>
>      >>>>>>>
>      >>>>>>>
>      >> <[email-masked] <mailto:[email-masked]>
>      >>>>>>>        mpls-denet-header,  seems that it can cover Active
>     OAM case as
>      >> well.
>      >>>>>>>        For normal DetNet packets, the CW is the d-CW as
>     defined in the
>     <mailto:Janos.Farkas@ericsson..com>>>
>      >>>>>>>        > Cc: DetNet WG <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>;
>      >>>>>>> detnet-
>     solution
>      >>>> described in
>      >>>>>>>        > draft-ietf-detnet-dp-sol-mpls. Analysis of active
>     SFC OAM
>      >>>>>>> in the
>      >>>>>> proposed
>      >>>>>>>        > MPLS data plane solution in
>     draft-mirsky-detnet-oam points
>      >>>>>>> to the
>      >>>>>> potential
>     include
>      >>>>>>>        > that this question should be discussed and, if we
>     agree on
>      >>>>>>> the
>      >>>> problem
>     support
>      >>>>>> <[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     document.
>      >>>>>>>        > > email to the list indicating "yes/support" or
>     "no/do not
>      >>>> support".  If
>      >>>>>>>        > > yes, please also feel free to provide comments
>     you'd like to see

--

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 21 Sep 2018 22:00:53 -0700

Hi Loa,
as I understand, for consistency of using GAL. PW ACH preceded GAL, which
primarily for LSP OAM.

Regards,
Greg

On Fri, Sep 21, 2018, 21:49 Loa Andersson <[email-masked]> wrote:

> >      >>>>>>> elimination nodes do not need to differentiate whether it
> is a
> >      >>>>>>> d-CW or  a
> >      >>>> PW ACH .
> >      >>>>>>> Regarding sequence number, there are two ways to generate
> the
> >      >>>>>> sequence
> >      >>>>>>>        > Cc: DetNet WG <[email-masked]
> >      >>>>>>>        > the mpls-detnet-header container is based on the
> >     solution
> >      >>>> described in
> >      >>>>>>>        > > email to the list indicating "yes/support" or
> >     "no/do not
> >      >>>> support".  If
> >      >>>>>>>        > > indicating no, please state your reservations
> >     with the
> >      >>>> document.  If

---

From: Loa Andersson <[email-masked]>
Date: Sat, 22 Sep 2018 13:06:22 +0800

Greg,

can't this be done in a uniform way? E.g. :

0                                  31
+--------+--------+--------+--------+
|         MPLS Label Stack          |
+--------+--------+--------+--------+
|          GAL (s-bit = 1)          |
+--------+--------+--------+--------+
|    ACH – Type = DetNet OAM |
+--------+--------+--------+--------+
|     Header of DetNet OAM          | tot len and number of elements
+--------+--------+--------+--------+
|                                   | e.g. proactive Fault Man. OAM
~   DetNet OAM Element (DOE) 1      ~
|                                   |
+--------+--------+--------+--------+
~                                   ~ etc.
+--------+--------+--------+--------+
|                                   |
~  DetNet OAM Element (DOE) n-1     ~ e.g Perf. Mon. OAM tool(s)
|                                   |
+--------+--------+--------+--------+
|                                   |
~   DetNet OAM Element (DOE) n      ~ etc.
|                                   |
+--------+--------+--------+--------+
|                                   |
~   Upper Layer Protocols/Payload   ~
|                                   |
+--------+--------+--------+--------+

The you just give each lemenet a structure, reuse whatever you want.

/Loa

On 2018-09-21 23:30, Greg Mirsky wrote:
> Hi Loa,
> DetNet OAM, in my view, is not another OAM function but includes FM and 
> PM OAM functions we have in any networking layer, e.g., IP or MPLS. I 
> believe we must have on-demand and proactive Fault Management OAM, as 
> well as Performance Monitoring OAM tool(s). Also, because of PREF, 
> on-demand OAM must be extended. Hence, my thought that BFD, RFC 6374, 
> etc. ACH types may be re-used on DetNet layer.
> 
> Regards,
> Greg
> 
> On Fri, Sep 21, 2018 at 3:44 AM Loa Andersson <[email-masked] 
>          > But then we'll need to re-define number
>      > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      >     Mach,
>      >
>      >      > Loa,
>      >      > GAL is just an OAM indicator, the problem here is that when do
>      >      > My suggestion is to use the reserved field of ACH to carry
>      >      > Best regards,
>      >      > Mach
>      >      >> -----Original Message-----
>      >      >> From: detnet [mailto:[email-masked]
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked]
>     <mailto:[email-masked]>>] On Behalf Of Loa Andersson
>      >      >> Sent: Thursday, September 20, 2018 3:21 PM
>      >      >> To: Mach Chen <[email-masked]
>      >     <mailto:[email-masked] <mailto:[email-masked]>>>;
>     Greg Mirsky
>      >      >> <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >      >> Cc: DetNet WG <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>; János
>      >     Farkas
>      >      >> <[email-masked]
>     <mailto:[email-masked]>>>;
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >      >> Subject: Re: [Detnet] Regarding the model for Active OAM
>     packet
>      >      >>
>      >      >> Mach,
>      >      >>
>      >      >> If I understand you correctly this is for an LSP in an MPLS
>      >     network, can you
>      >      >> help me understand why GAL does not enough. Given that there
>      >     might be
>      >      >> some minor extensions to GAL because of replication and
>     elimination.
>      >      >>
>      >      >> /Loa
>      >      >>
>      >      >> On 2018-09-19 14:31, Mach Chen wrote:
>      >      >>> Hi Greg,
>      >      >>>
>      >      >>> Indeed, there is no DetNet Associated Channel defined in
>      >      >>> draft-ietf-detnet-dp-sol-mpls for now, I think there
>     should be.  I
>      >      >>> also assume that PW ACH will be used for DetNet OAM.
>      >      >>>
>      >      >>> Assume that PW ACH will be used for DetNet OAM and the
>     reserved
>      >     filed
>      >      >>> of the PW ACH will be used to carry sequence number for
>     OAM packet.
>      >      >>> But
>      >      >>>    for PREF, a tricky way is to treat the “Version”+
>     “Reserved” +
>      >      >>> ”Channel type” as the Sequence number, the replication or
>      >     elimination
>      >      >>> nodes do not need to differentiate whether it is a d-CW
>     or  a
>      >     PW ACH .
>      >      >>> This way, OAM can be supported without additional processing
>      >     and states.
>      >      >>>
>      >      >>>          0                   1
>      >     2                   3
>      >      >>>
>      >      >>>          0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3
>     4 5 6
>      >     7 8 9 0
>      >      >>> 1
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>>         |0 0 0 1|Verion |    Reserved   |        
>     Channel Type
>      >      >>> |
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>> Regarding sequence number, there are two ways to
>     generate the
>      >      >> sequence
>      >      >>> number IMHO:  1) generated by the edge node, but it may
>     need to
>      >      >>> configure the start number, or 2) copied from the
>      >     application-flow (if
>      >      >>> there is). If the WG agree with this, the model can be
>     updated
>      >     reflect
>      >      >>> this.
>      >      >>>
>      >      >>> Best regards,
>      >      >>>
>      >      >>> Mach
>      >      >>>
>      >      >>> *From:*Greg Mirsky [mailto:[email-masked]
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>>]
>      >      >>> *Sent:* Wednesday, September 19, 2018 11:29 AM
>      >      >>> *To:* Mach Chen <[email-masked]
>      >     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >      >>> *Cc:* János Farkas <[email-masked]
>     <mailto:[email-masked]>>>; DetNet WG
>      >      >>> <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>;
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >      >>> *Subject:* Re: Regarding the model for Active OAM packet
>      >      >>>
>      >      >>> Hi Mach,
>      >      >>>
>      >      >>> thank you for your attention to my comment and the most
>     expedient
>      >      >> response.
>      >      >>>
>      >      >>> I don't find the DetNet Associated Channel defined in
>      >      >>> draft-ietf-detnet-dp-sol-mpls and thus I assumed that OAM
>      >     packets that
>      >      >>> follow the data packet encapsulation defined in that
>     draft use
>      >     PW ACH
>      >      >>> as defined in section 5 RFC 4385: True, it includes 8
>     bits-long
>      >      >>> Reserved field that may be defined as OAM Sequence
>     Number but that
>      >      >> had
>      >      >>> not been discussed. One is certain, existing nodes do
>     not check the
>      >      >>> Reserved field. And without a field to hold the sequence
>      >     number, PREF
>      >      >>> will not handle the OAM packets. Another question,
>     additional
>      >      >>> processing and amount of state introduced in the fast
>     path by
>      >     the fact
>      >      >>> that OAM's Sequence Number will have different length and
>      >     location in
>      >      >>> d-CW (differentiating cases by the first nibble).
>      >      >>>
>      >      >>> Now, if we step back from DetnNet in MPLS data plane
>     encapsulation,
>      >      >>> why the control-word, as I understand, is configurable?
>     I think
>      >     that
>      >      >>> the Sequence Number is not configurable, nor the first
>     nibble.
>      >     What do
>      >      >>> you think?
>      >      >>>
>      >      >>> Regards,
>      >      >>>
>      >      >>> Greg
>      >      >>>
>      >      >>> On Tue, Sep 18, 2018 at 7:48 PM Mach Chen
>     <[email-masked] <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>>
>      >      >>> <mailto:[email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>>> wrote:
>      >      >>>
>      >      >>>      Hi Greg,
>      >      >>>
>      >      >>>      The MPLS DetNet header is defined as below:
>      >      >>>
>      >      >>>      grouping mpls-detnet-header {
>      >      >>>           description
>      >      >>>               "The MPLS DetNet encapsulation header
>     information.";
>      >      >>>           leaf service-label {
>      >      >>>             type uint32;
>      >      >>>             mandatory true;
>      >      >>>             description
>      >      >>>               "The service label of the DetNet header.";
>      >      >>>           }
>      >      >>>           leaf control-word {
>      >      >>>             type uint32;
>      >      >>>             mandatory true;
>      >      >>>             description
>      >      >>>               "The control word of the DetNet header.";
>      >      >>>           }
>      >      >>>         }
>      >      >>>
>      >      >>>      Although do not consider Active OAM when design the
>     above
>      >      >>>      mpls-denet-header,  seems that it can cover Active OAM
>      >     case as well.
>      >      >>>      No matter a normal DetNet packet or an Active OAM
>     packet,
>      >     there
>      >      >>>      should be a CW field, just as defined above.
>      >      >>>
>      >      >>>      For normal DetNet packets, the CW is the d-CW as
>     defined
>      >     in the
>      >      >>>      draft-ietf-detnet-dp-sol-mpls.
>      >      >>>
>      >      >>>      For OAM packets, the CW is the "DetNet Associated
>     Channel".
>      >      >>>
>      >      >>>      Best regards,
>      >      >>>      Mach
>      >      >>>
>      >      >>>
>      >      >>>      > -----Original Message-----
>      >      >>>      > From: detnet [mailto:[email-masked]
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked]
>     <mailto:[email-masked]>> <mailto:detnet- <mailto:detnet->
>     <mailto:detnet- <mailto:detnet->>
>      >      >> [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:bounces@ietf..org>>>] On Behalf
>      >      >>>      Of Greg Mirsky
>      >      >>>      > Sent: Wednesday, September 19, 2018 3:17 AM
>      >      >>>      > To: János Farkas <[email-masked]
>     <mailto:[email-masked]>>
>      >      >> <mailto:[email-masked]
>     <mailto:[email-masked]>>>>
>      >      >>>      > Cc: DetNet WG <[email-masked]
>     <mailto:[email-masked]>>
>      >     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>>; detnet-
>      >      >> [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>
>      >      >>>      <mailto:[email-masked]
>      >     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >      >>>      > Subject: Re: [Detnet] WG adoption poll
>      >      >>>      >
>      >      >>>      > Hi Janos, et.. al,
>      >      >>>      > the mpls-detnet-header container is based on the
>      >     solution described in
>      >      >>>      > draft-ietf-detnet-dp-sol-mpls. Analysis of active SFC
>      >     OAM in the
>      >      >> proposed
>      >      >>>      > MPLS data plane solution in draft-mirsky-detnet-oam
>      >     points to the
>      >      >> potential
>      >      >>>      > problem as result the fact that OAM packet doesn't
>      >     include d-CW. I
>      >      >> believe
>      >      >>>      > that this question should be discussed and, if we
>     agree
>      >     on the problem
>      >      >>>      > statement, properly resolved. Until then, I do not
>      >     support the adoption
>      >      >> of
>      >      >>>      > the model that may not be capable to support
>     active OAM.
>      >      >>>      >
>      >      >>>      > Regards,
>      >      >>>      > Greg
>      >      >>>      > On Tue, Sep 18, 2018 at 12:03 PM Janos Farkas
>      >      >> <[email-masked]
>     <mailto:[email-masked]>>
>     <mailto:[email-masked]>>>>
>      >      >>>      > wrote:
>      >      >>>      > >
>      >      >>>      > > Dear all,
>      >      >>>      > >
>      >      >>>      > > This is start of a two week poll on making
>      >      >>>      > > draft-geng-detnet-conf-yang-04 a working group
>      >     document. Please
>      >      >> send
>      >      >>>      > > email to the list indicating "yes/support" or
>     "no/do
>      >     not support".  If
>      >      >>>      > > indicating no, please state your reservations
>     with the
>      >     document.  If
>      >      >>>      > > yes, please also feel free to provide comments
>     you'd
>      >     like to see
>      >      >>>      > > addressed once the document is a WG document.
>      >      >>>      > >
>      >      >>>      > > The poll ends Oct 3.
>      >      >>>      > >
>      >      >>>      > > Thanks,
>      >      >>>      > > János and Lou
>      >      >>>      > >
>      >      >>>      > > _______________________________________________
>      >      >>>      > > detnet mailing list
>      >      >>>      > > [email-masked] <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >      >>>      > > https://www.ietf.org/mailman/listinfo/detnet
>      >      >>>      >
>      >      >>>      > _______________________________________________
>      >      >>>      > detnet mailing list
>      >      >>>      > [email-masked] <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      >      >>>      > https://www.ietf.org/mailman/listinfo/detnet
>      >      >>>
>      >      >>>
>      >      >>>
>      >      >>> _______________________________________________
>      >      >>> detnet mailing list
>      >      >>> [email-masked] <mailto:[email-masked]>
>      >      >>> https://www.ietf.org/mailman/listinfo/detnet
>      >      >>>
>      >      >>
>      >      >> --
>      >      >>
>      >      >>
>      >      >> Loa Andersson                        email: [email-masked]
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>>
>      >      >> Senior MPLS Expert
>      >      >> Bronze Dragon Consulting             phone: +46 739 81 21 64
>      >      >>
>      >      >> _______________________________________________
>      >      >> detnet mailing list
>      >      >> [email-masked] <mailto:[email-masked]>
>      >      >> https://www.ietf.org/mailman/listinfo/detnet
>     <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>      >     Senior MPLS Expert

--

---

From: Greg Mirsky <[email-masked]>
Date: Fri, 21 Sep 2018 23:04:41 -0700

Hi Loa,
that may work but the problem how ACH-based OAM packet been treated by
PREF, in my view, will still be there. d-CW and ACH/d-ACH both immediately
follow BoS label. d-CW includes the 28 bits-long Sequence Number field that
is used by the Elimination sub-function. PW ACH doesn't have any field that
may be monotonically increased. d-ACH may define the eight bits-long
Reserved field of PW ACH as Sequence Number, and then the Elimination
sub-function may treat 28 most significant bits as the sequence number.
That is what Mach and I will explore. There could be some problems but it
might work.

Regards,
Greg

On Fri, Sep 21, 2018 at 10:06 PM Loa Andersson <[email-masked]> wrote:

> >      >      >> <[email-masked] <mailto:[email-masked]>
> >      >      >> help me understand why GAL does not enough. Given that
> there
> >      >     might be
> >      >      >>> nodes do not need to differentiate whether it is a d-CW
> >     or  a
> >      >     PW ACH .
> processing
> >      >      >>>         |0 0 0 1|Verion |    Reserved   |
> >     Channel Type
> >      >      >>> |
> >      >      >>>
> >      >      >>>
> >      >      >>>
> >      >      >>> Regarding sequence number, there are two ways to
> >     generate the
> >      >      >> sequence
> >      >      >>> there is). If the WG agree with this, the model can be
> >     updated
> >      >     reflect
> >      >      >>> this.
> >      >      >>>
> >      >      >>> Best regards,
> >      >      >>>
> >      >      >>> Mach
> >      >      >>>
> >      >     <mailto:[email-masked] <mailto:[email-masked]
> >>]
> >      >      >>> <[email-masked] <mailto:[email-masked]>
> >      >      >>> follow the data packet encapsulation defined in that
> >     draft use
> >      >     PW ACH
> >      >      >>> processing and amount of state introduced in the fast
> >     path by
> >      >     the fact
> >      >      >>> why the control-word, as I understand, is configurable?
> >     I think
> >      >     that
> >      >      >>> the Sequence Number is not configurable, nor the first
> >     nibble.
> >      >     What do
> >      >      >>> you think?
> >      >      >>>
> >      >      >>> Regards,
> >      >      >>>
> >      >      >>> Greg
> >      >      >>>
> >      >      >>> <mailto:[email-masked]
> OAM
> >      >      >>>      No matter a normal DetNet packet or an Active OAM
> >     packet,
> >      >     there
> >      >      >> [email-masked] <mailto:[email-masked]>
> >      >     <mailto:[email-masked] <mailto:[email-masked]
> >>>
> >      >      >>>      > Hi Janos, et.. al,
> >      >      >>>      > that this question should be discussed and, if we
> >     agree
> >      >     on the problem
> >      >      >>>      > > yes, please also feel free to provide comments
> >     you'd
> >      >     like to see

---

From: Mach Chen <[email-masked]>
Date: Tue, 25 Sep 2018 01:55:54 +0000

Hi Loa,

Please see my reply inline...

> Sent: Friday, September 21, 2018 6:55 PM
> crucial here is how to "cheat" the replication/elimination nodes that an OAM
> packet is a "normal" DetNet packet, then they can replicate/eliminate the
> OAM packets as normal DetNet packets. Otherwise, it needs to introduce
> > To support this, I suggest to use ACH without GAL (of cause, a new ACH-
> type) for DetNet OAM (as bellow) and the "reserved" field  carries sequence
> number information, the "ACH" can be considered as the d-CW by the

The first nibble of the ACH field would be for that purpose. 

Best regards,
Mach
> >> you can define 65k ACH-types, what stops you from defining a ACH
> >> channel type for DetNet OAM, then define that the structure of the
> >> following octets in a way that you see fit (like (yes I'm inventing
> >> as I type, more thoughts should go into to this):
> >>
> >>          0          1          2          3
> >>>> is used, to support the replication or elimination, there has to be
> >>>> a sequence number filed. But ACH (as its current defined) does not
> >>>> have
> >> such a field.
> >>>>>
> >>>> packet or a normal packet, they could just treat the right 28 bits
> >>>> of the ACH as the sequence number ( or treat the ACH as the d-CW),
> >>>> then both OAM and replication/elimination can be supported.
> >>>>>
> >>>>> Best regards,
> >>>>> Mach
> >>>>>
> >>>>>>> draft-ietf-detnet-dp-sol-mpls for now, I think there should be.
> >>>>>>> I also assume that PW ACH will be used for DetNet OAM.
> >>>>>>>
> >>>>>>>      for PREF, a tricky way is to treat the “Version”+
> >>>>>>> “Reserved” + ”Channel type” as the Sequence number, the
> >>>>>>> replication or elimination nodes do not need to differentiate
> >>>>>>> whether it is a d-CW or  a
> >>>> PW ACH .
> >>>>>>> 7
> >>>>>>> configure the start number, or 2) copied from the
> >>>>>>> application-flow (if there is). If the WG agree with this, the
> >>>>>>> model can be updated reflect this.
> >>>>>>>
> >>>>>>> Best regards,
> >>>>>>>
> >>>>>>> Mach
> >>>>>>>
> >>>>>>> draft-ietf-detnet-dp-sol-mpls and thus I assumed that OAM
> >>>>>>> packets that follow the data packet encapsulation defined in
> >>>>>>> that draft use PW ACH as defined in section 5 RFC 4385: True, it
> >>>>>>> includes 8 bits-long Reserved field that may be defined as OAM
> >>>>>>> Sequence Number but that
> >>>>>> had
> >>>>>>>        mpls-denet-header,  seems that it can cover Active OAM
> >>>>>>> case as
> >> well.
> >>>>>>> <mailto:[email-masked]>>;
> >>>>>>> detnet-
> >>>>>> [email-masked]
> >>>>>>>        > that this question should be discussed and, if we agree
> >>>>>>> on the
> >>>> problem
> >>>>>>>        > > email to the list indicating "yes/support" or "no/do
> >>>>>>> not
> >>>> support".  If
> >>>>>>>        > > indicating no, please state your reservations with
> >>>>>>> the
> >>>> document.  If