Subject: [Detnet] DetNet Use Cases vs "Requirements"

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 26 Sep 2018 01:53:51 +0000

Hi Bryan,
Bryan wrote:

And may I ask why the WG decided not to have a requirement draft? Sorry if I missed some meetings or meeting minutes, but I really think a requirement document can be helpful for knowing the technique gaps and requirements

My understanding, as I tried to explain in my earlier email, is that at the start of DetNet WG, we were not certain of what results we could deliver, so we wanted a way to compromise between what was being asked and what we would deliver, thereby avoiding a situation where every architecture or design solution that was proposed would be blocked because there was some particular "Requirement(s)" which that design could not meet (such as "make it work on the open Internet"). We reasoned that we would rather push back on a particularly difficult requirement (such as that one) in the interest of providing a timely and generally useful solution.

So at this point I feel confident that the Use Cases draft as currently written does match up pretty well with what the DetNet Architecture and Design can deliver. So even though we are not using the word "requirements", I would say that what we have described in the Use Cases draft in terms of individual use case "asks" or "common themes" amounts to essentially the same thing as "requirements".

I suppose it could be argued that if we had created a Requirements draft that we could have adapted it over time in the same as we did the Use Cases draft. However my thinking is that usually "requirements" come before "architecture and design" whereas in our case we wanted to make it clear that we intended the two to evolve in tandem, with each one informing the other.

I hope this helps, and if not perhaps someone else can present their view.
Best,
Ethan (as Use Cases draft editor)

---

From: "Liubingyang (Bryan)" <[email-masked]>
Date: Wed, 26 Sep 2018 06:36:20 +0000

Hi Ethan,

Thank you very much for providing this background information. Now I understand :)

Best
Bingyang (Bryan)

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Wednesday, September 26, 2018 9:54 AM
To: [email-masked]; Liubingyang (Bryan) <[email-masked]>
Subject: [Detnet] DetNet Use Cases vs "Requirements"

Hi Bryan,
Bryan wrote:

---

From: "Liubingyang (Bryan)" <[email-masked]>
Date: Thu, 27 Sep 2018 01:44:28 +0000

Hi Ethan,

I read the common themes section of the draft.  I have two comments.
First, bounded jitter is explicitly required by multiple use cases as described in Section 2~10. But why is not jitter listed in the common themes?
Second, Section 11.2 describes "scalable size" in terms of link length, the number of nodes and hops. Indeed, this will also raise requirement on scalability of the control plane (e.g., resource discovery and reservation) and the data plane (flow management, i.e., shaping and scheduling) in terms of the number of flows, because the potential number of flows can grow faster than the number of nodes and hops. This requirement has been expressed explicitly or implicitly in use case sections. For example, in Section 10.5, network slicing needs to deal with scalable number of flows, and in Section 9.4 Blockchain needs distributed scalable control plane. So I suggest adding scalability as a common theme in Section 11.

best
Bingyang (Bryan)

From: detnet [mailto:[email-masked]] On Behalf Of Liubingyang (Bryan)
Sent: Wednesday, September 26, 2018 2:36 PM
To: Grossman, Ethan A. <[email-masked]>; [email-masked]
Subject: Re: [Detnet] DetNet Use Cases vs "Requirements"

Hi Ethan,

Best
Bingyang (Bryan)

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Wednesday, September 26, 2018 9:54 AM
To: [email-masked]<mailto:[email-masked]>; Liubingyang (Bryan) <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] DetNet Use Cases vs "Requirements"

Hi Bryan,
Bryan wrote:

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 27 Sep 2018 03:23:19 +0000

Hi Bryan,
Thank you for pointing out that bounded jitter is missing from the Use Case Common Themes, I have no idea how I missed that. I also agree that adding number of flows to Section 11.2. Scalable Size would be an improvement. I hope that at this stage of review it is not too late to add these.
Ethan.

From: Liubingyang (Bryan) <[email-masked]>
Sent: Wednesday, September 26, 2018 6:44 PM
To: Grossman, Ethan A. <[email-masked]>; [email-masked]
Subject: RE: DetNet Use Cases vs "Requirements"

Hi Ethan,

best
Bingyang (Bryan)

From: detnet [mailto:[email-masked]] On Behalf Of Liubingyang (Bryan)
Sent: Wednesday, September 26, 2018 2:36 PM
To: Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] DetNet Use Cases vs "Requirements"

Hi Ethan,

Best
Bingyang (Bryan)

Hi Bryan,
Bryan wrote: