Subject: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

From: Janos Farkas <[email-masked]>
Date: Fri, 14 Aug 2020 15:50:08 +0000

Hi,

This is start of a three week poll on making
draft-mirsky-detnet-ip-oam-03 a working group document. Please
send email to the list indicating "yes/support" or "no/do not
support".  If indicating no, please state your reservations with the
document.  If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.

The poll ends September 4.

Regards,
Janos and Lou

---

From: Greg Mirsky <[email-masked]>
Date: Sun, 16 Aug 2020 16:04:20 -0700

Hi Janos, Lou, et al.,
yes/support adoption as the co-author of the draft.
The draft is on the Informational track as the authors don't see the need
to define any new mechanism for OAM in DetNet over IP.

Regards,
Greg

On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas <Janos.Farkas=
[email-masked]> wrote:

> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 16 Aug 2020 23:47:00 -0400

Yes, I support making this a WG draft.

Cheers,
Andy

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Aug 2020 06:42:21 +0000

I support adoption too. Many thanks for thIs work Greg!

Pascal

Le 17 août 2020 à 05:47, Andrew G. Malis <[email-masked]> a écrit :

Cheers,
Andy

On Sun, Aug 16, 2020 at 7:04 PM Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Hi Janos, Lou, et al.,
yes/support adoption as the co-author of the draft.
The draft is on the Informational track as the authors don't see the need to define any new mechanism for OAM in DetNet over IP.

Regards,
Greg

On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas <Janos.Farkas=[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,
Janos and Lou
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Black, David" <[email-masked]>
Date: Mon, 17 Aug 2020 13:17:21 +0000

Yes, I support adoption of this draft (as a co-author).

Thanks, --David

From: detnet <[email-masked]> On Behalf Of Greg Mirsky
Sent: Sunday, August 16, 2020 7:04 PM
To: Janos Farkas
Cc: DetNet WG
Subject: Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

[EXTERNAL EMAIL]
Hi Janos, Lou, et al.,

Regards,
Greg

Regards,
Janos and Lou

---

From: Jeong-dong Ryoo <[email-masked]>
Date: Tue, 18 Aug 2020 13:42:27 +0900 (KST)

Hi,

Yes, I also support adoption.

Best regards,

Jeong-dong

-----Original Message-----
From: "Pascal Thubert (pthubert)" &lt;pthubert=[email-masked]&gt;
To: "Andrew G. Malis" &lt;[email-masked]&gt;;
Cc: "Greg Mirsky" &lt;[email-masked]&gt;; "Janos Farkas" &lt;janos.farkas=[email-masked]&gt;; "DetNet WG" &lt;[email-masked]&gt;;
Sent: 2020-08-17 (월) 15:42:59 (UTC+09:00)
Subject: Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Pascal

Le 17 août 2020 à 05:47, Andrew G. Malis &lt;[email-masked]&gt; a écrit&nbsp;:
Yes, I support making this a WG draft.
Cheers,
Andy

On Sun, Aug 16, 2020 at 7:04 PM Greg Mirsky &lt;[email-masked] mailto:[email-masked]&gt; wrote:
Hi Janos, Lou, et al.,yes/support adoption as the co-author of the draft.
The draft is on the Informational track as the authors don't see the need to define any new mechanism for OAM in DetNet over IP.

Regards,
Greg

On Fri, Aug 14, 2020 at 8:50 AM Janos Farkas &lt;Janos.Farkas=[email-masked] mailto:[email-masked]&gt; wrote:
Hi,
&nbsp;
This is start of a three week poll on making
draft-mirsky-detnet-ip-oam-03 a working group document. Please
send email to the list indicating "yes/support" or "no/do not
support".&nbsp; If indicating no, please state your reservations with the
document.&nbsp; If yes, please also feel free to provide comments you'd
like to see addressed once the document is a WG document.
&nbsp;
The poll ends September 4.
&nbsp;
Regards,
Janos and Lou

_______________________________________________detnet mailing [email-masked] mailto:[email-masked]://www.ietf.org/mailman/listinfo/detnet https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________detnet mailing [email-masked] mailto:[email-masked]://www.ietf.org/mailman/listinfo/detnet https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________detnet mailing [email-masked]://www.ietf.org/mailman/listinfo/detnet
_______________________________________________ detnet mailing list [email-masked] https://www.ietf.org/mailman/listinfo/detnet

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 19 Aug 2020 02:01:41 +0000

Yes, support!
One more comment: In the next version, I think some explanations about the relationship between OAM drafts (including draft-ietf-detnet-mpls-oam-01) and DetNet controller plane framework draft should be considered.

Best Regards
Xuesong

From: detnet [mailto:[email-masked]] On Behalf Of Janos Farkas
Sent: Friday, August 14, 2020 11:50 PM
To: DetNet WG <[email-masked]>
Subject: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi,

Regards,
Janos and Lou

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 18 Aug 2020 19:29:44 -0700

Hi Geng Xuesong,
thank you for your kind consideration of the draft and thoughtful
suggestion. I agree that the explanation of relationships among three
drafts will help readers. Will discuss that with authors of the
draft-malis-detnet-controller-plane-framework and
draft-ietf-detnet-mpls-oam.

Regards,
Greg

On Tue, Aug 18, 2020 at 7:01 PM Gengxuesong (Geng Xuesong) <
[email-masked]> wrote:

> Yes, support!
>
> One more comment: In the next version, I think some explanations about the
> relationship between OAM drafts (including draft-ietf-detnet-mpls-oam-01)
> and DetNet controller plane framework draft should be considered.
>
>
>
> Best Regards
>
> Xuesong
>
>
>
> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Janos
> Farkas
> *Sent:* Friday, August 14, 2020 11:50 PM
> *To:* DetNet WG <[email-masked]>
> *Subject:* [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03
>
>
>
> Hi,
>
>
>

---

From: "Gengxuesong (Geng Xuesong)" <[email-masked]>
Date: Wed, 19 Aug 2020 12:10:01 +0000

Sure Greg. Thanks for your advice!
Let’s have more discussions about this together, especially about what should be included in draft-malis-detnet-controller-plane-framework about OAM.

Best Regards
Xuesong

From: Greg Mirsky [mailto:[email-masked]]
Sent: Wednesday, August 19, 2020 10:30 AM
To: Gengxuesong (Geng Xuesong) <[email-masked]>
Cc: Janos Farkas <Janos.Farkas=[email-masked]>; DetNet WG <[email-masked]>
Subject: Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi Geng Xuesong,
thank you for your kind consideration of the draft and thoughtful suggestion. I agree that the explanation of relationships among three drafts will help readers. Will discuss that with authors of the draft-malis-detnet-controller-plane-framework and draft-ietf-detnet-mpls-oam.

Regards,
Greg

On Tue, Aug 18, 2020 at 7:01 PM Gengxuesong (Geng Xuesong) <[email-masked]<mailto:[email-masked]>> wrote:
Yes, support!
One more comment: In the next version, I think some explanations about the relationship between OAM drafts (including draft-ietf-detnet-mpls-oam-01) and DetNet controller plane framework draft should be considered.

Best Regards
Xuesong

From: detnet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Janos Farkas
Sent: Friday, August 14, 2020 11:50 PM
To: DetNet WG <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi,

Regards,
Janos and Lou

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 27 Aug 2020 07:43:21 +0000

Hello Greg:

Please find some review comments below

P4, 1st sentence: Nit; “specified” -> “is specified”

P4 section 3.1: We need to discuss the attack vector whereby the attacker would flood the DetNet Path with forged OAM and consume the available bandwidth

P4 section 3.2: We need to elaborate on the OAM behavior if there is a replication point. Also, how it plays with coding.

P5 Section 3: Suggestion to add 2 subsections,

  *   One on the 6TiSCH model that is echoed in the the personal sub of RAW architecture, see https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7, in particular section 7.3.
  *   One on IPPM and iOAM where the measurement fields are in the packet header, inserted by the source (or encapsulator)

Take care,

Pascal

From: detnet <[email-masked]> On Behalf Of Greg Mirsky
Sent: lundi 17 août 2020 01:04
To: Janos Farkas <Janos.Farkas=[email-masked]>
Cc: DetNet WG <[email-masked]>
Subject: Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03

Hi Janos, Lou, et al.,

Regards,
Greg

Regards,
Janos and Lou

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 31 Aug 2020 12:39:42 -0700

Hi Pascal,
thank you for your suggestions. I'll apply the editorial fix in the next
update of the draft, hope that is acceptable.
We've discussed your suggestions with the
authors draft-theoleyre-raw-oam-support.  Perhaps it might be more
appropriate to discuss these topics in the new draft that Lou has
recommended at the RAW WG meeting. The work has already started and we are
planning to share the first version before IETF-109. Do you think that
this is a reasonable approach?
I've added my answers, notes below in-line under GIM>> tag.

Kind regards,
Greg

On Thu, Aug 27, 2020 at 12:43 AM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> P4 section 3.1: We need to discuss the attack vector whereby the attacker
> would flood the DetNet Path with forged OAM and consume the available
> bandwidth
>
GIM>> Such a scenario is more likely applicable to DetNet in general. If
you agree, it will be considered in the new document that describes OAM in
DetNet.

>
>
> P4 section 3.2: We need to elaborate on the OAM behavior if there is a
> replication point. Also, how it plays with coding.
>
GIM>> I think that DetNet WG decided that PREOF is supported only in DetNet
with MPLS data plane. I agree with you, the document that defines OAM
functions specific to PREOF is required.

>    - One on the 6TiSCH model that is echoed in the the personal sub of
>    RAW architecture, see
>    https://tools.ietf.org/html/draft-pthubert-raw-architecture-04#section-7,
>    in particular section 7.3.
>
> GIM>> Thank you for your recommendation, will address this topic in the
new draft.

>
>    -
>    - One on IPPM and iOAM where the measurement fields are in the packet
>    header, inserted by the source (or encapsulator)
>
> GIM>> Thank you for this question! We will certainly discuss the
applicability of the methods to collect on-path telemetry information and
transport it for processing in the new DetNet OAM draft (and will add a
section on specifics of RAW to draft-theoleyre-raw-oam-support).

>
>    -
>
>
>
> Take care,
>
>
>
> Pascal
>
>
>
> *From:* detnet <[email-masked]> *On Behalf Of *Greg Mirsky
> *Sent:* lundi 17 août 2020 01:04
> *To:* Janos Farkas <Janos.Farkas=[email-masked]>
> *Cc:* DetNet WG <[email-masked]>
> *Subject:* Re: [Detnet] WG adoption poll on draft-mirsky-detnet-ip-oam-03
>
>
>
> Hi Janos, Lou, et al.,
>