Subject: [Detnet] New Version Notification for draft-varga-detnet-ip-preof-00.txt

From: Balázs Varga A <[email-masked]>
Date: Wed, 9 Jun 2021 10:23:45 +0000

Hi,

We have created a new draft to describe how to use PREOF in case of DetNet IP.
It works for both IP v4 and IPv6. Furthermore it reuses existing DetNet data plane 
solutions (e.g., [RFC8964], [RFC9025]) and allows with minimal implementation 
effort the DetNet service sub-layer for IP packet switched networks.

Comments/suggestions are welcome.

Cheers
Bala'zs

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, June 9, 2021 12:18 PM
To: Andrew G. Malis <[email-masked]>; Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>; Andrew Malis <[email-masked]>; Balázs Varga A <[email-masked]>; Janos Farkas <[email-masked]>
Subject: New Version Notification for draft-varga-detnet-ip-preof-00.txt

A new version of I-D, draft-varga-detnet-ip-preof-00.txt
has been successfully submitted by =?utf-8?q?Bal=C3=A1zs_Varga?= and posted to the IETF repository.

Name:		draft-varga-detnet-ip-preof
Revision:	00
Title:		Deterministic Networking (DetNet): PREOF for DetNet IP
Document date:	2021-06-09
Group:		Individual Submission
Pages:		12
URL:            https://www.ietf.org/archive/id/draft-varga-detnet-ip-preof-00.txt
Status:         https://datatracker.ietf.org/doc/draft-varga-detnet-ip-preof/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-varga-detnet-ip-preof

Abstract:
   This document describes how DetNet IP data plane can support the
   Packet Replication, Elimination, and Ordering Functions (PREOF) based
   on [RFC9025].

The IETF Secretariat

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 11 Jun 2021 09:01:12 +0100

This is a good approach which I support. However, I anticipate a counter attack by the SRv6 proponents that will propose putting the information in the suffix of the IPv6 address.

What you are doing is to create a set of underlay UDP/IP tunnels between an overlay set of DetNet nodes. I think it might be useful to clarify that as the underlying model.

- Stewart

> On 9 Jun 2021, at 11:23, Balázs Varga A <balazs.a.varga=[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 11 Jun 2021 09:19:46 +0000

Hello Stewart:

There's effectively an alternate proposal already on the table but it comes neither from MPLS thinking as this one does, or from SRv6 as you are suggesting below.
It's plain IPv6 and leverages the HbH Option Header.

The main benefit of the HbH OH is that it is placed immediately after the IPv6 header in plain sight for the DetNet nodes. 
Along a DetNet path there's the expectation that all nodes are under an administrative control so the usual issues against HbH OH like with middle boxes do not apply.

On the side the draft allows to separate the flow signaling from the path signaling used by the forwarding sublayer. This is useful for fate sharing, e.g., for OAM or QUIC flows.
Then there's provision for signaling network coding portions of the same packet, so the reordering is done only on the packet but the portions can be delivered in any order.

Please see: https://datatracker.ietf.org/doc/html/draft-pthubert-detnet-ipv6-hbh, I just republished.

Keep safe;

Pascal

> From: detnet <[email-masked]> On Behalf Of Stewart Bryant
> Sent: vendredi 11 juin 2021 10:01
> To: Balázs Varga A <balazs.a.varga=[email-masked]>
> Cc: Stewart Bryant <[email-masked]>; [email-masked]
> Subject: Re: [Detnet] New Version Notification for draft-varga-detnet-ip-
> preof-00.txt
> 
> This is a good approach which I support. However, I anticipate a counter
> attack by the SRv6 proponents that will propose putting the information in
> the suffix of the IPv6 address.
> 
> What you are doing is to create a set of underlay UDP/IP tunnels between an
> overlay set of DetNet nodes. I think it might be useful to clarify that as
> the underlying model.
> 
> - Stewart
> 
> > On 9 Jun 2021, at 11:23, Balázs Varga A
> <balazs.a.varga=[email-masked]> wrote:
> >
> > Hi,
> >
> > It works for both IP v4 and IPv6. Furthermore it reuses existing
> > DetNet data plane solutions (e.g., [RFC8964], [RFC9025]) and allows
> > with minimal implementation effort the DetNet service sub-layer for IP
> packet switched networks.
> >
> > To: Andrew G. Malis <[email-masked]>; Balázs Varga A
> > <[email-masked]>; Janos Farkas
> > <[email-masked]>; Andrew Malis <[email-masked]>; Balázs
> > Varga A <[email-masked]>; Janos Farkas
> > <[email-masked]>

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 11 Jun 2021 12:57:04 +0000

Hi Stewart,
Thank You for Your support.
Yes, this is based on underlay tunnels. 
We are happy to add further clarifications.
Cheers
Bala'zs

-----Original Message-----
From: Stewart Bryant <[email-masked]> 
Sent: Friday, June 11, 2021 10:01 AM
To: Balázs Varga A <[email-masked]>
Cc: Stewart Bryant <[email-masked]>; [email-masked]
Subject: Re: [Detnet] New Version Notification for draft-varga-detnet-ip-preof-00.txt

- Stewart

> with minimal implementation effort the DetNet service sub-layer for IP packet switched networks.
>

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 11 Jun 2021 13:04:48 +0000

Hi Pascal,

Thanks for the feedback and for the heads-up. I'm reviewing your draft, will come back to it.

Just for clarification "detnet-ip-preof" is fully in-line with existing DetNet RFCs, no extra data plane needed.

Cheers
Bala'zs

-----Original Message-----
From: Pascal Thubert (pthubert) <pthubert=[email-masked]> 
Sent: Friday, June 11, 2021 11:20 AM
To: Stewart Bryant <[email-masked]>; Balázs Varga A <[email-masked]>
Cc: [email-masked]
Subject: RE: [Detnet] New Version Notification for draft-varga-detnet-ip-preof-00.txt

Hello Stewart:

Keep safe;

Pascal

> Subject: Re: [Detnet] New Version Notification for 
> draft-varga-detnet-ip- preof-00.txt
> 
> This is a good approach which I support. However, I anticipate a 
> counter attack by the SRv6 proponents that will propose putting the 
> information in the suffix of the IPv6 address.
> 
> What you are doing is to create a set of underlay UDP/IP tunnels 
> between an overlay set of DetNet nodes. I think it might be useful to 
> clarify that as the underlying model.
> 
> - Stewart
> 
> > We have created a new draft to describe how to use PREOF in case of 
> > DetNet
> IP.
> > <[email-masked]>; Andrew Malis <[email-masked]>; 
> > Balázs Varga A <[email-masked]>; Janos Farkas 
> > has been successfully submitted by =?utf-8?q?Bal=C3=A1zs_Varga?= and 
> > posted
> to the IETF repository.
> >