Subject: [Detnet] charter update

From: Janos Farkas <[email-masked]>
Date: Mon, 14 Mar 2022 11:40:19 +0000

WG,

As mentioned in past meetings, we have been looking into our charter to permit the definition of additional data plane mechanisms, such as new traffic treatment/queuing mechanisms. Based on our discussions with our AD, we propose the changes below.  We expect to discuss these changes at IETF113 and the changes to be discussed by the IESG after our meeting. We have also taken this opportunity to revisit our milestones.

The current charter can be found at https://datatracker.ietf.org/wg/detnet/about/

For the Charter, we propose a fairly small change to the reference to forwarding in the Data Plane section to more generally refer to "treatment (including forwarding, service protection, and queuing)".  Note that DetNet already defines mechanisms for forwarding and service protection.  The proposed revision is as follows:

OLD

Data plane: This work will document how to use IP and/or MPLS, and
related OAM, to support a data plane method of flow identification
and packet forwarding over Layer 3. Other IETF defined data plane
technologies may also be used.

NEW

Data plane: This work will document how to use IP and/or MPLS, and
related OAM, to support a data plane method of flow identification
and packet treatment (including forwarding, service protection, and queuing)
over Layer 3. Other IETF defined data plane
technologies may also be used.

Again, our plan is to discuss this on the list, at IETF 113, and then submit to the IESG after IETF 113.

For Milestones, we are proposing the following:

March 2022    Submit DetNet first IP OAM document
April 2023    Submit controller plane framework
July 2022    Submit OAM framework  for publication
Apr 2022     Adopt Enhanced DetNet Data Plane Requirements  document
Jul 2022     Adopt  first Enhanced DetNet Data Plane solution document
Dec 2022     Submit Enhanced DetNet Data Plane Requirements document for publication
June 2023     Submit first Enhanced DetNet Data Plane solution document for publication

Here too, we'd like feedback on the list as well as at IETF 113.  We will make the changes after our meeting.

Thank you,
Janos and Lou

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 18 Mar 2022 15:24:15 +0800

Dear chairs and WG,
 
Thanks for posting the Detnet recharter proposal. I think it is great to expand Detnet in this direction. There have been a few drafts and discussion in this area in the past year.
 
My co-authors and I have been working on draft-liu-detnet-large-scale-requirements for enhancements required to deploy TSN/DETNET like mechanisms in large scale networks which may span over multiple domains.
As suggested from the earlier Detnet meetings, the latest version of this I-D has merged another requirement draft (draft-xiong-detnet-wide-area-ip-requirements). At the same time, comments from the offline reviews were also addressed. 
We think it could be a starting point to document the requirements and would appreciate the reviews and comments from the group.  

Regards,
Peng

[email-masked]
 
From: Janos Farkas
Date: 2022-03-14 19:40
To: DetNet WG
Subject: [Detnet] charter update
WG,