Subject: [Detnet] New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt

From: Peng Liu<[email-masked]>
Date: 11 Apr 2022 14:12:41 +0800

Dear all,

We have posted the new version of draft-liu-detnet-large-scale-requirements-02. Section 5 to cover the potential data plane requirement from the large scale deterministic networking was added.

We'd like to ask you to review the document.

Based on the WG's recharter discussion in ietf 113 and the earlier discussion on this document and its predecessors, we think this document can be used as the starting point of the milestone of “enhancement requirements” for WG.

If the responses are not too averse, we will request a call for adoption this month. Thanks. 

Regards,

Peng&amp;co authors

Peng Liu | 刘鹏

China Mobile | 移动研究院

mobile phone：13810146105

email:  [email-masked]

发件人: internet-drafts

时间: 2022/04/11(星期一)11:56

收件人: Jeong-dong Ryoo;Peng Liu;Quan Xiong;Toerless Eckert;Yizhou Li;

主题: New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt
A new version of I-D, draft-liu-detnet-large-scale-requirements-02.txt
has been successfully submitted by Peng Liu and posted to the
IETF repository.

Name:draft-liu-detnet-large-scale-requirements
Revision:02
Title:Requirements for Large-Scale Deterministic Networks
Document date:2022-04-11
Group:Individual Submission
Pages:17
URL:            https://www.ietf.org/archive/id/draft-liu-detnet-large-scale-requirements-02.txt
Status:         https://datatracker.ietf.org/doc/draft-liu-detnet-large-scale-requirements/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-liu-detnet-large-scale-requirements
Diff:           https://www.ietf.org/rfcdiff?url2=draft-liu-detnet-large-scale-requirements-02

Abstract:
   Aiming at the large-scale deterministic network, this document
   describes the technical and operational requirements when the
   different deterministic levels of applications co-exist and are
   transported over a wide area.  This document also describes the
   corresponding Deterministic Networking (DetNet) data plane
   enhancement requirements.

The IETF Secretariat

---

From: Zhoulei <[email-masked]>
Date: Fri, 15 Apr 2022 03:17:32 +0000

Dear Peng and all,

I hope everything goes well with you.

Good to see the draft to propose the requirements for large-scale deterministic network, which is also concerned by my side.

Since we also have tried to use the deterministic network techniques in a wider network. This document could be a good starting point.

Moreover, If possible, I would like to provide more considerations or implemented experiences for the encapsulation of the cycle-id, the explicit flow-id for IP in addition to 5 or 6 tuple, and other potential requirements in next versions.

BR
Lei Zhou
New H3C Technologies
From: detnet [mailto:[email-masked]] On Behalf Of Peng Liu
Sent: Monday, April 11, 2022 2:13 PM
To: detnet <[email-masked]>
Cc: detnet-chairs <[email-masked]>; draft-liu-detnet-large-scale-requirements <[email-masked]>
Subject: [Detnet] New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt

Dear all,

We have posted the new version of draft-liu-detnet-large-scale-requirements-02<https://datatracker.ietf.org/doc/draft-liu-detnet-large-scale-requirements/>. Section 5 to cover the potential data plane requirement from the large scale deterministic networking was added.

Regards,
Peng&co authors

Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105
email:  [email-masked]<mailto:[email-masked]>

发件人: internet-drafts<mailto:[email-masked]>
时间: 2022/04/11(星期一)11:56
收件人: Jeong-dong Ryoo<mailto:[email-masked]>;Peng Liu<mailto:[email-masked]>;Quan Xiong<mailto:[email-masked]>;Toerless Eckert<mailto:[email-masked]>;Yizhou Li<mailto:[email-masked]>;
主题: New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt

Name: draft-liu-detnet-large-scale-requirements
Revision: 02
Title: Requirements for Large-Scale Deterministic Networks
Document date: 2022-04-11
Group: Individual Submission
Pages: 17
URL: https://www.ietf.org/archive/id/draft-liu-detnet-large-scale-requirements-02.txt
Status: https://datatracker.ietf.org/doc/draft-liu-detnet-large-scale-requirements/
Htmlized: https://datatracker.ietf.org/doc/html/draft-liu-detnet-large-scale-requirements
Diff: https://www.ietf.org/rfcdiff?url2=draft-liu-detnet-large-scale-requirements-02

Abstract:

The IETF Secretariat

-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 15 Apr 2022 18:48:02 +0800

Hi Lei Zhou,

Thank you for your interest, we welcome any input of experience and comments. If you have any specific consideration, please feel free to contact us.

Regards,
Peng

[email-masked]
 
From: Zhoulei
Date: 2022-04-15 11:17
To: Peng Liu; detnet
CC: detnet-chairs; draft-liu-detnet-large-scale-requirements
Subject: RE: [Detnet] New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt
Dear Peng and all,

 

BR
Lei Zhou
New H3C Technologies
 
Dear all,

 

Regards,
Peng&co authors
 
Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105
 
发件人: internet-drafts
时间: 2022/04/11(星期一)11:56

Abstract:

The IETF Secretariat

---

From: <[email-masked]>
Date: Mon, 18 Apr 2022 19:55:47 +0800 (CST)

Hi PengLiu,

Thank you for thinking about the requirements of  large-scale deterministic networks. 
I read your new section 5 and feel that its content needs further revision. 
In general, it has obvious scheme implication, which should go beyond the scope of requirements documents. For example, flow id field as descibed in section 5.1, cyclic queuing MUST be supported as described in section 5.2, explicit path as described in section 5.4.

So, some comments for section 5:
1. It should not be limited to IPv6, and MPLS also needs to add queuing extension.
2. The description of the treatment of the enhanced data plane is necessary. The treatment includes service protection, forwarding and queuing.
3. The queue mechanism should not be limited to an individual mechanism, even for TSN it is still open to introduce more mechanisms. Not sure if there are data plane extensions for a general queue mechanism.

Regards,
PSF

------------------原始邮件------------------
发件人：PengLiu
收件人：detnet;
抄送人：detnet-chairs;draft-liu-detnet-large-scale-requirements;
日 期 ：2022年04月11日 14:09
主 题 ：[Detnet] New Version Notification for draft-liu-detnet-large-scale-requirements-02.txt
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

Dear all,

发件人: internet-drafts
时间: 2022/04/11(星期一)11:56

Abstract:

The IETF Secretariat