Subject: Last Call: DHCP Option for User Authentication Protocol to (fwd)

From: "Ralph E. Droms" <[email-masked]>
Date: Thu, 15 Oct 1998 18:03:40 -0400 (EDT)

The IESG has received a request from the Dynamic Host Configuration
Working Group to consider DHCP Option for User Authentication Protocol
<draft-ietf-dhc-options-uap-01.txt> as a Proposed Standard.

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by October 29, 1998.

Files can be obtained via
ftp://ftp.ietf.org/internet-drafts/draft-ietf-dhc-options-uap-01.txt

---

From: [email-masked] (Glenn Waters)
Date: Mon, 19 Oct 1998 10:10:45 -0400 (EDT)

this spec proposes that URLs be separated by a space character.  is that not
problematic if a URL contains a space?

/gww

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Ralph E. Droms
> Sent: Thursday, October 15, 1998 18:07
> To: Multiple recipients of list
> Subject: Last Call: DHCP Option for User Authentication Protocol to
> (fwd)
>
>
>

---

From: Mike Carney - SNT Internet Engineering <[email-masked]>
Date: Mon, 19 Oct 1998 13:01:01 -0400 (EDT)

> problematic if a URL contains a space?

Hi glenn,
	The space is used to differentiate one URL from another. The client would
need to parse this into a list of URLs (simple, since it can use the space
character as the separator).

Mike Carney
SNT Internet Engineering
Sun Microsystems, Inc.

---

From: Steve Drach <[email-masked]>
Date: Mon, 19 Oct 1998 13:10:57 -0400 (EDT)

>From RFC1738: "The space character is unsafe ....  All unsafe characters
must always be encoded within a URL."  So, the space character must be
represented by %20.  Further on in the RFC, it does say that whitespace
in URL's embedded in context (i.e. e-mail) should be ignored.  But this
option isn't really the kind of context it's refering to.  We can specify
that, for this option, a space seperates URLs.

---

From: [email-masked] (Glenn Waters)
Date: Mon, 19 Oct 1998 15:10:03 -0400 (EDT)

how do you tell if a space is separating two URLs or whether the space is
part of the URL?

/gww

> From: Mike Carney - SNT Internet Engineering
> [mailto:[email-masked]]
> Sent: Monday, October 19, 1998 10:28
> To: Glenn Waters
> Cc: Multiple recipients of list
> Subject: RE: Last Call: DHCP Option for User Authentication Protocol to
> (fwd)
>
>

---

From: Mike Carney - SNT Internet Engineering <[email-masked]>
Date: Mon, 19 Oct 1998 16:14:57 -0400 (EDT)

> how do you tell if a space is separating two URLs or whether the space is

As you said yourself, a space is an illegal character in an URL. Thus, steve's
draft is using a space to separate URLs within the field.

Mike Carney
SNT Internet Engineering
Sun Microsystems, Inc.

---

From: "metin" <[email-masked]>
Date: Mon, 19 Oct 1998 16:19:22 -0400 (EDT)

unsubscribe

---

From: [email-masked] (Larry Borsato)
Date: Mon, 19 Oct 1998 16:20:01 -0400 (EDT)

The RFC states that all unsafe characters (i.e. space) must be encoded
within an URL. So space = %20.

Best,
Larry

--------------------------------------------
Larry W. Borsato,   NetID Product Manager
Bay Networks, a Nortel Networks Business
Email:  mailto:[email-masked]
Phone:  +1 (613) 722-1921

> Glenn Waters
> Sent: Monday, October 19, 1998 3:12 PM

---

From: "metin" <[email-masked]>
Date: Mon, 19 Oct 1998 16:18:36 -0400 (EDT)

unsubscribe
-----Original Message-----
From: Glenn Waters <[email-masked]>
To: Multiple recipients of list <[email-masked]>
Date: Monday, October 19, 1998 9:16 PM
Subject: RE: Last Call: DHCP Option for User Authentication Protocol to
(fwd)