Subject: Subnet Selection Option Draft 02

From: Rob Stevens <[email-masked]>
Date: Thu, 17 Jun 1999 16:51:28 -0400 (EDT)

If I could just risk raising my head above the parapet
and risk having it blown off by all this exploding multicast ordnance...

I wondered if this draft could use some words of
explanation about the conditions under which a
DHCP server's reply will reach the client.

If giaddr is set, then the router configured with that
giaddr must know how to route to the subnet
implied by the subnet selection option. 
This is likely, and perhaps not controversial.

But when giaddr is not set (so the "proxy" is
on the same segment as the server) the
server is going to try and unicast to the
Ip address on the subnet-selected,
presumably by attempting to add an
entry to its own ARP table. But that
isn't going to work, because ARP caches
know that they are only supposed to have
IP's in them which are directly reachable.
The solution might be to force the server
to broadcast, as it would with the
Broadcast-bit set.

Also, when the proxy renews the address
the server will try a simple unicast, independant
of giaddr (which ought to be zero on a real renewal).
At some point a router will ARP for the IP address
being renewed. Is the "control plane" of the entity
in question going to respond to that ARP?

I realise the words "proxy" haven't been used in the
draft, but I still think these points should be addressed.

Rob Stevens

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 17 Jun 1999 17:42:29 -0400 (EDT)

>of giaddr (which ought to be zero on a real renewal).

	Ah, but it *could* be set, as for a
	rebinding, and that is what we should probably
	recommend, I'd say.

	Cheers -- Kim

---

From: "Glenn Waters" <[email-masked]>
Date: Tue, 22 Jun 1999 13:53:50 -0400 (EDT)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Kim
> Kinnear
> Sent: Thursday, June 17, 1999 17:43
> To: Multiple recipients of list
> Subject: Re: Subnet Selection Option Draft 02
>
>

could you clarify which you meant when you said "could be set",  the
broadcast bit or the giaddr?

i believe we need to say that the giaddr needs to be set.

---

From: Kim Kinnear <[email-masked]>
Date: Tue, 22 Jun 1999 14:49:35 -0400 (EDT)

>i believe we need to say that the giaddr needs to be set.

	Yes, I meant the giaddr, and I agree with you.

	Kim