Subject: static leases based on client_identifier?

From: Jan Krueger <[email-masked]>
Date: Fri, 4 Jun 1999 11:53:40 -0400 (EDT)

Hi,

is it possible to define static leases based on the client_identifier?
I already tried out to define static leases based on the hardware address like

		 hardware token-ring 00:50:04:38:69:e5;
		 fixed-address 10.147.248.72;

Can I use a statement like

		 clientID <whatever it is>;
		 fixed-address 10.147.248.72;
??

I also don't understand in the doku of version 2, whether the hostname parameter
in the host <hostname> {} statement can be used for that purpose or if it is 
checked againt the hostname or client_hostname parameter, the client
transmits in the DISCOVER and REQUEST. 

Thanks in advance.

Best regards.

Jan Krueger
-- 
[email-masked]     | CeBit98: thinking on demand business 
http://www.stud.uni-hannover.de/~jk/ | solutions improvement for a small planet

---

From: Ted Lemon <[email-masked]>
Date: Fri, 4 Jun 1999 12:53:37 -0400 (EDT)

> 		 fixed-address 10.147.248.72;

option dhcp-client-identifier <whatever>;

> transmits in the DISCOVER and REQUEST. 

Nope, it's just a label that's used internally.   You can, if you
want, have the server send it back to the client in the host-name
option by enabling use-host-decl-names.

			       _MelloN_