Subject: Reconfigure-Inits

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Mon, 7 May 2001 22:49:14 -0500

One item to consider ... presently, the -18 draft wording has the Reconfigure-Init (unicast case) going directly to the client. This means that this message bypasses any relay-agent. And, there is no mechanism to prevent this.

Might we want to consider that the server should save the relay-agent information (if any) along with the client information and use the relay-agent to forward the Reconfigure-Init to the client? This would either be the default (so that all traffic goes via the relay) and there's some negotiation to allow direct communication or to we allow the client and server to communicate directly and by default and have a mechanism to disable this?

I know there are many that would like to allow direct communication between client and server, but think of the security implications. It is easier to secure the server to relay-agent path than the server to client path, meaning the relay could easily drop any spoofed packets and never allow them into the network. Relay-agent logic is drop all Reconfigure-Init messages except those relayed thru me from a known list of server (and perhaps the Relay-Reply needs some special authentication information in addition). This is especially attractive in cable-modem and DSL environment I should think.

- Bernie Volz

---

From: Jim Bound <[email-masked]>
Date: Tue, 8 May 2001 00:29:25 -0400 (EDT)

There should be no use of relay agent for reconfigure-init at this point.
If we want to add it at a later date that is fine.  I do not think this is
important to get a spec out.  

/jim