Subject: RE: [dhcwg] DHC WG charter

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 09:36:32 -0400

Ralph,

I think we need to add something to the charter for Mobility and Prefix delegation for IPv6.  I think this team and group can do a lot of good and help with evolution of wireless networks and the integration of Mobile.  Specifically:

- Determine the requirements for DHC to support the dynamic renumbering of networks using fast path delegaion as CPE front end between ISP and Private Networks.

What do others think?  I just think we have work to do in this space and not sorted it all out yet.  But do we have to for a charter?

thanks
/jim

> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Thursday, June 13, 2002 8:27 AM
> To: [email-masked]
> Subject: [dhcwg] DHC WG charter
> 
> 
> The Internet ADs have suggested it is time (likely
> *way* past time) to revisit the DHC WG charter.  Here's a 
> first pass at
> what I see as the issues currently in front of the WG.  The 
> objectives are
> not presented in any particular order.
> 
> Please review and send your comments to the mailing list.  The goal is
> to have consensus on a list of objectives for final review at the WG
> meeting in Yokohama.
> 
> - Ralph
> 
> =====
> 
> The working group has the following primary objectives:
> 
> * Develop additional authentication protocols within the framework
>   defined in RFC3118, along with other mechanisms to mitigate the
>   threat of attacks on DHCP clients and servers:
>   - New RFC3118 protocols to address improved key management and
>     improved scalability
>   - Provide security for messages passed between relay agents and
>     servers
>   - Consider solutions for specific threats such as use of nonce
>     identifier to defend against DoS attacks through FORCERENEW from
>     off-path attackers
> 
> * Complete the specification of DHCP for IPv6 (DHCPv6):
>   - Gain acceptance and publication of current Internet Draft as
>     Proposed Standard
>   - Develop and publish specifications for options and other
>     extensions to DHCPv6, including those already published as
>     Internet Drafts:
>     + "DNS Configuration Options for DHCPv6"
>     + "Time Configuration Options for DHCPv6"
>     + "NIS Configuration Options for DHCPv6"
>     + "DSTM Ports Option for DHCPv6", "DSTM Options for DHCPv6"
>     + "Load Balancing for DHCPv6"
>   - Encourage independent implementations and conduct interoperability
>     testing
>   - Revise specification and publish for acceptance as Draft Standard
>     by 6/30/2002
>   - Develop extensions to DHCPv6 for prefix delegation, DNS
>     configuration, etc.
> 
> * Revise and submit the DHCP specification for acceptance as a Full
>   Standard
> 
> * Complete the specification and publish work in progress as
>   standards:
>   - Failover protocol
>   - DHCP/DDNS interaction
>   - SNMP MIB
>   - Host name options
>   - Other client and relay agent options
> 
> * Review new options for DHCP, as deemed appropriate by the working
>   group and/or the Internet area directors
> 
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 13 Jun 2002 09:02:52 -0500

Jim:

Yes mobility and prefix delegation would be good to consider. I think it

Regarding your addition:
>- Determine the requirements for DHC to support the dynamic renumbering
>of networks using fast path delegaion as CPE front end between ISP and
>Private Networks.

This seems too specific and I'm not exactly sure what it means. Perhaps the
requirement is to determine how DHCP can be used to assist in rapid
renumbering of networks?

- Bernie

-----Original Message-----
From: Bound, Jim [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 9:37 AM
To: Ralph Droms; [email-masked]
Subject: RE: [dhcwg] DHC WG charter

Ralph,

thanks
/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Jun 2002 15:22:21 -0400

Bernie,
 
Let me be more direct.  I want to see routers be able to use lightweight DHCP to support IPv6 information requests, router renumbering, and the like.  The below ext text is good but I am looking for us to extend the architecture of dhcp to support lightweight processes for router or gateways or what is now called edge-servers.  So I think it needs a separate bullet.
 
Let me think and come up with different wording?
 
p.s. Ralph - whats our time frame to discuss the charter?
 
thanks
/jim

-----Original Message-----
From: Bernie Volz (EUD) [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 10:03 AM
To: Bound, Jim; Ralph Droms; [email-masked]
Subject: RE: [dhcwg] DHC WG charter

Jim: 

- Bernie 

-----Original Message----- 
From: Bound, Jim [ mailto:[email-masked]] 
Sent: Thursday, June 13, 2002 9:37 AM 
To: Ralph Droms; [email-masked] 
Subject: RE: [dhcwg] DHC WG charter 

Ralph, 

thanks 
/jim 

> From: Ralph Droms [ mailto:[email-masked]]

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 13 Jun 2002 22:26:47 -0500

Jim:
 
That's fine by me. Just wasn't clear (to me) from your previous bullet.
 
- Bernie

-----Original Message-----
From: Bound, Jim [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 3:22 PM
To: Bernie Volz (EUD); Ralph Droms; [email-masked]
Subject: RE: [dhcwg] DHC WG charter

Bernie,

 
 
thanks
/jim

-----Original Message-----
From: Bernie Volz (EUD) [mailto:[email-masked]]
Sent: Thursday, June 13, 2002 10:03 AM
To: Bound, Jim; Ralph Droms; [email-masked]
Subject: RE: [dhcwg] DHC WG charter

Jim: 

- Bernie 

-----Original Message----- 
From: Bound, Jim [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, June 13, 2002 9:37 AM 
To: Ralph Droms; [email-masked] 
Subject: RE: [dhcwg] DHC WG charter 

Ralph, 

thanks 
/jim 

> From: Ralph Droms [ mailto:[email-masked] <mailto:[email-masked]> ] 
> https://www1.ietf.org/mailman/listinfo/dhcwg <https://www1.ietf.org/mailman/listinfo/dhcwg>  
> 

_______________________________________________ 
dhcwg mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/dhcwg <https://www1.ietf.org/mailman/listinfo/dhcwg>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 17 Jun 2002 10:19:19 -0400

Thomas,

Well I have the expertise to work on prefixes topic area so does Ralph for CPE and edge routers. Plus we can always add others.  Plus I think there are others here you may not be aware of with expertise your not aware of, which you did ask.

Lets assume we agree with you.  Where would you suggest this work exist in the IETF?

thanks
/jim

> From: Thomas Narten [mailto:[email-masked]]
> Sent: Friday, June 14, 2002 10:59 AM
> To: Ralph Droms
> Cc: [email-masked]
> Subject: Re: [dhcwg] DHC WG charter 
> 
> 
> Ralph,
> 
> Thanks for getting this discussion started.
> 
> I think the charter should be more specific here. What new protocols
> are needed? What problems need to be solved? The above is just a blank
> check to do unspecified work (not good).
> 
> A good deliverable.
> This might be good, but it seems like a prerequisite is to have a
> documented threat analysis. What are the primary threats to DHCP?
> Which ones are the ones that are important to address? Only then does
> it make sense to think about specfic solutions. 
> 
> I don't think this needs to be called out in the charter. WGs don't do
> interoperability testing per se. But interoperability reports are
> needed for advancing documents along the standards track.
> 
> I'm not sure I agree with this. I think the DHC needs to stick with
> its core expertise, which is the DHC core protocols, and reviewing
> options motivated from outside the WG from the perspective of being
> consistent with standard DHC operating practice.
> 
> But in terms of actually defining new options, I think that requires
> significant input AND MOTIVATION from the customers of the option. In
> the case of Prefix delegation, that seems like a broader problem,
> where a DHC solution might well be appropriate. But I don't think this
> should be driven by the DHC WG, since the problem is not inherently a
> DHC problem.
> 
> Does the DHC WG really have the expertise to do the prefix delegation
> work? I wouldn't immediately think so. They do have  expertise to
> review any options once it is determined what the prefix delegation
> solution requires.
> 
> So, I think better charter wording would say that the WG will review
> options whose impetus comes from other WGs. A number of the specific
> options mentioned above are really motivated by other WGs.
> 
> I guess I'm a cynic. If there is no realistic plan for doing this, I'd
> say leave it out of the charter.
> 
> The charter should not be a kitchen sink of all possible work
> items. It should capture the priority items the WG will work on over
> the next 12 months. One can easily recharter if something interesting
> pops up that should get attention.
> 
> What is the MIB item? Do we really need it?
> 
> >   - Host name options
> Thomas