Subject: [dhcwg] Temporary addresses

From: "Vijayabhaskar A K" <[email-masked]>
Date: Sat, 15 Jun 2002 19:35:34 +0530

We dont have T1 and T2 values for IA having temporary addreses
but the draft says that the temporary addresses can be renewed.
So, if the client wishes to renew the adddresses, 
when should the client renew the addresses?
Does it mean that the application has to trigger the renew
in the case, if it need to use the address for some more time?

RFC 3041 says the mechanism of generating random Interface IDs,
for subsequent addresses for the same interface of the node.
Does the DHCP server need to implement this mechanism for
allocating temporary addresses to the client?

Probabably, we can add some text to state that once a temporary 
address is released or lifetime expires, the server should
forget the bindings, unlike the normal addresses.
This will be helpful in allocating different addresses for the
subsequent request from the same node.

Vijayabhaskar A K
Hewlett Packard ESDI
91-80-2051424,9624-371137

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Sat, 15 Jun 2002 12:41:43 -0500

Vijay:

Correct - we don't have T1/T2 times for IA_TA. It is the clients choice as to when (and
if) to renew these. I would think it would following a policy similar to that specified
in RFC 3041 (to extend the preferred and/or valid lifetime). Essentially, the client
should start the renewal process early enough to continue using the address.

I don't think the DHCP server needs to follow the procedures of RFC 3041 in generating
temporary addresses. The DHCP server may not even have the client's link-local address
(interface identifier).

>forget the bindings, unlike the normal addresses.

For temporary addresses, there is good reason for the server to forget them as ever
being associated with a client after the valid lifetime expires (or it is released).
However, this may also be the case for normal addresses. For normal addresses, this
is really a server policy issue and up to the server (or administrator of the server
if configuration of this is allowed).

- Bernie

-----Original Message-----
From: Vijayabhaskar A K [mailto:[email-masked]]
Sent: Saturday, June 15, 2002 10:06 AM
To: [email-masked]
Subject: [dhcwg] Temporary addresses

Vijayabhaskar A K
Hewlett Packard ESDI