Subject: question on sending request to multiple servers

From: Vijaya Bhaskar A K <[email-masked]>
Date: Sat, 20 Jan 2001 13:20:50 +0530 (IST)

It is mentioned in the draft that at the expiration of T2,
the client initiates the request/reply message exchange.
This request message will be sent to a multicast address.
i have few questions on this.

1) Is this the request for assignment of a new ip-address to an IA? 
(OR) 
2) renewal of the a particular ip-address assigned to an IA?

case 1)
Since  this is a  multicast  message,  more than  server  can  assign an
IP-address.  This  means  for a single  reqeust,  the  client  gets many
IP-address.

case 2)
assume the server A which has assigned the particular ip-address
to the client is down. then, how can a server B renew the lease
for the ip-address assigned by server A? 

So, what is the actual use of sending the request message to mutiple
servers after the expiration of T2.

Regards,
Vijay

---

From: Ralph Droms <[email-masked]>
Date: Mon, 22 Jan 2001 11:15:44 -0500

>2) renewal of the a particular ip-address assigned to an IA?

The request at time T2 will be case 2.  So, it's OK if multiple servers 
respond (ignoring the problem of different lifetimes from different servers).

Other requests - e.g, the request at T1 - will be case 1.

- Ralph