Subject: RE: -16 rev of DHCPv6 spec

From: Ralph Droms <[email-masked]>
Date: Thu, 08 Feb 2001 06:09:17 -0500

Bernie asked the following questions about the DHCPv6 message header:

At 10:36 AM 11/28/00 -0500, Bernie Volz wrote:

>- In most of the message headers, there is the 16-byte client-link-local
>address. What about dropping the first 64-bits of this (the prefix)? It
>would save 8-bytes/packet. This is just a thought - there might be good
>reasons NOT to do this. But on the other hand, it would remove the need for
>servers/relays to validate that the prefix is the link local - instead, they
>pre-append the prefix when they need to use it as a link-local address. So,
>if we were to do this, we'd call this 64-bit field "interface ID" or
>something similar (at least based on RFC 2373 terminology).
>
> From RFC 2373, it appears that link local doesn't really consume the full
>64-bits before the interface-id, instead only the first 10 bits are really
>specified (with the next 54-bits being zero, though it is not clear that is
>REQUIRED).
>
>    |   10     |
>    |  bits    |        54 bits          |          64 bits           |
>    +----------+-------------------------+----------------------------+
>    |1111111010|           0             |       interface ID         |
>    +----------+-------------------------+----------------------------+

I'm a little leery of changing the DHCP message header based on the 
assumption that link-local addresses will always have the same 
format.  Discussion?

- Ralph

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 8 Feb 2001 10:39:55 -0600

Ralph, et al:

I was just suggesting this as a possibility since we might want to minimize the size of the packets. I do think it best to use/send all 128-bits just to be safe (perhaps in the future, we might want to allow something other than a link-local address here).

- Bernie

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Thursday, February 08, 2001 6:09 AM
To: DHCPv6 discussion list
Subject: RE: -16 rev of DHCPv6 spec

- Ralph

---

From: [email-masked]
Date: Thu, 8 Feb 2001 11:17:45 -0600

bernie,
 
FE80 is required or it is not a link local address.
 
/jim

-----Original Message-----
From: ext Bernie Volz (EUD) [mailto:[email-masked]]
Sent: Thursday,February 08,2001 11:40 AM
To: DHCPv6 discussion list
Subject: RE: -16 rev of DHCPv6 spec

Ralph, et al: 

I was just suggesting this as a possibility since we might want to minimize
the size of the packets. I do think it best to use/send all 128-bits just to
be safe (perhaps in the future, we might want to allow something other than
a link-local address here).

- Bernie 

-----Original Message----- 
From: Ralph Droms [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, February 08, 2001 6:09 AM 
To: DHCPv6 discussion list 
Subject: RE: -16 rev of DHCPv6 spec 

- Ralph

---

From: "Thirumalesh Bhat" <[email-masked]>
Date: Thu, 8 Feb 2001 09:26:20 -0800

I think we should keep the message header generic and not specific. This
would allow the protocol to handle scenarios that may develop as IPv6
evolves further..

thx

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Thursday, February 08, 2001 3:09 AM
To: DHCPv6 discussion list
Subject: RE: -16 rev of DHCPv6 spec

- Ralph