Subject: Server Preference Value in DHCPv6

From: [email-masked]
Date: Tue, 13 Mar 2001 11:38:43 +0530

I have a few doubts regarding the "preference" field.  I would like to know
the importance of server preference value from the client perspective.

In draft 17 it is mentioned that the setting of a server preference value
SHOULD be allowed by administrator. What decides a server to be of "high
prefernce" and how  does an administrator selects a value.
Does it depend upon
                  the number of addresses that a server can give
     (or) the link/relay through which the server receive the SOLICIT
messages
     (or) the efficiency of the machine ( ???? )
     (or) just an administrators option which is constant throughout.

thanks and regards
   Suresh Kodati
   IBM India Software Labs
  Email:- [email-masked]

---

From: [email-masked]
Date: Tue, 13 Mar 2001 07:45:16 -0600

thats really up to the customer isn't it.  we give them the tool to define
whats important to their network.

/jim

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Tuesday,March 13,2001 1:09 AM
> To: DHCPv6 discussion list
> Subject: Server Preference Value in DHCPv6
> 
> 
>

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Tue, 13 Mar 2001 11:59:41 -0600

Suresh:

These are good questions. I believe the simple answer is that it is for administrators to decide (whatever factors they want to use). You might think of it as if you have three servers servicing a network for redundancy (no failover type protocol), you want clients to get answers from the highest preference server first.

Note that a server can use different preferences on different networks. So, in the above three server situation, I could have all servers servicing all networks, but assign the first server highest priority over two networks, another highest over some others, and the third highest over the remaining.

The preference issue has gotten a bit messy, IMHO. Mainly because we now allow the Advertise to include options (such as the addresses offerred to the client). The problem here is what if a client receives three Advertisements but the one with the addresses (or other options) it really wants (whatever that means) is given the lowest preference? Can it use that one? Or MUST it use the highest?

The exact wording (if memory serves) actually uses SHOULD and MAY, so I guess the preferences are already watered down some.

I still think it has value. But, I think the client policies will generally be to chose the highest preference server that offers the "services" desired. (That factors in what the server returns as options in the Advertise.)

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, March 13, 2001 1:09 AM
To: DHCPv6 discussion list
Subject: Server Preference Value in DHCPv6

thanks and regards
   Suresh Kodati
   IBM India Software Labs