Subject: RE: [dhcwg] Options in base doc for DHCPv6

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Tue, 22 Jan 2002 19:21:22 -0600

Ralph:

I agree with this. It also means we can divide the work by having many people write drafts. Reviewing is also easier as people can focus on those documents that they feel are critical to them.

I also think your initial list of options looks good and is the basic set for protocol operation. It may not provide the basic set for client configuration and we might even argue that two, the Domain Search Option and Domain Name Server Option, could even be moved to that other document since they aren't related to the operational issues of the DHCP protocol. 

For IESG review, I think it will be important to point out that this is the basic set required for proper DHCP protocol operation and not the basic set to provide client configuration.

- Bernie

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Tuesday, January 22, 2002 2:56 PM
To: [email-masked]
Subject: [dhcwg] Options in base doc for DHCPv6

We've recently experienced a proliferation of proposed and defined options 
for DHCPv6.  Initially, the WG agreed to publish all options that were 
defined at the time the base spec was completed in the same doc.  I'm 
having second thoughts about that decision.  Here's what I'm thinking:

* The new options are adding more weight to
   an already hefty document
* Keeping all the options in one doc make
   updating any one option more complicated
* Reviewing all of these options will slow
   down the acceptance process

I propose that we put a moratorium on adding any new options to 
draft-ietf-dhc-dhcpv6-22.txt, and move any non-essential options out of 
draft-ietf-dhc-dhcpv6-22.txt into individual drafts.  The definition of 
"essential" is open to discussion; here's a first pass at a list of the 
options to retain in draft-ietf-dhc-dhcpv6-22.txt:

* DHCP unique identifier option
* Identity association option
* IA Address option
* Requested Temporary Addresses (RTA) Option
* Option request option
* Preference option
* Elapsed Time
* Client message option
* Server message option
* Authentication option
* Server unicast option
* Domain Search Option
* Domain Name Server Option
* Status Code Option

- Ralph

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Jim Bound <[email-masked]>
Date: Tue, 22 Jan 2002 23:40:37 -0500 (EST)

Bernie,

Again DNS options are needed NOW for IPv6 deployment.  Specifically for
IPv6 DNS Stateless discovery.

That which is needed for IPv6 deployment is as important to any option we
have in the spec.

Implementors like VJ and others need these now the reason is we are so
late with DHC6 for the market we do not have the luxury to not include
basic options which which are required by the IPv6 market early adopters.

So I would argue this should affect our thinking on this discussion.
Right now boot server for diskess nodes is less important to the market
(our customer here) than configured tunnel option.  

/jim