Subject: RE: [dhcwg] static route option for dhcpv6

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Tue, 15 Jan 2002 12:51:06 -0600

How about defining the option format?

I'd suggest we base this more on the Classless Static Routes option.

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |          OPTION_ROUTES        |             option-len        |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   .                                                               .
   .                           route-data                          .
   .                                                               .
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Where route-data is one or more of a sequence of route table entries
in the following format:

	1 byte <prefix-length>
	<n> byte <prefix address>
	16 byte destination address

Where <n> is the minimum number of bytes required to represent
<prefix-length> bits of the <prefix address>.

A /64 prefix has the following format: 1 byte prefix (value of 64),
8-bytes of the prefix, followed by 16 bytes destination address.

- Bernie Volz

-----Original Message-----
From: Vijayabhaskar A K [mailto:[email-masked]]
Sent: Tuesday, January 15, 2002 9:36 AM
To: [email-masked]
Subject: [dhcwg] static route option for dhcpv6

I have gone through the dhcpv6 22 spec.
I felt that, static route option (option 33 in RFC 2132) is missing.
which is useful for routing. Can we include this option
also in the spec? 
thanks and regards
Vijay

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Vijayabhaskar A K" <[email-masked]>
Date: Wed, 16 Jan 2002 23:43:12 +0530

RE: [dhcwg] static route option for dhcpv6Bernie,
This option format looks ok for me. We can include it.
Vijay
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bernie Volz (EUD)
  Sent: Wednesday, January 16, 2002 12:21 AM
  To: [email-masked]'; [email-masked]
  Subject: RE: [dhcwg] static route option for dhcpv6

      0                   1                   2                   3

          1 byte <prefix-length>

  - Bernie Volz