Subject: [dhcwg] Is ARP Check Up process needed for later RENEW/REBIND states???

From: "Gopi Krishna" <[email-masked]>
Date: Thu, 3 Jan 2002 08:19:22 -0800

Hi,
I have one doubt regarding the ARP check up process by the DHCP Client once it gets IP address information through DHCP ACK.
I did not understand from RFC whether this can be tested for the first DHCP ACK  from Server or it can be done for later RENEW/REBIND also.
But In some DHCP Client  implementations,I observerd that client is doing ARP Check even in RENEW also.Is it needed?
Could you please clafify this.

Thanks,
Gopi

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Alka Mohite" <[email-masked]>
Date: Fri, 4 Jan 2002 16:04:58 +0530

Hi

The rfc 2131, page 23 last but one para has a very confusing statement

"In all cases, when 'giaddr' is zero, the server broadcasts any DHCPNAK
messages to 0xffffffff".

Just before this line, you have explained the actions for combinations of
"giaddr" and "ciaddr", which contradicts with the above statements.

Can anyone, please clarify.

Thanks,

Alka.