Subject: Re: [dhcwg] Router option, in DHCPv6

From: Jean-Mickael Guerin <[email-masked]>
Date: Mon, 13 Sep 2004 12:24:15 +0200

There is the case when DHCPv6 client is a router that performs prefix 
delegation, and does not run any routing protocol. This router would 
just need a default gateway. I think setting this gateway to the 
delegating router is enough but perhaps some scenario may require an 
explicit gateway ?

Jean-Mickael

Bernie Volz wrote:

> I agree. We do not need this option.
> 
> If someone can demonstrate a solid need for this (either a list of =
> default
> routers or list of static routes), we will consider this. But if you =
> have no
> solid use case, this should be outside the scope of DHCPv6.=20
> 
> In IPv4, there was no basic mechanism for a host to find router(s) and =
> to
> discover whether addresses are on or off link (ICMP messages were added
> later, but I think they've been little used). This is a basic feature of
> IPv6.
> 
> - Bernie
> 
> 
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]=20
>>On Behalf Of Robert Elz
>>Sent: Friday, September 10, 2004 3:00 PM
>>To: Anil Kumar Reddy
>>Cc: [email-masked]
>>Subject: Re: [dhcwg] Router option, in DHCPv6=20
>>=20
>>=20
>>    Date:        Fri, 10 Sep 2004 19:32:22 +0530
>>    From:        "Anil Kumar Reddy" <[email-masked]>
>>    Message-ID:  <[email-masked]>
>>=20
>>  | 	I feel, having a router configuration option (similar to=20
>>  | 	DNS, SIP, NIS) would help the client's network connectivity=20
>>  | 	in the absence of RA.
>>=20
>>As a rationale, that's useless.   If there are no RAs, there are no
>>routers, RAs in v6 aren't optional.
>>=20
>>But, it might be perhaps useful to be able to configure a=20
>>particular router on a net with several - and perhaps=20
>>different routers for different hosts, which is something=20
>>that RAs cannot achieve, so the option shouldn't necessarily=20
>>simply be discarded as completely useless.
>>=20
>>Whether the benefit in allowing this is worth the extra=20
>>complexity I'm not sure I'd like to take a position on at the minute.
>>=20
>>kre
>>=20
>>=20
>>_______________________________________________
>>dhcwg mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/dhcwg
>>=20
> 
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg

-- 

Jean-Mickael GUERIN
Tel : +33 1 39 30 92 33
Web site : www.6wind.com

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 15 Sep 2004 10:35:21 -0400

Hi Anil,

In addition to what Bernie provided. 
> : A host can receive multiple RAs from two different
> : routers.  How the host defines its default or preferred route
> : from two routes is implementation defined.  Yes there is work
> : for router preferences I realize that, but that is not an
> : issue, as whether that is done or not implicit failover is
> : achieved from the IPv6 link and Neighbor Discovery
> : architecture and protocol messaging.
> 
> This leaves hosts to decide which path to take, so I feel, 
> there  is no control over "managing the network". This also 
> makes me to  ask one basic question: why do we need stateful, 
> dhcpv6, mechanism ?

Only in the sense to select a default route which is correct for the
host to do.  If it does no want to do that it will use
last-in-first-default method.  But route preference and default route as
I said is in discussion.

Statful is in my humble opinion for managers who will not permit
stateless to be used for address assignment and only for neighbor
discovery processing.  Many IT net admin/managers do not want routers to
give out nodes addresses we are finding in deployment.  I will not
discuss there reasons its none of my business its their networks and
they are in charge of their networks so lets not go there.  Stateful
also provides support for other configuration parameters for the network
not in neighbor discovery and now prefix delegation.  So DHCPv6 has many
benefits for IPv6.

> 
> And, just to be clear from my side, here the case is not with 
>  respect to failover mechanism and it is with respect to load 
>  balancing/distribution over two paths.

Bernie answered that.

> 
> Please clarify if I am wrong on any point.

Not wrong just maybe do not have all views of IPv6 efforts.  Also DHCPv6
WG should not be altering the base connectivity and interoperability of
the link on this list this is for IPv6 WG and would have to approve.
But don't go there if you loose the battle here and give up, without
DHCPv6 support for your idea your not on solid ground and this is good
place to run the idea don't get my view wrong.

Thanks
/jim
> 
> --
> Thanks,
> Anil
> 
> : Adding more
> : superferlous state to a stateless link is not congruent with
> : the IPv6 architecture or with existing practice for IPv6
> : deployment and use cases.  I suggest we leave RAs/RSs to
> : routers and stateless, and stateful to DHCPv6 which could be
> : on a platform that can support holding light state or serious
> : heavy weight state like bzillions of records and data.  So
> : not only do I not see a compelling reason for this option or
> : thought process, but now after thinking about it believe it
> : is in conflict with the IPv6 architecture principals that are
> : imperative to the proper functioning of nodes for IPv6
> : deployment in practice.
> : 
> : Thanks
> : /jim
> : 
> : > -----Original Message-----
> : > From: [email-masked]
> : [mailto:[email-masked]] On Behalf
> : > Of Ralph Droms
> : > Sent: Wednesday, September 15, 2004 4:00 AM
> : > To: Anil Kumar Reddy
> : > Cc: [email-masked]; 'Bernie Volz'; 'Robert Elz'
> : > Subject: RE: [dhcwg] Router option, in DHCPv6
> : >
> : > Anil - the scenario you describe falls, I think, in the class of
> : > scenarios kre described:
> : >
> : > >But, it might be perhaps useful to be able to configure a
> : particular
> : > >router on a net with several - and perhaps different routers for
> : > >different hosts, which is something that RAs cannot
> : achieve, so the
> : > >option shouldn't necessarily simply be discarded as
> : > completely useless.
> : >
> : > Do we have any reason to believe, at this point, that load
> : balancing
> : > through explicit default router assignment will be used 
> in practice?
> : >
> : > - Ralph
> : >
> : > At 12:10 PM 9/15/2004 +0530, Anil Kumar Reddy wrote:
> : >
> : > >Thanks for your responses. Sorry for the delay in my response.
> : > >
> : > >I have a question :
> : > >Take a case of load balancing, where two routers present and
> : > >  we want to manage/configure few set of hosts (address range)
> : > >  to use one router and others to use a different one (two
> : > >  paths), how do we achieve this using RAs ?
> : > >
> : > >--
> : > >Thanks,
> : > >Anil
> : > >
> : > >: -----Original Message-----
> : > >: From: Bernie Volz [mailto:[email-masked]]
> : > >: Sent: Saturday, September 11, 2004 7:36 PM
> : > >: To: 'Robert Elz'; 'Anil Kumar Reddy'
> : > >: Cc: [email-masked]
> : > >: Subject: RE: [dhcwg] Router option, in DHCPv6
> : > >:
> : > >: I agree. We do not need this option.
> : > >:
> : > >: If someone can demonstrate a solid need for this (either a
> : > >: list of default routers or list of static routes), we will
> : > >: consider this. But if you have no solid use case, this should
> : > >: be outside the scope of DHCPv6.
> : > >:
> : > >: In IPv4, there was no basic mechanism for a host to find
> : > >: router(s) and to discover whether addresses are on or off
> : > >: link (ICMP messages were added later, but I think they've
> : > >: been little used). This is a basic feature of IPv6.
> : > >:
> : > >: - Bernie
> : > >:
> : > >: > -----Original Message-----
> : > >: > From: [email-masked]
> : > >: [mailto:[email-masked]] On Behalf
> : > >: > Of Robert Elz
> : > >: > Sent: Friday, September 10, 2004 3:00 PM
> : > >: > To: Anil Kumar Reddy
> : > >: > Cc: [email-masked]
> : > >: > Subject: Re: [dhcwg] Router option, in DHCPv6
> : > >: >
> : > >: >
> : > >: >     Date:        Fri, 10 Sep 2004 19:32:22 +0530
> : > >: >     From:        "Anil Kumar Reddy" <[email-masked]>
> : > >: >     Message-ID:  
> <[email-masked]>
> : > >: >
> : > >: >   |         I feel, having a router configuration option
> : > >: (similar to
> : > >: >   |         DNS, SIP, NIS) would help the client's network
> : > >: connectivity
> : > >: >   |         in the absence of RA.
> : > >: >
> : > >: > As a rationale, that's useless.   If there are no RAs, 
> : > there are no
> : > >: > routers, RAs in v6 aren't optional.
> : > >: >
> : > >: > But, it might be perhaps useful to be able to configure a
> : > >: particular
> : > >: > router on a net with several - and perhaps different
> : routers for
> : > >: > different hosts, which is something that RAs cannot
> : > achieve, so the
> : > >: > option shouldn't necessarily simply be discarded as 
> completely
> : > >: > useless.
> : > >: >
> : > >: > Whether the benefit in allowing this is worth the extra
> : > >: complexity I'm
> : > >: > not sure I'd like to take a position on at the minute.
> : > >: >
> : > >: > kre
> : > >: >
> : > >: >
> : > >: > _______________________________________________
> : > >: > dhcwg mailing list
> : > >: > [email-masked]
> : > >: > https://www1.ietf.org/mailman/listinfo/dhcwg
> : > >: >
> : > >:
> : > >:
> : > >
> : > >
> : > >
> : > >_______________________________________________
> : > >dhcwg mailing list
> : > >[email-masked]
> : > >https://www1.ietf.org/mailman/listinfo/dhcwg
> : >
> : >
> : > _______________________________________________
> : > dhcwg mailing list
> : > [email-masked]
> : > https://www1.ietf.org/mailman/listinfo/dhcwg
> : >
> : 
> : 
> 
> 
>