Subject: RE: Address lifetime extension and configuration changes in respo nse to Confirm (Was: RE: A few additional items re: -19 draft)

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 26 Jul 2001 17:03:40 -0500

Yes, by all means we need to clean up the language.

I would also suggest that we add language to state that clients do not send
nor should expect to get other configuration related options (such as Domain Name,
Domain Server Addresses, etc) on the Confirm/Reply sequence.

We do have to be a bit careful here as there could be options that are important
to send (especially in the future as new options get defined).

- Bernie

-----Original Message-----
From: Ted Lemon [mailto:[email-masked]]
Sent: Thursday, July 26, 2001 5:54 PM
To: DHCPv6 discussion list
Subject: Re: Address lifetime extension and configuration changes in
respo nse to Confirm (Was: RE: A few additional items re: -19 draft) 

> By NAK I assume we mean "NoPrefixMatch" type error.
> 
> By ACK I assume we mean "the prefixes you're using are valid for the link"
> (no indication of whether the addresses themselves are).
> 
> I think that's all the Confirm needs to say since I believe all it was
> intended to communicate was whether the client was still on the same
> link.

This sounds fine, but the present language for this message needs to
be clarified to make this more clear.

			       _MelloN_

---

From: Jim Bound <[email-masked]>
Date: Fri, 27 Jul 2001 12:11:47 -0400 (EDT)

good point.  we want to do this for the list you sent but tomorrow we may
want to send an option that is not relative to address configuration
though I can't think of one right now.

/jim