Subject: Vicarious DHCP

From: Jimmy Bush <[email-masked]>
Date: Wed, 18 Jul 2001 07:45:24 -0700 (PDT)

Is there any mechanism or has anyone ever successfully
completed a vicarious DHCP interaction?  By this I
mean that I would like to use a PC to perform all
interaction with a server and then send all revelant
information to a unit incapable of DHC.  I can do it
if I am on the same subnet as the device and stick my
NIC into promiscous mode, but is there a cleaner way,
a way that could be extended to larger networks or
different topologies?  
Thanks in advance for any help.

Regards,

Jimmy Bush

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: "Christopher B. Zydel" <[email-masked]>
Date: Wed, 18 Jul 2001 10:58:40 -0400

Are you using some sort of test program to act as a DHCP client
for testing purposes?  If this is the case, you may want to have
it handle the packets as if it were a relay agent by filling in giaddr
with an address on the subnet that you will be populating with leases.  In
this case, you would have your program unicast its transactions directly
to the DHCP server, and the subnet that you will be populating with leases
should be routed to the host running the test program.

This mechanism has worked well for us for the purpose of performance and
client processing testing. 

/cbz