Subject: RE: [dhcwg] I-D ACTION:draft-ietf-dhc-server-override-00.txt

From: "Kostur, Andre" <[email-masked]>
Date: Fri, 14 Feb 2003 11:50:49 -0800

> > 1) This introduces a new point of failure in a DHCP 
> infrastructure.  
> > If this particular relay goes down, then devices which 
> currently hold 
> > a lease cannot renew, where under standard DHCP, they would 
> be able > to.
> 
> Not true.   They can still renew in the REBINDING state - just not in 
> the RENEWING state.
> 
> Your observation about the wording of when the DHCP server should pay 
> attention to this option makes sense, though - I wonder where 
> that came 
> from.

Assuming that the Draft is modified to have the DHCP server always pay
attention to the sub-option, what about the initial DHCPREQUEST (the one
sent in response to an Offer) arriving at the DHCP server with a ServerID
that isn't the DHCP Server's IP?  Wouldn't that mean to the server that it
should _not_ pay attention to this packet since it is intended for a
different DHCP server?

---

From: Ted Lemon <[email-masked]>
Date: Fri, 14 Feb 2003 13:58:34 -0600

> should _not_ pay attention to this packet since it is intended for a

Yes, that needs to be addressed.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg