Subject: [dhcwg] RE: DHCP issue in draft-palet-v6ops-solution-tun-auto-disc-01.txt

From: Soohong Daniel Park <[email-masked]>
Date: Tue, 02 Nov 2004 10:12:09 +0900

>I'm not considering DHCP at all. May be need to be further 
>clarified. Is one more option, but more related, in my opinion, 
>to very controlled networks where you are sure that DHCP 
>options are relayed. We can even delete this section if it 
>creates confusion. 

*controlled networks* is also important domain for adopting
IPv6 widely, especially enterprise network is entirely controlled
by network administrator. Also enabling DHCP is quite normal,
cheap and a widely deployed scenario. This solution works
very well within our enterprise network.

>Thoughts from the WG well be needed here !

Which WG do you mean ? DHC WG or V6OPS WG or both ?

     Daniel (Soohong Daniel Park)
     Mobile Platform Lab. Samsung Electronics.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 02 Nov 2004 02:26:46 +0100

Hi Daniel,

My original email was in v6ops, because I think is that WG who should decide
about if the document (draft-palet-v6ops-solution-tun-auto-disc-01.txt) need
to keep or not the DHCP solution for "controlled networks".

I agree with your comment, let's see what the rest of the WG say.

Regards,
Jordi

> De: Soohong Daniel Park <[email-masked]>
> Responder a: [email-masked]
> Fecha: Tue, 02 Nov 2004 10:12:09 +0900
> Para: [email-masked], [email-masked]
> CC: Dhcwg <[email-masked]>
> Asunto: RE: DHCP issue in draft-palet-v6ops-solution-tun-auto-disc-01.txt
> 

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Pekka Savola <[email-masked]>
Date: Tue, 2 Nov 2004 08:20:49 +0200 (EET)

> very well within our enterprise network.

I've no doubt it works within an enterprise network, but because it 
does not work under all the major scenarios (for example, over 
dial-ups, ADSLs, over VPN or v6-in-[udp]v4 tunnels, etc. where you 
don't run DHCP, and not necessarilily even PPP), the real question is: 
"is DHCP a sufficiently convincing method in a subset of all scenarios 
for configuration of the tunnel endpoint?"

DNS works under every scenario.  DHCP provides a slightly more 
customization per client but I'm sceptical whether this is 
an actual necessity.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings