Subject: [dhcwg] options 66, 67

From: "Ooms Dirk" <[email-masked]>
Date: Fri, 3 Dec 2004 12:09:16 +0100

Hello,

In my understanding option 66 and 67 are set by the server in case of option overloading. i was wondering how a server should react on a client that explicitly requests option 66 and 67 although the option space is not fully used. Should the  server copy the content of "sname" and "filename" into options 66 and 67, should it not return the options, ....

dirk

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: [email-masked]
Date: Sat, 4 Dec 2004 16:31:32 +0100 (CET)

> In my understanding option 66 and 67 are set by the server in case of option overloading. i was wondering how a server should react on a client that explicitly requests option 66 and 67 although th…

IMHO, the server should honour the request and copy them to 66/67,
that's the way we did it in our implementation. We encountered some
clients (docsis cablemodems in our case) which whouldn't boot when
those options where not present.

Patrick