Subject: [dhcwg] Re: Draft agenda

From: Ralph Droms <[email-masked]>
Date: Fri, 22 Jul 2005 12:45:48 -0400

Here's the latest dhc WG agenda:

                          DHC WG agenda - IETF 63
                         1030-1230 04/08/05 (Thu)
                   (Last revised 07/22/2005 12:32:56 ET)
                   -------------------------------------

Administrivia                                      Ralph Droms      10 minutes
  Agenda bashing; blue sheets; scribe; Jabber scribe
  Request for milestones for dhc WG drafts

DHCP Option for Proxy Server Configuration         M. Alexander     10 minutes
  <draft-ietf-dhc-proxyserver-opt-02.txt>

Merging of data from DHCP4 and DHCPv6              Chown/Venaas     10 minutes
  <draft-venaas-dhc-dual-stack-merge>

DHCPv6 Default Address Selection Policy option     T. Fujisaki      10 minutes
  <draft-fujisaki-dhc-addr-select-opt-00.txt>

Zone Suffix Option for DHCPv6                      R. Yan           10 minutes
  <draft-yan-dhc-dhcpv6-opt-dnszone-02.txt>

DHCP Option for CLF/NASS                           L. Jun           10 minutes
  <draft-lijun-dhc-clf-nass-option-00.txt>

DHCPv4 option for PANA Authentication Agents       Suraj Kumar      10 minutes
  <draft-suraj-dhcpv4-paa-option-00.txt>

TAHI DHCPv6 test tool                              Nobumichi Ozoe   05 minutes

Status report on option code registration          B. Volz          10 minutes

Route Injection for DHCPv6 Prefix Delegation       TBD              10 minutes

DHCPv6<->DNA interaction                           TBD              10 minutes
                                                                   -----------
                                                                   105 minutes

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 23 Jul 2005 15:10:29 -0400

Well, that's too bad as this work has been dragging on for a long time
and it would really be nice to put it to bed.

I'd much rather spend time on this than the 10 minutes for RFC 3942 as
there really isn't much more to report than what I've requested IANA to
post on the http://www.iana.org/assignments/bootp-dhcp-parameters page.

- Bernie 

> -----Original Message-----
> From: Ralph Droms (rdroms) 
> Sent: Saturday, July 23, 2005 3:06 PM
> To: Bernie Volz (volz)
> Cc: Stig Venaas; [email-masked]
> Subject: RE: [dhcwg] Draft agenda
> 
> At this point, I don't think we have time in the WG meeting agenda to
> get in a good discussion of the draft.
> 
> Might be a good topic for a bar BOF for interested WG members...
> 
> - Ralph
> 
> On Sun, 2005-07-17 at 09:50 -0400, Bernie Volz (volz) wrote:
> > Do we want to discuss the Conflict Resolution draft?
> > 
> > - Bernie 
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] 
> > > On Behalf Of Stig Venaas
> > > Sent: Monday, July 11, 2005 3:57 AM
> > > To: [email-masked]
> > > Cc: Ralph Droms (rdroms)
> > > Subject: [dhcwg] Draft agenda
> > > 
> > > Here is the first draft agenda for the dhc WG meeting at IETF-63.
> > > Please contact the chairs to request an agenda slot...
> > > 
> > > Stig
> > > 
> > >                           DHC WG agenda - IETF 63
> > >                             <date and time TBD>
> > >                    (Last revised 07/10/2005 14:16:50 ET)
> > >       80 minutes

---

From: "Woundy, Richard" <[email-masked]>
Date: Sun, 24 Jul 2005 13:55:18 -0400

Bernie,

>Much of the problem is that I think not many people care about this 
>issue any longer...

This specification is part of an ongoing effort that has lasted almost a
DECADE. In fact, for at least 9 1/2 years -- witness the original
draft-ietf-dhc-dhcp-dns-00.txt in
<http://www.iana.org/periodic-reports/imr-feb96.txt>.

I supported the -08 draft and provided a very minor comment -- thanks
for incorporating it into -09. :^)

The WG seems unable to achieve consensus on one particular "MAY"
paragraph. I still support this draft, with or without the offending
paragraph, because I would like to have the "correct" resolution
technique specified once and for all.

-- Rich

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Bernie Volz (volz)
Sent: Saturday, July 23, 2005 9:22 PM
To: Ralph Droms (rdroms); Stig Venaas
Cc: [email-masked]
Subject: RE: [dhcwg] Draft agenda

There were only two people to comment - Ted Lemon and David Hankins (and
THANKS FOR YOUR COMMENTS!). And, as far as I determine from the current
discussion the only issue outstanding is the second paragraph of section
6.3.

But, I fear that this is will not make the cut for the required level of
feedback for a WG Last Call as past experience has shown that to be the
case.

Much of the problem is that I think not many people care about this
issue any longer as everyone that did at one time is using TXT records
to store the "client identity" (so there's no need for the DHCID RR and
actually deploying that will just make more work), conflicts are
basically already being resolved, and the (DHCPv4) FQDN option has been
in deployment for years. Thus, very few comment on these drafts (or has
long since lost interest in doing so).

This is also one reason I personally would like to see 6.3 stay as it
is. Existing deployments that are using TXT records and doing conflict
resolution just fine should not be required to switch to the algorithm
specified in the draft (yes, I know we don't say MUST). They should just
be able to switch to the DHCID RR.

- Bernie

> Sent: Saturday, July 23, 2005 3:27 PM
> To: Bernie Volz (volz)
> Cc: Stig Venaas; [email-masked]; Margaret Wasserman
> Well, I believe there was significant discussion of the draft during 
> the WG last call, indicating good review on the part of the WG.
>  
> But, I was away during a good part of the last call, and I haven't
> slogged through all of the e-mail.  Are there any outstanding issues 
> from the last call that still need to be resolved?
> 
> I don't think I was clear in my earlier response to your request for a
> slot in the WG agenda.  Seems to me the mailing list is the right 
> place for the discussion to continue, at this point, as I think it is 
> more likely we can come to consensus on the last call issues (if
> any) on the
> mailing list rather than in a short time slot at the WG meeting.
> 
> - Ralph
> 
> On Sat, 2005-07-23 at 15:19 -0400, Bernie Volz (volz) wrote:
> > But, perhaps a better first question is where do the WG
> Chairs believe
> > we stand with respect to the just concluded last call on
> this document?
> > 
> >    This message announces a WG last call on "Resolution of DNS
> >    Name Conflicts among DHCP Clients"
> >    <draft-ietf-dhc-ddns-resolution-09.txt>.  The last call will
> >    conclude at 1700 EST (USA) on 2005-07-22.
> > 
> > I realize that this just ended, so that may not yet be a
> fair question
> > to ask.
> > 
> > And, if the answer is that there wasn't sufficient
> feedback, I think we
> > have a bigger issue at hand that should be added to the
> agenda ... What
> > will it take for the DHC WG to get sufficient input into
> the Last Call
> > process to make it work. Otherwise, we might as well
> dissolve the WG?
> > 
> > You can probably tell that I am extremely frustrated by all this and
> > these work items (FQDN, Conflict Resolution, DHCID RR) will
> soon need a
> > new person willing to sheppard them through the process.
> > 
> > - Bernie
> > 
> > > From: Bernie Volz (volz)
> > > Sent: Saturday, July 23, 2005 3:10 PM
> > > To: Ralph Droms (rdroms)
> > > Well, that's too bad as this work has been dragging on for a long 
> > > time and it would really be nice to put it to bed.
> > > 
> > > I'd much rather spend time on this than the 10 minutes for RFC 
> > > 3942 as there really isn't much more to report than what I've 
> > > requested IANA to post on the 
> > > http://www.iana.org/assignments/bootp-dhcp-parameters page.
> > > 
> > > - Bernie
> > > 
> > > > > > Zone Suffix Option for DHCPv6                      
> R. Yan     
> > > > > >       10 minutes
> > > > > > Status report on option code registration          
> B. Volz    
> > > > > >       10 minutes
> > > > > > 
> > > > > > Route Injection for DHCPv6 Prefix Delegation       
> TBD        
> > > > > >       10 minutes
> > > > > > 
> > > > > > DHCPv6<->DNA interaction                           
> TBD        
> > > > > >       10 minutes
> > > > > >                                                     
>           
> > > > > >      -----------
> > > > > >                                                     
>           
> > > > > >       80 minutes
> > > > > > 
> > > > > > [email-masked] https://www1.ietf.org/mailman/listinfo/dhcwg
> > > > > > 
> > > > 
> > > 
>