Subject: Re: [dhcwg] Re: [Geopriv] Revised draft-ietf-geopriv-dhcp-civil - use case required

From: "James M. Polk" <[email-masked]>
Date: Fri, 29 Jul 2005 11:51:55 -0500

At 05:13 AM 7/29/2005 -0400, Andrew Newton wrote:

>On Jul 28, 2005, at 5:21 PM, John Schnizlein wrote:
>>There is no privacy issue to worry about when a host that has
>>attached to an ethernet jack includes its location in the DHCP
>>message that is part of its initial configuration.
>
>Why isn't there?  If my location-aware device knows my location and
>it is sending that information to anybody else, then I should be able
>to attach my privacy preferences to it.  If I'm sending that to the
>DHCP server, I should have the right to also say that it should not
>pass on that information.

Do you believe your device will make your privacy rules configurable to/by 
you whenever you divulge your location (whether asked for, or pushed)?

If so, you cannot use DHCP, because it has no privacy capability.  That's a 
security consideration, but not a reason to prevent communication.

If some device doesn't have privacy concerns (perhaps because there isn't a 
user for that device), it can use DHCP for this transaction, especially 
when "location" will be sent in cleartext by design.

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Andrew Newton <[email-masked]>
Date: Fri, 29 Jul 2005 14:56:34 -0400

On Jul 29, 2005, at 12:51 PM, James M. Polk wrote:

> Do you believe your device will make your privacy rules  
> configurable to/by you whenever you divulge your location (whether  
> asked for, or pushed)?
>
> If so, you cannot use DHCP, because it has no privacy capability.   
> That's a security consideration, but not a reason to prevent  
> communication.

Can't the same be said for SIP?

-andy

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 29 Jul 2005 16:00:02 -0500

>Can't the same be said for SIP?

the application layer nature of SIP allows for configurable control to occur.

SIP Loc Conveyance stipulates this, and creates the situation for conveying 
location within a PIDF-LO which contains Goepriv's retention and 
distribution indications - and can be S/MIME encrypted.

But SIP has identity attached to it that a DHCP client might not.

cheers,
James

                                 *******************