Subject: [dhcwg] Release message in the exchange of Decline messages

From: "haoda" <[email-masked]>
Date: Tue, 5 Jul 2005 15:30:23 +0900

Hi, everyone.

I want to confirm why the Release message be in the exchange 
of Decline messages.

Here is a diggest from the original text of RFC3315.  [Page 54]
======================================================
>18.2.7. Receipt of Decline Messages
>
>......
>   After all the addresses have been processed, the server generates a
>   Reply message and includes a Status Code option with the value
>  Success, a Server Identifier option with the server's DUID, and a
>   Client Identifier option with the client's DUID.  For each IA in the
>  Decline message for which the server has no binding information, the
>   server adds an IA option using the IAID from the Release message and
>  includes a Status Code option with the value NoBinding in the IA
>   option.  No other options are included in the IA option.
>   ....... 

Please notice this line,
>                                                      ......
the
>   server adds an IA option using the IAID from the Release message and
 
=======
>   includes a Status Code option with the value NoBinding in the IA
>   option.

At here, the IAID comes from the Release message!  But I think there is no
Release message that can be used in the Decline messages exchange.
If the type of this message is Decline, I think it is realizable.

Is my understanding right?

Haoda

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Stig Venaas <[email-masked]>
Date: Tue, 5 Jul 2005 10:49:42 +0200

> Here is a diggest from the original text of RFC3315.  [Page 54]

Yes, I believe it should say decline not release. My guess is that this
text was copied from 18.2.6 and that this word was accidentally not
replaced.

I haven't noticed this before, thanks for pointing it out.

Stig