Subject: Re: [dhcwg] Release message in the exchange of Decline messages

From: Stig Venaas <[email-masked]>
Date: Tue, 5 Jul 2005 20:51:46 +0200

On Tue, Jul 05, 2005 at 02:46:16PM -0400, Bernie Volz (volz) wrote:
> Is there such a thing?

Check http://www.rfc-editor.org/cgi-bin/errata.pl

I think this is a good place to put such unless the errors are truly
trivial.

> I've been keeping a mail folder of issues that we'll need to address in
> any 3315-bis type document as we advance that work to full standard?

Yes, that's the alternative. It's good if we as a wg can have a
collective list of such. It's useful to implementors if this list
is public though.

Stig

> 
> - Bernie 
> 
> > -----Original Message-----
> > From: Stig Venaas [mailto:[email-masked]] 
> > Sent: Tuesday, July 05, 2005 2:37 PM
> > To: Bernie Volz (volz)
> > Cc: haoda; [email-masked]
> > Subject: Re: [dhcwg] Release message in the exchange of 
> > Decline messages
> > 
> > On Tue, Jul 05, 2005 at 01:37:47PM -0400, Bernie Volz (volz) wrote:
> > > This is obviously a typo. It should be "Decline" message.
> > > 
> > > The text for the two sections is essentially identical, and 
> > this just
> > > was missed in the reviews.
> > 
> > Perhaps we should post this in the RFC errata? Might help us remember
> > fixing this if/when updating 3315 too.
> > 
> > Stig
> > 
> > > 
> > > - Bernie 
> > > 
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]] 
> > > > On Behalf Of haoda
> > > > Sent: Tuesday, July 05, 2005 2:30 AM
> > > > To: [email-masked]
> > > > Subject: [dhcwg] Release message in the exchange of 
> > Decline messages
> > > > 
> > > > Hi, everyone.
> > > > 
> > > > I want to confirm why the Release message be in the exchange 
> > > > of Decline messages.
> > > > 
> > > > Here is a diggest from the original text of RFC3315.  [Page 54]
> > > > ======================================================
> > > > >18.2.7. Receipt of Decline Messages
> > > > >
> > > > >......
> > > > >   After all the addresses have been processed, the server 
> > > > generates a
> > > > >   Reply message and includes a Status Code option with the value
> > > > >  Success, a Server Identifier option with the server's 
> > DUID, and a
> > > > >   Client Identifier option with the client's DUID.  For 
> > > > each IA in the
> > > > >  Decline message for which the server has no binding 
> > > > information, the
> > > > >   server adds an IA option using the IAID from the Release 
> > > > message and
> > > > >  includes a Status Code option with the value NoBinding 
> > in the IA
> > > > >   option.  No other options are included in the IA option.
> > > > >   ....... 
> > > > 
> > > > Please notice this line,
> > > > >                                                      ......
> > > > the
> > > > >   server adds an IA option using the IAID from the Release 
> > > > message and
> > > >  
> > > > =======
> > > > >   includes a Status Code option with the value 
> > NoBinding in the IA
> > > > >   option.
> > > > 
> > > > At here, the IAID comes from the Release message!  But I 
> > > > think there is no
> > > > Release message that can be used in the Decline messages exchange.
> > > > If the type of this message is Decline, I think it is realizable.
> > > > 
> > > > Is my understanding right?
> > > > 
> > > > 
> > > > 
> > > > Haoda
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > _______________________________________________
> > > > dhcwg mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/dhcwg
> > > > 
> > > 
> > > _______________________________________________
> > > dhcwg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/dhcwg
> > 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Tue, 5 Jul 2005 14:46:16 -0400

Is there such a thing?

- Bernie