Subject: RE: [dhcwg] Release message in the exchange of Decline messages

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Tue, 5 Jul 2005 13:37:47 -0400

This is obviously a typo. It should be "Decline" message.

The text for the two sections is essentially identical, and this just
was missed in the reviews.

- Bernie 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of haoda
> Sent: Tuesday, July 05, 2005 2:30 AM
> To: [email-masked]
> Subject: [dhcwg] Release message in the exchange of Decline messages
> 
> Hi, everyone.
> 
> I want to confirm why the Release message be in the exchange 
> of Decline messages.
> 
> Here is a diggest from the original text of RFC3315.  [Page 54]
> ======================================================
> >18.2.7. Receipt of Decline Messages
> >
> >......
> >   After all the addresses have been processed, the server 
> generates a
> >   Reply message and includes a Status Code option with the value
> >  Success, a Server Identifier option with the server's DUID, and a
> >   Client Identifier option with the client's DUID.  For 
> each IA in the
> >  Decline message for which the server has no binding 
> information, the
> >   server adds an IA option using the IAID from the Release 
> message and
> >  includes a Status Code option with the value NoBinding in the IA
> >   option.  No other options are included in the IA option.
> >   ....... 
> 
> Please notice this line,
> >                                                      ......
> the
> >   server adds an IA option using the IAID from the Release 
> message and
>  
> =======
> >   includes a Status Code option with the value NoBinding in the IA
> >   option.
> 
> At here, the IAID comes from the Release message!  But I 
> think there is no
> Release message that can be used in the Decline messages exchange.
> If the type of this message is Decline, I think it is realizable.
> 
> Is my understanding right?
> 
> 
> 
> Haoda
> 
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Stig Venaas <[email-masked]>
Date: Tue, 5 Jul 2005 20:36:37 +0200

> was missed in the reviews.

Perhaps we should post this in the RFC errata? Might help us remember
fixing this if/when updating 3315 too.

Stig