Subject: RE: [dhcwg] Re: Draft agenda

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Sat, 23 Jul 2005 21:38:21 -0400

Also, what's happened with the M/O bit discussion? Has this been
resolved in the IPv6 WG or are they expecting us to do anything? Should
that be an agenda item?

- Bernie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ralph Droms (rdroms)
> Sent: Friday, July 22, 2005 12:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [dhcwg] Re: Draft agenda
> 
> Here's the latest dhc WG agenda:
> 
>                           DHC WG agenda - IETF 63
>                          1030-1230 04/08/05 (Thu)
>                    (Last revised 07/22/2005 12:32:56 ET)
>                    -------------------------------------
> 
> Administrivia                                      Ralph 
> Droms      10 minutes
>   Agenda bashing; blue sheets; scribe; Jabber scribe
>   Request for milestones for dhc WG drafts
> 
> DHCP Option for Proxy Server Configuration         M. 
> Alexander     10 minutes
>   <draft-ietf-dhc-proxyserver-opt-02.txt>
> 
> Merging of data from DHCP4 and DHCPv6              
> Chown/Venaas     10 minutes
>   <draft-venaas-dhc-dual-stack-merge>
> 
> DHCPv6 Default Address Selection Policy option     T. 
> Fujisaki      10 minutes
>   <draft-fujisaki-dhc-addr-select-opt-00.txt>
> 
> Zone Suffix Option for DHCPv6                      R. Yan     
>       10 minutes
>   <draft-yan-dhc-dhcpv6-opt-dnszone-02.txt>
> 
> DHCP Option for CLF/NASS                           L. Jun     
>       10 minutes
>   <draft-lijun-dhc-clf-nass-option-00.txt>
> 
> DHCPv4 option for PANA Authentication Agents       Suraj 
> Kumar      10 minutes
>   <draft-suraj-dhcpv4-paa-option-00.txt>
> 
> TAHI DHCPv6 test tool                              Nobumichi 
> Ozoe   05 minutes
> 
> Status report on option code registration          B. Volz    
>       10 minutes
> 
> Route Injection for DHCPv6 Prefix Delegation       TBD        
>       10 minutes
> 
> DHCPv6<->DNA interaction                           TBD        
>       10 minutes
>                                                               
>      -----------
>                                                               
>      105 minutes
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2005 11:45:26 +0100

> resolved in the IPv6 WG or are they expecting us to do anything? Should

I think it should, at least briefly.

My recollection is that the discussion fizzled out without a conclusion.

There is a specifc (newish) draft on the topic:
http://www.ietf.org/internet-drafts/draft-ietf-ipv6-ra-mo-flags-01.txt

I'm not sure how strong consensus is on the contents of this draft.

One of the issues was that there are two bits, with four combinations,
one of which is 'meaningless'.   But then an administrator should never
use that combination.   People still seem to see some 'confusion' in
the semantics.  While questions keep hitting the ipv6 list, one can argue
that the M/O text is certainly not as clear/streamlined as it could be.

Some argued whether a DHC service indication was needed at all.  Just let
the client back off.  One question was over unecessary use of 
bandwidth/battery on low capacity wireless devices - a hint that no DHC 
was available would then be useful rather than the client retrying.

There were some interesting ideas, e.g. that perhaps all stateless DHC
servers could respond to the same message types as stateful - I think the 
JOIN people suggested that.   Presumably you'd then only need the M bit, 
given M and O semantics were being ushered towards the message type.

I don't like the idea of changing things now without larger deployment
experience, and I recall most people agreed that was lacking.

Anyway, Ralph/Stig should maybe check that the topic is on the ipv6 WG
agenda and take it from there, since ipv6 is held on Tuesday and dhc is
on Thursday.

Tim

---

From: Stig Venaas <[email-masked]>
Date: Mon, 25 Jul 2005 12:51:38 +0200

> On Sat, Jul 23, 2005 at 09:38:21PM -0400, Bernie Volz (volz) wrote:
[...]
> experience, and I recall most people agreed that was lacking.

I agree it's an interesting idea, but I also feel that we need to get
some more experience before we go along changing things.

> agenda and take it from there, since ipv6 is held on Tuesday and dhc is

It appears not to be on the IPv6 wg agenda.

Stig

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Jul 2005 12:11:20 +0100

> some more experience before we go along changing things.

Ditto.
 
> It appears not to be on the IPv6 wg agenda.

Well, the draft draft-ietf-ipv6-ra-mo-flags-01 is an IPv6 WG item, so
could be a discussion point there.   Can you prod Brian/Bob and the
author(s)?

-- 
Tim/::1

---

From: Ralph Droms <[email-masked]>
Date: Mon, 25 Jul 2005 07:24:12 -0400

Tim - my memory is also that the discussion tapered off without a
conclusion.

I do remember getting a summary e-mail from Bob and Brian (ipv6 WG
chairs) about "no consensus for changing M/O bits at this point" (but I
can't locate that e-mail); however, my memory of the discussion is that
there were two interleaved discussions: (1) improve documentation of
what was in the RFC 246[012] specs and (2) consider changes
(improvements) to spec for M/O bits and DHCPv6.  So, I'm unclear about
any conclusions...

I've included the ipv6 WG chairs and the authors of draft-ietf-ipv6-ra-
mo-flags-01.txt in the CC: list; can any of you clarify the resolution
of the discussion, and should the discussion appear on the ipv6 or dhc
(or both) WG agendas?

- Ralph

---

From: Syam Madanapalli <[email-masked]>
Date: Mon, 25 Jul 2005 17:29:07 +0530

Hi,

We tried to summarize the discussion on M/O flags, but we (authors of
the M/O flags) were busy with other things, so we could not do that. But
from the discussion we found three different opinions

1. Leave M/O Flags unchanged
2. Flags independently represent DHCPv6 and DHCP lite (M-flag for HCB,
    O-Flag for ICB)
3. M-Flag (to hint) for triggering DHC (Remove O-flag)

Even in the case of 1 we would like to put some text to clarify the flags 
usage.
We are planning to trim draft-ietf-ipv6-ra- mo-flags-01.txt without policy
variables.

Also it may be worth to see what could be the impacts of case 2 and case 3
from DHCP perspective as well as from IPv6 perspective. If at we decide to
change better to go for 3, otherwise just clarify them about their (M/O 
flags)
usage and leave them as it is.

Regards,
Syam

----- Original Message ----- 
From: "Ralph Droms" <[email-masked]>
To: "Tim Chown" <[email-masked]>
Cc: "Robert Hinden" <[email-masked]>; "Brian Haberman" 
<[email-masked]>; <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, July 25, 2005 4:54 PM
Subject: Re: [dhcwg] Re: Draft agenda

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Mon, 25 Jul 2005 21:04:06 +0900

>>>>> On Mon, 25 Jul 2005 11:45:26 +0100, 
>>>>> Tim Chown <[email-masked]> said:

> My recollection is that the discussion fizzled out without a conclusion.

Same here, and I feel I'm responsible to some extent for the lack of

> http://www.ietf.org/internet-drafts/draft-ietf-ipv6-ra-mo-flags-01.txt

I've been trying to summarize the discussion we had before, but it
desperately diverged where almost anyone had slightly different
opinion, and I've not managed to make a useful summary for the next
step yet...I'll try to provide something that can (hopefully) help the
next step this week anyway.

Regarding the meeting agenda, it would be great if we could allocate
some slot for this topic (in either or both of ipv6/dhc), but I'm
afraid it would not be fair since we failed to revise that document
for this meeting.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

---

From: Soohong Daniel Park <[email-masked]>
Date: Mon, 25 Jul 2005 21:11:44 +0900

Tim,

> could be a discussion point there.   Can you prod Brian/Bob and the

I already requested a slot for this discussion to chairs of IPv6.
Hopefully, we will make more sharp consensus to move
this document forward in IPv6 meeting as well as DHC meeting.

Regards,

Daniel (Soohong Daniel Park)
Mobile Platform Lab., SAMSUNG Electronics.