Subject: Re: [dhcwg] Abuse of the Preference option

From: Ralph Droms <[email-masked]>
Date: Fri, 01 Jul 2005 18:30:21 -0400

Bud - by "abuses", do you mean, for example, a DoS attack by a rogue
DHCPv6 server?  

- Ralph

On Wed, 2005-06-29 at 14:08 +0200, Bud Millwood wrote:
> Has there been any discussion of possible abuses of the preference option 
> described in RFC 3315?
> 
> If a client is *required* to ignore other advertisements when a particular 
> advertisement has preference 255, doesn't this undermine a DHCP client's 
> ability to possibly make a more informed decision about which advertisement 
> to go with? Shouldn't the "preference" option be just that, a preference?
> 
> - Bud
> 
> Bud Millwood
> Weird Solutions, Inc.
> http://www.weird-solutions.com
> tel: +46 8 758 3700
> fax: +46 8 758 3687
> mailto:[email-masked]
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Bud Millwood <[email-masked]>
Date: Tue, 5 Jul 2005 10:06:34 +0200

Yep, that's what I was thinking.

I'm not entirely sure what criteria a client could use when deciding to drop 
an ADV msg where pref=255, but if the "lock-in" behavior is not specified, at 
least a client is free to find creative ways of detecting illicit lock-in.

What's the impetus for specifying this behavior?

- Bud

On Saturday 02 July 2005 00:30, Ralph Droms wrote:
> > If a client is *required* to ignore other advertisements when a
> > particular advertisement has preference 255, doesn't this undermine a
> > DHCP client's ability to possibly make a more informed decision about
> > which advertisement to go with? Shouldn't the "preference" option be just
> > that, a preference?
> >
> > - Bud
> >
> > Bud Millwood
> > Weird Solutions, Inc.

-- 
Bud Millwood
Weird Solutions, Inc.