Subject: [dhcwg] IANA issue during Last Call: draft-ietf-dhc-dhcpv6-leasequery (DHCPv6 Leasequery) to Proposed Standard

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Wed, 23 May 2007 10:48:59 -0400

During the IANA review, an issue was raised that there was no text in
the "6. IANA Considerations" to specify an allocation policy for new
query-types:

> Action #4:
> Upon approval of this document, the IANA will create the 
> following sub-registry named "LQ_QUERY options" 
> in the "DHCPv6 and DHCPv6 options - per [RFC3315]" registry 
> located at http://www.iana.org/assignments/dhcpv6-parameters
>
> Initial contents of this registry will be: 
>
> 1 QUERY_BY_ADDRESS [RFC-dhc-dhcpv6-leasequery-00]
> 2 QUERY_BY_CLIENTID [RFC-dhc-dhcpv6-leasequery-00]
> 3 - ??? Available for assignment 
>
>
> Allocation policy is missing.

I propose we add the following allocation policy:

   New OPTION_LQ_QUERY option query-type codes are assigned through
   Standards Action, as defined in RFC 2434 [RFC2434]. 

Please let us know if you have an objection to this text.

- Bernie

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 23 May 2007 11:02:53 -0700

>    Standards Action, as defined in RFC 2434 [RFC2434].

Works for me.