Subject: [dhcwg] prefix length determination for DHCPv6

From: "Leino, Tammy" <[email-masked]>
Date: Fri, 10 Aug 2007 16:59:53 -0500

Hello,

In implementing RFC 3315, I see no option or field in the IA_NA option for a prefix length associated with an assigned IPv6 address.  How does the client determine the prefix length of the IPv6 address the server is assigning?

Furthermore, in the absence of a configured IPv6 router on the link, can the client use the DHCPv6 server to find a default gateway out of the local network?  If so, what RFC specifies this option?

Any help or referrals to additional RFCs would be much appreciated.

Best Regards,
Tammy Leino
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "John Jason Brzozowski (JJMB)" <[email-masked]>
Date: Fri, 10 Aug 2007 18:14:11 -0400

Hello Tammy,

RAs could be configured to supply the length for prefixes valid on the link  Otherwise, there is no DHCPv6 option that can be used to supply this data.

Regarding, your second question why would you need information about the router if it does not exist or is not configured to route?   Just looking for a little more information.

John
######################
John Jason Brzozowski, CISSP, RHCT
[email-masked]
484-994-6787
######################

-----Original Message-----
From: "Leino, Tammy" <[email-masked]>
To: [email-masked]
Sent: 08/10/07 17:59
Subject: [dhcwg] prefix length determination for DHCPv6

Hello,

Best Regards,
Tammy Leino

---

From: Ralph Droms <[email-masked]>
Date: Sat, 18 Aug 2007 20:24:37 -0400

Where you configure a mask with an address is an accident of the UI.   
Where you use the mask is based on the protocol design.  The prefix  
length is not used in any way with an address assigned to an  
interface.  The only reason a mask is specified with an address in  
IPv4 is to convey on-link prefix information.  That information is  
provided through RAs in IPv6.  Therefore there is no need to provide  
a prefix length with an assigned IPv6 address, whether that address  
is assigned through SLAAC, DHCPv6, manual assignment or divine  
intervention.

- Ralph

On Aug 15, 2007, at Aug 15, 2007,9:13 AM, Iljitsch van Beijnum wrote:

> On 15-aug-2007, at 12:15, Mark Smith wrote:
>
>
>>> I disagree. For better or for worse, the notion of a subnet mask
>>> going along with an interface address is deeply ingrained in the way
>>> IP is implemented. Separating the two for no apparent reason is a  
>>> bad
>>> idea.
>>>
>
>
>> I think you need to modify the following sentence as such:
>>
>
>
>> "For better or for worse, the notion of a subnet mask
>>  going along with an interface address is deeply ingrained in the way
>> **IPv4** is implemented."
>>
>
> No, I was very careful about what I said. The only place that I can  
> think of where you don't configure a mask along with an address is  
> in the case of HSRP. EVERYWHERE else that I know of you need to  
> specify it now that we have CIDR and obviously it was implied  
> before we had CIDR. Yes, in IPv6, too.
>
> We can talk long and hard about the pros and cons of this  
> architecturally, but the simple truth is that changing this doesn't  
> appear to buy as anything tangible and it will require huge amounts  
> of work in implementations and then generate huge amounts of  
> confusion in operations so PLEASE let's not go down this road.
>
> And if you have to look back before RFC 791 to provide  
> counterexamples that really doesn't disprove "ingrained" in my  
> opinion...
>