Subject: [dhcwg] Fwd: I-D ACTION:draft-deng-dhc-service-identifiers-00.txt

From: "Hui Deng" <[email-masked]>
Date: Fri, 16 Nov 2007 15:13:43 +0800

Hello, all

If possible, please help to review and make some comment on it.
Many thanks

-Hui

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

       Title           : Service Identfiers List Option for DHCPv6
       Author(s)       : H. Deng
       Filename        : draft-deng-dhc-service-identifiers-00.txt
       Pages           : 11
       Date            : 2007-11-15

  This document describes a new option for DHCPv6 [RFC3315] that
  provides a mechanism for specifying a list of service identifer which
  this connection support or doesn't support.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Shane Kerr <[email-masked]>
Date: Fri, 16 Nov 2007 09:34:40 +0100

Hui,

> If possible, please help to review and make some comment on it.

Interesting idea, but it's not clear to me what it means when a service is
advertised. For instance, if I advertise "ntp", does that mean that the local
network has a reachable NTP server, or that the network allows port 123 traffic
through it's firewall, or what?

- --
Shane

---

From: "Hui Deng" <[email-masked]>
Date: Sat, 17 Nov 2007 09:38:45 +0800

Hi, Shane,

Thanks for your comments, reply as below,

> through it's firewall, or what?

I guess for some operator, they would like to say they allow such kind of
port 123 traffic,  for others operator,
this draft could be extended to show there is a reachable NTP server.

We hope it could ignite other purpose as well based on comments.
Thanks again

-Hui

---

From: Shane Kerr <[email-masked]>
Date: Mon, 19 Nov 2007 11:02:17 +0100

> this draft could be extended to show there is a reachable NTP server.

Clients need to be able to know exactly what the server means when it sends a
service identifier.

Also, if you are going to be sending lists of ports that are open, perhaps it
makes more sense to send those, instead of giving service names. Clients will
need to know how these ports are handled.

I think the draft needs more work before wider consideration.

- --
Shane

---

From: "Hui Deng" <[email-masked]>
Date: Mon, 19 Nov 2007 23:17:11 +0800

Hi, Shane,

Thanks for the discussion, see below reply.

2007/11/19, Shane Kerr <[email-masked]>:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hui Deng wrote:
> > Hi, Shane,
> >
As you said here, client does need to know what exactly means of it,
Software cooperation work between client and server is mandatory to
support this function.

> need to know how these ports are handled.
I guess that here really need deep discussion. some time service are dynamically
negotiate the port number, you remind us here like whether we also
need consider the port number range information shall be advertised or
not.

really thanks for your comments.

-Hui

> I think the draft needs more work before wider consideration.
We appreciate the comments which could help to progress it.