Subject: [dhcwg] Some suggestions on draft-ietf-dhc-relay-id-suboption

From: Bharat Joshi <[email-masked]>
Date: Mon, 11 Aug 2008 21:36:46 +0530

Hi Mark,

      I have some minor suggestions on this draft:

* In Abstract, it would be good to expand:

"The suboption carries an identifer that uniquly identifies a Relay Agent. This identifier can be configured or generated in Relay Agent"

* In last paragraph of Introduction, A typo "carries an sequenect" -> "carries a sequence"

* In section 4, in statement "Relay Agent who use generated identifiers should make the generated", do you think we should use SHOULD instead of should.

* Do you think it will be helpful to add a use case for the relay id usage? For example: we have proposed to use this in our Bulk Lease Query draft.

Thanks,
Bharat

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely 
for the use of the addressee(s). If you are not the intended recipient, please 
notify the sender by e-mail and delete the original message. Further, you are not 
to copy, disclose, or distribute this e-mail or its contents to any other person and 
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken 
every reasonable precaution to minimize this risk, but is not liable for any damage 
you may sustain as a result of any virus in this e-mail. You should carry out your 
own virus checks before opening the e-mail or attachment. Infosys reserves the 
right to monitor and review the content of all messages sent to or from this e-mail 
address. Messages sent to or from this e-mail address may be stored on the 
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Mark Stapp <[email-masked]>
Date: Mon, 11 Aug 2008 15:00:41 -0400

Hi Bharat,

thanks for the feedback. some discussion/responses inline...

> "The suboption carries an identifer that uniquly identifies a Relay Agent. This identifier can be configured or generated in Relay Agent"

sure, I can add some more here. I guess I would like to keep the 
abstract pretty lean though, so maybe just a sentence or two?

> * In last paragraph of Introduction, A typo "carries an sequenect" -> "carries a sequence"

Thanks - I will fix that.

> * In section 4, in statement "Relay Agent who use generated identifiers should make the generated", do you think we should use SHOULD instead of should.

that section does carry a MUST about using the RFC3315-style DUIDs; I do 
feel that the form of the generated DUID, the actual data, has to be 
very clear. the line you quote is about UI feedback, some way to show an 
admin what was generated. I'm somewhat less willing to be too strong 
there, because there are so many kinds of devices and OSs, and it's hard 
to demand much about UIs to embedded systems. that doesn't really seem 
like a protocol issue - imo - although I agree that useability and 
manageability are important.

how strongly do you feel about that one? is there a specific concern you 
have in mind, that motivates that suggestion? does anyone else feel that 
this should be made a SHOULD?

> * Do you think it will be helpful to add a use case for the relay id usage? For example: we have proposed to use this in our Bulk Lease Query draft.

I did try to use some discussion about the factory-floor environment as 
a sort of a use-case, in the Introduction section. did you feel that 
that wasn't clear enough or a strong enough motivation? or do you think 
that text is basically ok, but should be moved into its own section maybe?

Thanks,
Mark

---

From: Bharat Joshi <[email-masked]>
Date: Tue, 12 Aug 2008 09:28:51 +0530

Hi Mark,

> abstract pretty lean though, so maybe just a sentence or two?

Yes. One sentence may be enough. I was just thinking to bring out the
fact that this identifier uniquely identifies the Relay Agent.

> this should be made a SHOULD?

IMO, most of the network elements have a UI [Either CLI/SNMP etc.] where
this kind of information is displayed. If it is configurable, I may
relax this a little because administrator would anyway know what he has
configured. But if it is generated, I think administrator would want a
way to find out what is the Relay Id DUID for a given Relay Agent. This
may be required to configure DHCP server for a specific policy if he
ever want to use it that way. So my suggestion is coming from this fact.

> that text is basically ok, but should be moved into its own section maybe?

Yes. I saw that. I think it would be great if we can have this in a
separate section as 'Motivation' or 'Use case'. In the use cases, you
may want to add case for 'Bulk Lease Query' as well.

Thanks,
Bharat

---

From: Mark Stapp <[email-masked]>
Date: Tue, 12 Aug 2008 08:59:44 -0400

Hi Bharat,
thanks again - I'll take a pass through to make changes, and post an 
updated version.

Regards,
Mark