Subject: [dhcwg] I-D Action:draft-ietf-dhc-dhcpv6-opt-netboot-00.txt

From: [email-masked]
Date: Tue, 19 Aug 2008 08:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

	Title           : DHCPv6 option for network boot
	Author(s)       : T. Huth, J. Freimann
	Filename        : draft-ietf-dhc-dhcpv6-opt-netboot-00.txt
	Pages           : 9
	Date            : 2008-08-19

The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) provides a
framework for passing configuration information to nodes on a
network.  This document describes a new option for DHCPv6 to convey
information, required for network booting, to the nodes.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-dhc-dhcpv6-opt-netboot-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "H. Peter Anvin" <[email-masked]>
Date: Thu, 21 Aug 2008 15:29:11 -0700

> http://www.ietf.org/internet-drafts/draft-ietf-dhc-dhcpv6-opt-netboot-00.txt

This looks like a pretty clean and straightforward draft.  One thing, 
however, that may be worth considering, is whether it would be useful to 
reserve specific ranges of suboption numbers for different agents during 
the boot process.

For example, reserve the top four bits of the suboption numbers and 
break it down like this:

	0 - IANA assignments
	1 - firmware vendor assignments
	2 - network boot loader vendor assignments
	    (secondary boot loaders like PXE's NBP)
	3 - OS vendor assignments

... with the remaining numbers reserved for future use.

	-hpa

---

From: "Jens Freimann" <[email-masked]>
Date: Fri, 29 Aug 2008 17:10:14 +0200

2008/8/22 H. Peter Anvin <[email-masked]>:
> reserve specific ranges of suboption numbers for different agents during the
> boot process.
>
> For example, reserve the top four bits of the suboption numbers and break it
> down like this:
>
>        0 - IANA assignments

I think that's a good idea. I'll talk to Thomas Huth so we can work
something out
and update the draft.

Any other opinions or ideas?

with kind regards

Jens Freimann

---

From: "David W. Hankins" <[email-masked]>
Date: Fri, 29 Aug 2008 09:13:20 -0700

> reserve specific ranges of suboption numbers for different agents during 

The way this kind of hting has been solved in other DHCP spaces is to
use a single option whose format is a 32-bit enterprise ID number
followed by a field of suboptions.

The site-local space in DHCPv4 has left us with many problems.  With
a single site-local space, we can have a mechanism to talk about
multiple site local spaces.  With 4 distinct "vendor local spaces"
in a sub-option space, it gets a bit hard to keep things clear.

Having distinct identification seems to improve this.

-- 
Ash bugud-gul durbatuluk agh burzum-ishi krimpatul.
Why settle for the lesser evil?	 https://secure.isc.org/store/t-shirt/
-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		     you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg