Subject: Re: [dhcwg] Muti-homing support.

From: HYUN WOOK CHA <[email-masked]>
Date: Thu, 07 Aug 2008 09:14:02 +0000 (GMT)

Hello, Woj.

Woj> In SP networks this kind of asymetric routing is very much a
problem. Not having the PD route advertised by the non-active gateway is
one possible solution.
(Joseph) What is the SP network? 

Woj> Ehm, but the situation described earlier was one which saw the PD
route installed at only one of the relays. If that route is lost, by
loosing say PD state, then there will be no backup route to go with.
(Joseph) I assumed that if replies come down through both relays, both relays can maintain the PD states and have the PD routes installed. If my assumption is not correct, please let me know.

Joseph
 
> -----Original Message-----
Continued inline...

> From: HYUN WOOK CHA [mailto:[email-masked]] 
> Sent: 07 August 2008 09:55
> To: Wojciech Dec (wdec)
> Cc: [email-masked]
> Subject: Re: RE: Re: [dhcwg] Muti-homing support.
> 
> 
> Woj, 
> 
> Please see my inline comments.
> 
> > Why does the server send just one reply to two relayed 
> REQUEST? From 
> > server's point of view, two messages are same like retransmissioned 
> > one. Could you clarify this?
> 
> Good point, however even if the reply does come down through 
> both relays, one again has the problem of asymmetric routing, 
> since the host will almost certainly prefer to use one gateway.
> (Joseph) I am not sure that this kind of asymmetric routing 
> is an issue. Default router selection by client solely 
> depends on implementation of IPv6 hos, which I do not know 
> exactly. (Maybe, If other parameters are same, router 
> lifetime in RA might affect the decision.) Incoming traffics 
> destined to client are forwarded to one of two routers which 
> is chosen by a routing protocol. I guess, one router is 
> likely to be preferrable for both sides.

Woj> In SP networks this kind of asymetric routing is very much a
problem. Not having the PD route advertised by the non-active gateway is
one possible solution.

> 
> Moreover, should there actually be a dhcp packet drop from/to 
> one of the relays (admittedly a corner case, but one none the 
> less), then again one would arrive at the situation described earlier.
> 
> (Joseph)  If one of relay(RouterA) loses the PD state, 
> RouterA will notify this event to internal routing system, 
> then, relevant entries of forwarding tables in upstream 
> routers can be switched into backup route to the other relay 
> for the delated prefixes through routing protocol.

Woj> Ehm, but the situation described earlier was one which saw the PD
route installed at only one of the relays. If that route is lost, by
loosing say PD state, then there will be no backup route to go with.

-Woj.

> 
> Joseph
> 
> > 
> > 
> > 
> > ------- Original Message -------
> > Sender : Wojciech Dec (wdec)<[email-masked]> 
> > Date   : 2008-08-06 18:35 (GMT+09:00)
> > Title  : Re: [dhcwg] Muti-homing support.
> > 
> > Hi folks,
> > 
> > Adding my views (which I shared earlier with Joseph)
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > [mailto:[email-masked]] On Behalf
> > > Of Bernie Volz (volz)
> > > Sent: 06 August 2008 00:13
> > > To: David W. Hankins; [email-masked]
> > > Subject: Re: [dhcwg] Muti-homing support.
> > > 
> > > I'd still like to see a real network diagram for this issue.
> > > 
> > > Joseph had:
> > > 
> > >            Server
> > >              | 
> > >     |----------------| 
> > >   RelayA            RelayB 
> > >     |----------------|
> > >              |
> > >            Client
> > > 
> > > and
> > > 
> > >   ServerA         ServerB
> > >      |              |
> > >   RelayA          RelayB
> > >      |--------------|
> > >             |
> > >           client
> > > 
> > > But the routers are missing here. The multiple connections
> > to the ISPs
> > > are missing - where are these located; how are they
> > connected into the
> > > network. Yes, I understand that the "|"
> > > elements could be replaced with "cloud" but that still misses the 
> > > point.
> > 
> > What IMO is a problem still waiting to be fully 
> addressed/explained in 
> > relation to DHCP's interaction with relaying routers that need to 
> > install state deriving from the DHCP exchange. Consider picture 1 
> > above and the following scenario playing out (am modifying Joseph's 
> > original description to illustrate the points):
> > RelayA and RelayB are co-located in different routers which are 
> > advertising the same link prefix in RAs towards the client 
> with the O 
> > flag set, besides indicating that they are eligible default 
> gateways.
> > The client issues a SOLICIT for an IA_PD (and other info) which by 
> > means of the relays makes its way to the server.
> > This then sends an ADVERTISE to *each* of the relays (or just one), 
> > and the client receives two ADVERTISE messages. It then sends a 
> > REQUEST for the IA_PD which again arrives to the server. 
> This time the 
> > server sends just one reply to one of the Relay agents (say RelayA) 
> > which install the PD prefix as a route.
> > Now the problems: 
> > - The client will use either Relay A or Relay B as its 
> default gateway 
> > (possibly even both), leading to asymmetric routing that is not 
> > desired by many operators.
> > - Should the client get disconnected from RelayA, a black hole is 
> > created for the PD prefix, even though the client still has 
> RelayB as 
> > a valid default gateway.
> > - Should RelayA loose routing state, the client becomes pretty much 
> > isolated until it issues a DHCP rebind (fingers crossed even then)
> > 
> > Can we agree that the above are indeed problems that deserve to be 
> > addressed?
> > 
> > Cheers,
> > Woj.
> > 
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 7 Aug 2008 11:18:53 +0200

> Sent: 07 August 2008 11:14
> To: Wojciech Dec (wdec)
> Cc: [email-masked]
> Subject: Re: RE: RE: Re: [dhcwg] Muti-homing support.
> 
> Hello, Woj.
> 
> problem. Not having the PD route advertised by the non-active 
> gateway is one possible solution.

Woj> Should have expanded SP to Service Provider.

> route installed at only one of the relays. If that route is 
> lost, by loosing say PD state, then there will be no backup 
> route to go with.
> (Joseph) I assumed that if replies come down through both 
> relays, both relays can maintain the PD states and have the 
> PD routes installed. If my assumption is not correct, please 
> let me know.

Woj> Yes that is correct, given the caveat of asymmetric routing.
Perhaps the misunderstanding lies in the fact that I was referring to my
earlier mail, where the reply comes down via only one of the relays.

-Woj.

> > Good point, however even if the reply does come down through both 
> > relays, one again has the problem of asymmetric routing, since the 
> > host will almost certainly prefer to use one gateway.
> > (Joseph) I am not sure that this kind of asymmetric routing is an 
> > issue. Default router selection by client solely depends on 
> > implementation of IPv6 hos, which I do not know exactly. (Maybe, If 
> > other parameters are same, router lifetime in RA might affect the 
> > decision.) Incoming traffics destined to client are 
> forwarded to one 
> > of two routers which is chosen by a routing protocol. I guess, one 
> > router is likely to be preferrable for both sides.
> 
> problem. Not having the PD route advertised by the non-active 
> gateway is one possible solution.
> 
> > 
> > Moreover, should there actually be a dhcp packet drop 
> from/to one of 
> > the relays (admittedly a corner case, but one none the less), then 
> > again one would arrive at the situation described earlier.
> > 
> > (Joseph)  If one of relay(RouterA) loses the PD state, RouterA will 
> > notify this event to internal routing system, then, 
> relevant entries 
> > of forwarding tables in upstream routers can be switched 
> into backup 
> > route to the other relay for the delated prefixes through routing 
> > protocol.
> 
> route installed at only one of the relays. If that route is 
> lost, by loosing say PD state, then there will be no backup 
> route to go with.
> 
> -Woj.
> 
> > 
> > Joseph
> > 
> > > 
> > > 
> > >