Subject: Re: [dhcwg] Muti-homing support.

From: HYUN WOOK CHA <[email-masked]>
Date: Fri, 08 Aug 2008 09:17:37 +0000 (GMT)

David,
 
               Server         
                   |
          |----------|
      Relay1       Relay2
          |               |
         CM          CM
          |----------|
                   |
                Client

In this figure, the administrative domain(assumed as an ISP) has single server which is serving stateful addresses, other configs and PD. Relay1 and Relay2 are located in different access routers(R1, R2) which are advertising different prefixes(P1, P2). CM means CPE Modem.(from Bernie's figure)  Also, server does not know that R1 and R2 are connected in the same link, which means the client is multi-homed. 
In this case, I would like to know whether client can obtain stateful addresses from both prefixes(P1, P2) or not.  

     Server1       Server2         
          |               |
      Relay1       Relay2
          |               |
         CM          CM
          |----------|
                   |
                Client
Also, I considered two servers in an administraive domain(ISP) are serving different access networks. So, I thought that the client could obtain stateful addresses with both prefixes(P1, P2) from two servers. 
Ok, before discussing more which one is better, I think that we should figure out how multi-homing can provide benefits we expects from it.
Joseph

------- Original Message -------
Sender : David W. Hankins<[email-masked]> 
Date   : 2008-08-08 07:48 (GMT+09:00)
Title  : Re: [dhcwg] Muti-homing support.

On Thu, Aug 07, 2008 at 12:08:11AM +0000, HYUN WOOK CHA wrote:
> The reason why I suggest to utilize on-link prefix-list for the decision of choosing multiple servers is that I think that multi-homing is solely relevent to the network topologies instead of administrative domains. Even though different administrative domains means different network attachements which equals multi-homing, I do not see any reason that multi-homing should not be allowed under single domain when clients can see different on-link prefixes advertised by multiple routers. IMO, this is the case for clients which are multi-homed with SLAAC. 

A single administrative domain only needs one DHCPv6 server, or
consistently (or intentionally inconsistently) configured multiple
DHCPv6 servers.

So today you can multihome in one administrative domain, and this
would not change.

-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		you'll just have to do it again."
Internet Systems Consortium, Inc.	-- Jack T. Hankins

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Fri, 8 Aug 2008 06:58:11 -0400

On Aug 8, 2008, at Aug 8, 2008,5:17 AM, HYUN WOOK CHA wrote:

> David,
>
>               Server
>                   |
>          |----------|
>      Relay1       Relay2
>          |               |
>         CM          CM
>          |----------|
>                   |
>                Client
>
> In this figure, the administrative domain(assumed as an ISP) has  
> single server which is serving stateful addresses, other configs and  
> PD. Relay1 and Relay2 are located in different access routers(R1,  
> R2) which are advertising different prefixes(P1, P2). CM means CPE  
> Modem.(from Bernie's figure)  Also, server does not know that R1 and  
> R2 are connected in the same link, which means the client is multi- 
> homed.
> In this case, I would like to know whether client can obtain  
> stateful addresses from both prefixes(P1, P2) or not.

You've described an artificial example.  The assumption in DHCP is  
that the network admin knows the network topology.  Additionally,  
there is no fixed relationship between the routers advertising  
prefixes on a link and the relay agent through which a client  
communicates with the DHCP server.  So, in this example, it doesn't  
matter which relay agent forwards the traffic between the client and  
the server.  The server should be configured to return addresses for  
the client from both P1 and P2, independent of which relay agent  
forwards the traffic.

>     Server1       Server2
>          |               |
>      Relay1       Relay2
>          |               |
>         CM          CM
>          |----------|
>                   |
>                Client
> Also, I considered two servers in an administraive domain(ISP) are  
> serving different access networks. So, I thought that the client  
> could obtain stateful addresses with both prefixes(P1, P2) from two  
> servers.
> Ok, before discussing more which one is better, I think that we  
> should figure out how multi-homing can provide benefits we expects  
> from it.

The fundamental problem here is that the DHCP architecture includes no  
provision for a client interacting with multiple servers simultaneously.

There's is nothing in the architecture that precludes a client from  
managing sessions with more than one server.  However, at present:
* the docs are all written with the assumption that a client only  
interacts with one server
* a client has no way to know if it should interact with multiple  
servers
* a client has no way to differentiate between servers

Dave Hankins suggested an extension through which a server could  
identify the admin domain to which it belongs, which would address the  
third bullet.  I suppose we could devise some text to address the  
first two bullets - although I would be leery of trying to specify  
client policy that generally describes how a client should behave when  
it receives responses from more than one server.
> Joseph

- Ralph

>> The reason why I suggest to utilize on-link prefix-list for the  
>> decision of choosing multiple servers is that I think that multi- 
>> homing is solely relevent to the network topologies instead of  
>> administrative domains. Even though different administrative  
>> domains means different network attachements which equals multi- 
>> homing, I do not see any reason that multi-homing should not be  
>> allowed under single domain when clients can see different on-link  
>> prefixes advertised by multiple routers. IMO, this is the case for  
>> clients which are multi-homed with SLAAC.
>
>