Subject: [dhcwg] question on the Host name field

From: "Malek John-AJM240" <[email-masked]>
Date: Tue, 29 Mar 2011 18:26:31 -0400

Hi All,

??? question on the Host name field

It seems that the MS DHCP server  will ignore a DHCP discovery if it is
sent with some special characters($#) in the host name field.

My question is there a way to configure the DHCP server so that it will
ignore the host name field?

Or does anyone know of any 3rd party servers that will accept special
characters in the host name field?

Thank You,

John Malek

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Mar 2011 06:48:10 +0000

On Mar 30, 2011, at 8:42 AM, "Malek John-AJM240" <[email-masked]<mailto:[email-masked]>> wrote:
It seems that the MS DHCP server  will ignore a DHCP discovery if it is sent with some special characters($#) in the host name field.
My question is there a way to configure the DHCP server so that it will ignore the host name field?
Or does anyone know of any 3rd party servers that will accept special characters in the host name field?

I'm not aware of any DHCP servers that have this behavior; your mention of the Microsoft server doing this is the first I've heard of it.   There certainly is no IETF standard that recommends this behavior--it's quite nonsensical.

Having said that, there are lots of other DHCP servers out there; the main problem you will have is that very few of them run on Microsoft Windows, so you will have to install Linux or Unix if you want to use them.  I happen to know that neither the Nominum DHCP server nor the ISC DHCP server will drop DHCPDISCOVER messages based on the hostname option.

---

From: "Malek John-AJM240" <[email-masked]>
Date: Wed, 30 Mar 2011 14:03:22 -0400

Thanks for the answer, I was given some bad info and passed it to you
(sorry). After examining captures I just received from the customer, I
see the problem was with the gidder 

Not matching his ip pool.  Believe Problem should be solved now.

Regards,

John

From: Ted Lemon [mailto:[email-masked]] 
Sent: Tuesday, March 29, 2011 11:48 PM
To: Malek John-AJM240
Cc: [email-masked]
Subject: Re: [dhcwg] question on the Host name field

On Mar 30, 2011, at 8:42 AM, "Malek John-AJM240"
<[email-masked]> wrote:

	It seems that the MS DHCP server  will ignore a DHCP discovery
if it is sent with some special characters($#) in the host name field.

	My question is there a way to configure the DHCP server so that
it will ignore the host name field?

	Or does anyone know of any 3rd party servers that will accept
special characters in the host name field?

I'm not aware of any DHCP servers that have this behavior; your mention
of the Microsoft server doing this is the first I've heard of it.
There certainly is no IETF standard that recommends this behavior--it's
quite nonsensical.

Having said that, there are lots of other DHCP servers out there; the
main problem you will have is that very few of them run on Microsoft
Windows, so you will have to install Linux or Unix if you want to use
them.  I happen to know that neither the Nominum DHCP server nor the ISC
DHCP server will drop DHCPDISCOVER messages based on the hostname
option.