Subject: [dhcwg] DHCPv6 client(proxy) sending unicast packets to server in all dhcp packets.

From: sudurais a <[email-masked]>
Date: Mon, 27 Jun 2011 16:29:50 -0700

Hi All,

I've question regarding DHCPv6 server behavior for Unicasted DHCP packets
from DHCPv6 clients(Proxy clients - Neither a Relay or Client. Proxy client
has a valid IPv6 address but for its subscribers its acting as Proxy which
also includes some of Relay Agent Options to identify binding of address
returned by server). In our application, we know server IPv6 addresses
forehand and also client(Proxy client) needs to go across routers
(routing-domain) to communicate with server. In that case,
multicast/broadcast isn't viable solution from DHCPv6 Proxy client. If
DHCPv6 client does unicast DISCOVER packet to server and uses unicast for
all of its communication with server, will it be a problem in server side ?.
Is server mandates client should be sending packets with bcast/mcast address
as destination address in DHCP discover or request packets ?.

Thanks in advance,

Regards,
sudurais.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 30 Jun 2011 11:50:06 -0400

On Jun 27, 2011, at 7:29 PM, sudurais a wrote:
> If DHCPv6 client does unicast DISCOVER packet to server and uses unicast for all of its communication with server, will it be a problem in server side ?. Is server mandates client should be sending packets with bcast/mcast address as destination address in DHCP discover or request packets ?.

The server is expected to ignore any such packets.   I presume that you mean "Solicit," not "DISCOVER," since there is no "DISCOVER" packet in DHCPv6.