Subject: [dhcwg] Quick review on the draft-ietf-dhc-dhcpv6-reconfigure-rebind-07

From: Leaf yeh <[email-masked]>
Date: Fri, 05 Aug 2011 11:19:58 +0000

In the DHC session of IETF81, the last slide of DHC WG Administrivia (01-administrivia<http://www.ietf.org/proceedings/81/slides/dhc-11.pdf> / http://www.ietf.org/proceedings/81/slides/dhc-11.pdf ) called for the review or statue update against draft-ietf-dhc-dhcpv6-reconfigure-rebind-07<http://tools.ietf.org/id/draft-ietf-dhc-dhcpv6-reconfigure-rebind>.

I read this draft today, but wonder the use case when we need Rebind of msg-type in the Reconfiguration Message Option included in the server-initiated Reconfiguration Message.

The description got from the section 1 (Introduction) of the above draft (draft-ietf-dhc-dhcpv6-reconfigure-rebind-07<http://tools.ietf.org/id/draft-ietf-dhc-dhcpv6-reconfigure-rebind>) is as follows:

‘Under some circumstances, it may be desirable
   for the client to communicate with a different server; for example,
   if the server that the client most recently communicated with is no
   longer available, the network administrator may want the client to
   communicate with a different server.’

In the general thinking, if the server has some new (or updated) configuration parameter for the client, then the server initiate a configuration exchange through Reconfiguration-renew/Reply message.

So the question is why the server definitely knows that it need to ask the client to get configuration from a different sever?

Best Regards,
Leaf

---

From: Ted Lemon <[email-masked]>
Date: Fri, 5 Aug 2011 13:25:50 +0000

On Aug 5, 2011, at 7:19 AM, Leaf yeh wrote:
So the question is why the server definitely knows that it need to ask the client to get configuration from a different sever?

The server doesn't know.   The server administrator knows that the original server is down, and that the client must talk to a different server.

---

From: Tomasz Mrugalski <[email-masked]>
Date: Fri, 05 Aug 2011 19:51:46 +0200

On 05.08.2011 15:25, Ted Lemon wrote:
>> So the question is why the server definitely knows that it need to ask
>> the client to get configuration from a different sever?
> 
> The server doesn't know.   The server administrator knows that the
> original server is down, and that the client must talk to a different
> server.
Another possibility is that such reconfigure event may be part of
graceful server shutdown procedure.

That would avoid RENEW flood for period between T1 and T2. Clients would
immediately REBIND to new server.

Oh, and by the way - I read and support this draft.

Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 17 Aug 2011 22:27:16 -0500

I support this document as well.

It will be useful when there is DHCPv6 failover ... what if the original
server is the partner that is down. Both servers know the nonce (since
they can exchange it in the binding updates) so the running partner can
send a Reconfigure. But it would be useless to do this as the client
will be sending Renew's with the downed failover partner's
server-identifier option.

(While the server's could also exchange their server-identifier option
and "process" each other's packets, I think this is a bad idea. As is
using the server-identifier for the failover pair.)

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Tomasz Mrugalski
Sent: Friday, August 05, 2011 1:52 PM
To: [email-masked]
Subject: Re: [dhcwg] Quick review on
thedraft-ietf-dhc-dhcpv6-reconfigure-rebind-07

Tomek
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg