Subject: [dhcwg] Is address rejection function needed in address registration?

From: Jiangsheng <[email-masked]>
Date: Wed, 03 Aug 2011 03:17:30 +0000

Hi, all,

In the IETF 81 DHC meeting, we have presented address registration solution. http://tools.ietf.org/html/draft-jiang-dhc-addr-registration-02.txt

However, there were debates whether the address registration server should have the ability to reject addresses. So, the authors would like to consult the WG whether this function is needed or not.

There are a couple of scenarios authors think it may be useful though they are not strong requirements. A) to refuse the host-generated interface id that does not follow ietf rules, for example RFC 5453 - Reserved IPv6 Interface Identifiers; B) to perform a duplicate address detection. If ND is not deployed or in a point-to-multipoint architecture, the host generated addresses cannot avoid duplication. Then the DHC registration server may play the DAD among the address database.

The authors would like to follow the WG consensus whether we keep this address rejection function or not.

Best regards,

Sheng

---

From: Ted Lemon <[email-masked]>
Date: Wed, 3 Aug 2011 12:14:49 +0000

> There are a couple of scenarios authors think it may be useful though they are not strong requirements. A) to refuse the host-generated interface id that does not follow ietf rules, for example RFC…

It would be helpful to understand the scenarios where either ND would not be deployed, or there would be a point-to-multipoint architecture that would work with DHCP.   My instinct is to think that this is not a real scenario, but I assume that you would not mention it if you didn't have something in mind.

If a device is not following the rules, why would it pay attention to the DHCP server's indication that its address was unacceptable?

---

From: "Brzozowski, John" <[email-masked]>
Date: Thu, 4 Aug 2011 05:04:31 +0000

The server will not need to perform DAD necessarily.  If it has assigned
the requested address it MUST reject the request for the same from a
different client.

John
=========================================
John Jason Brzozowski
Comcast Cable
e) mailto:[email-masked]
o) 609-377-6594
m) 484-962-0060
w) http://www.comcast6.net
=========================================

On 8/2/11 11:17 PM, "Jiangsheng" <[email-masked]> wrote:

>Hi, all,
>
>In the IETF 81 DHC meeting, we have presented address registration
>solution. 
>http://tools.ietf.org/html/draft-jiang-dhc-addr-registration-02.txt
>
>However, there were debates whether the address registration server
>should have the ability to reject addresses. So, the authors would like
>to consult the WG whether this function is needed or not.
>
>There are a couple of scenarios authors think it may be useful though
>they are not strong requirements. A) to refuse the host-generated
>interface id that does not follow ietf rules, for example RFC 5453 -
>Reserved IPv6 Interface Identifiers; B) to perform a duplicate address
>detection. If ND is not deployed or in a point-to-multipoint
>architecture, the host generated addresses cannot avoid duplication. Then
>the DHC registration server may play the DAD among the address database.
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Brzozowski, John" <[email-masked]>
Date: Thu, 4 Aug 2011 05:04:52 +0000

John

---

From: Jiangsheng <[email-masked]>
Date: Thu, 04 Aug 2011 09:12:26 +0000

> architecture, the host generated addresses cannot avoid duplication.
> Then the DHC registration server may play the DAD among the address
> database.
> 
> It would be helpful to understand the scenarios where either ND would
> not be deployed, or there would be a point-to-multipoint architecture
> that would work with DHCP.   My instinct is to think that this is not a
> real scenario, but I assume that you would not mention it if you didn't
> have something in mind.
> 
> If a device is not following the rules, why would it pay attention to
> the DHCP server's indication that its address was unacceptable?

draft-ietf-6man-dad-proxy in 6man wg has described the point-to-multipoint architecture, in which ND DAD cannot guarantee address collision free. DAD proxy can be one of the solution, so our registration function.

Sheng

---

From: Jiangsheng <[email-masked]>
Date: Thu, 04 Aug 2011 09:19:01 +0000

> the requested address it MUST reject the request for the same from a

Yes, DHCPv6 server does not need to perform DAD, instead, it only checks through its address database. The debate point here is whether the address collision scenario exists. If it exists, we need the rejection function; otherwise, the DHCPv6 may have only registration function.

Sheng
 
> Then

---

From: Jiangsheng <[email-masked]>
Date: Mon, 08 Aug 2011 06:56:10 +0000

Now, the only scenario is the requested addresses collision. Is it possible, particularly in the point-to-multipoint network topology? If the scenario is real, we probably need the address rejection function; otherwise, the authors would like to remove it from the address registration procedure.

Ted, John, how do you think?

Sheng

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Jiangsheng
> Sent: Thursday, August 04, 2011 5:19 PM
> To: Brzozowski, John; dhc WG
> Cc: ChenGang
> Subject: Re: [dhcwg] Is address rejection function needed in address
> registration?
> 
> Yes, DHCPv6 server does not need to perform DAD, instead, it only
> checks through its address database. The debate point here is whether
> the address collision scenario exists. If it exists, we need the
> rejection function; otherwise, the DHCPv6 may have only registration
> function.
> 
> Sheng
> 
> > John
> > >The authors would like to follow the WG consensus whether we keep
> this
> > >address rejection function or not.
> > >
> > >Best regards,
> > >
> > >Sheng
> > >
> > >

---

From: Ted Lemon <[email-masked]>
Date: Mon, 8 Aug 2011 14:52:43 +0000

On Aug 8, 2011, at 2:56 AM, Jiangsheng wrote:
Now, the only scenario is the requested addresses collision. Is it possible, particularly in the point-to-multipoint network topology? If the scenario is real, we probably need the address rejection function; otherwise, the authors would like to remove it from the address registration procedure.

DAD proxy solves this problem, or at least proposes to.   So I think if you don't care to solve this problem, you shouldn't feel obligated to do so.   A lot of resistance to the draft is a mistaken impression that address rejection is being used as an address allocation control mechanism, so you are going to have a much easier time of it if you take out that part.

Also, FWIW, I think DAD proxy is a better solution to the problem anyway.

---

From: Jiangsheng <[email-masked]>
Date: Tue, 09 Aug 2011 01:16:25 +0000

Removing the address rejection function it is. We are fine to dedicate the registration function to registration only.

The authors will make an update version applying this discussion result. Then, maybe, chairs can call wg adoption in the mail list?

Sheng

From: Ted Lemon [mailto:[email-masked]]
Sent: Monday, August 08, 2011 10:53 PM
To: Jiangsheng
Cc: Brzozowski, John; dhc WG; ChenGang
Subject: Re: [dhcwg] Is address rejection function needed in address registration?

---

From: Ted Lemon <[email-masked]>
Date: Tue, 9 Aug 2011 04:06:11 +0000

On Aug 8, 2011, at 9:16 PM, Jiangsheng wrote:
The authors will make an update version applying this discussion result. Then, maybe, chairs can call wg adoption in the mail list?

Sounds great.   Thanks!