Subject: [dhcwg] DHCPv6 server/client Confirm behavior after Release

From: [email-masked]
Date: Thu, 16 Feb 2012 15:34:36 -0500

On a different but related note, we'd seen in our lab a DHCPv6 client 
implementation perform 2 releases (IA_NA and then IA_PD), both 
acknowledged by the server, followed by a Confirm on the IA_NA. At that 
point the server answered with a Success Reply and the client resumed 
using its IA_NA (even after the release). 

Question #1 to the group: is this the correct server behavior after a 
release? 
I understand the Confirm was only meant to verify the link is still 
suitable, but if the lease has been released, shouldn't a NoBinding answer 
be expected?

Question #2: In the scenario above, it looks like the client didn't 
express a proper behavior. The correct client behavior would be to 
initiate a Solicit after a successful Release. Is this correct? 

/JF

---

From: Ted Lemon <[email-masked]>
Date: Thu, 16 Feb 2012 20:37:34 +0000

On Feb 16, 2012, at 3:34 PM, <[email-masked]<mailto:[email-masked]>>
 wrote:
Question #1 to the group: is this the correct server behavior after a release?
I understand the Confirm was only meant to verify the link is still suitable, but if the lease has been released, shouldn't a NoBinding answer be expected?

Strictly speaking, the server isn't checking to see whether a binding exists for the address, but rather whether the address in the IA_NA is valid on the link.   So the server behavior here is probably okay.

Question #2: In the scenario above, it looks like the client didn't express a proper behavior. The correct client behavior would be to initiate a Solicit after a successful Release. Is this correct?

Correct.   The client is clearly broken.