Subject: Re: [dhcwg] Call for adoption: draft-mrugalski-softwire-dhcpv4-over-v6-option-01

From: Paul Ebersman <[email-masked]>
Date: Mon, 01 Oct 2012 17:59:45 +0400

TLemon> The authors have requested that the working group adopt
TLemon> draft-mrugalski-softwire-dhcpv4-over-v6-option as a working
TLemon> group work item.

I support working on this draft.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 5 Oct 2012 19:30:52 +0000

On Sep 26, 2012, at 1:27 PM, Ted Lemon <[email-masked]> wrote:
> The authors have requested that the working group adopt draft-mrugalski-softwire-dhcpv4-over-v6-option as a working group work item.   The document is within the scope of the current charter.   It describes a DHCPv6 option that is used to configure client relay agents (draft-ietf-dhc-dhcpv4-over-ipv6).

Just a reminder: we have only seen two responses on this draft, and I know that there are more than two working group participants who are interested in it.   The call for adoption expires on October 10.

FTR, with my wg chair hat off, I'm in favor of adopting.

---

From: Leaf yeh <[email-masked]>
Date: Mon, 8 Oct 2012 04:11:50 +0000

a. Schedule question: draft-mrugalski-softwire-dhcpv4-over-v6-option sounds work for the draft-cui-softwire-b4-translated-ds-lite per the section 2 of introduction, but draft-cui (LW4o6) is still in the status of individual draft. Is it suitable to adopt this draft after the (softwire) adoption of draft-cui?

<quote>In a typical deployment as [I-D.cui-softwire-b4-translated-ds-lite]..., CRA functionality will be a part of a Lightweight B4 element (Basic Bridging BroadBand element) implementation.</quote>
<quote>...the typical envisaged use would be the Lightweight 4over6 architecture, where TSV or TRA could be part of Lightweight AFTR implementation.</quote>

The above is quoted as the reference.

b. A naive question on the network scenario: why do we need call the client (LW4o6 initiator) to be CRA, not the *client* directly?
c. One more naive question on the network scenario: Could the dhcp4ov6 endpoint (called TSV or TRA) be the different one with the LW4o6 tunnel endpoint (called LW4o6 concentrator)? If yes, not sure it have been mentioned in draft-cui.

d. Technical question: Section 5 - DHCPv6 Client Behavior - <quote>It SHOULD warn its operator about such condition.</quote>. How?

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Saturday, October 06, 2012 3:31 AM
To: dhcwg WG
Subject: Re: [dhcwg] Call for adoption: draft-mrugalski-softwire-dhcpv4-over-v6-option-01

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Mon, 8 Oct 2012 11:22:44 +0000

> a. Schedule question: draft-mrugalski-softwire-dhcpv4-over-v6-option sounds work for the draft-cui-softwire-b4-translated-ds-lite per the section 2 of introduction, but draft-cui (LW4o6) is still i…

No, it's actually for the dhcpv4-over-ipv6 draft.

---

From: Leaf yeh <[email-masked]>
Date: Mon, 8 Oct 2012 11:47:05 +0000

A supplement or an update to draft-ietf-dhc-dhcpv4-over-ipv6?

Best Regards,
Leaf

---

From: "Qi Sun" <[email-masked]>
Date: Tue, 9 Oct 2012 16:36:58 +0800

Dear Ted,

I'm in favor of adopting this draft as a DHC WG item.

Best Regards!

Qi Sun

From: Ted Lemon
Date: 2012-09-27 01:27
To: dhcwg WG
Subject: [dhcwg] Call for adoption: draft-mrugalski-softwire-dhcpv4-over-v6-option-01
The authors have requested that the working group adopt draft-mrugalski-softwire-dhcpv4-over-v6-option as a working group work item.   The document is within the scope of the current charter.   It describes a DHCPv6 option that is used to configure client relay agents (draft-ietf-dhc-dhcpv4-over-ipv6).

If you think the working group should be working on such an option, please respond to this message by saying so.   If you think we should not, please say that.

We will evaluate consensus on or after October 10.

---

From: Ole Trøan <[email-masked]>
Date: Wed, 10 Oct 2012 10:06:18 +0200

> If you think the working group should be working on such an option, please respond to this message by saying so.   If you think we should not, please say that.

I think we should not. including draft-ietf-dhc-dhcpv4-over-ipv6.

a) DHC should wait until it is clear what the outcome of softwire is. there are multiple solutions to the same problem proposed.
    hopefully one will not end up with standardizing all of them. DHCPv4 over IPv6 is only needed in one of the solution sets.
b) is this the right solution? if the working group doesn't think solving the problem of running DHCPv6 over IPv4 should use a CRA.
    why is that the correct solution for DHCPv4 over IPv6?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Wed, 10 Oct 2012 12:34:10 +0000

>    why is that the correct solution for DHCPv4 over IPv6?

The working group has already adopted dhcpv4-over-ipv6.   This is an option to carry the IPv6 address of the DHCPv4-over-IPv6 server to the CRA so that it can relay correctly.

---

From: "Qi Sun" <[email-masked]>
Date: Thu, 11 Oct 2012 15:34:40 +0800

Hi Ole,

Please see my opinions inline.

Qi Sun

From: Ole Tr鴄n
Date: 2012-10-10 16:06
To: Ted Lemon
CC: dhcwg WG

[Qi] 1) In IPv4-over-IPv6 scenarios, it is needed to allocate IPv4 address to users in IPv6 access network. DHCPv4 is the right protocol to assign IPv4 address. 
       2) Using a Client Relay Agent is helpful to avoid modifications of DHCPv4 client, which will cause less change to current network and users.
       3) draft-mrugalski-softwire-dhcpv4-over-v6-option describes a DHCPv6 option that is used to tell the CRA the unicast IPv6 address of TSV/TRA. IMO this option can make the CRA work better.

Best Regards!
Qi Sun

---

From: Sun Qi <[email-masked]>
Date: Thu, 11 Oct 2012 20:55:07 +0800

**
Dear Ted,

Best Regards!

------------------------------
Qi Sun

 *From:* Ted Lemon <[email-masked]>
*Date:* 2012-09-27 01:27
*To:* dhcwg WG <[email-masked]>
*Subject:* [dhcwg] Call for adoption:
draft-mrugalski-softwire-dhcpv4-over-v6-option-01

The authors have requested that the working group adopt
draft-mrugalski-softwire-dhcpv4-over-v6-option as a working group work
item.   The document is within the scope of the current charter.   It
describes a DHCPv6 option that is used to configure client relay
agents (draft-ietf-dhc-dhcpv4-over-ipv6).

If you think the working group should be working on such an option,
please respond to this message by saying so.   If you think we should
not, please say that.

---

From: Sun Qi <[email-masked]>
Date: Thu, 11 Oct 2012 20:57:49 +0800

Hi Ole,

Here are my opinions.

1) In IPv4-over-IPv6 scenarios, it is needed to allocate IPv4 address to
users in IPv6 access network. DHCPv4 is the right protocol to assign IPv4
address.

2) Using a Client Relay Agent is helpful to avoid modifications of DHCPv4
client, which will cause less change to current network and users.

3) draft-mrugalski-softwire-dhcpv4-over-v6-option describes a DHCPv6 option
that is used to tell the CRA the unicast IPv6 address of TSV/TRA. IMO this
option can make the CRA work better.

Best Regards!
Qi Sun

2012/10/10 Ole Trøan <[email-masked]>

> describes a DHCPv6 option that is used to configure client relay agents
> (draft-ietf-dhc-dhcpv4-over-ipv6).
> >
> please respond to this message by saying so.   If you think we should not,
> please say that.
>
> a) DHC should wait until it is clear what the outcome of softwire is.
> there are multiple solutions to the same problem proposed.
>     hopefully one will not end up with standardizing all of them. DHCPv4
> over IPv6 is only needed in one of the solution sets.
> b) is this the right solution? if the working group doesn't think solving
> the problem of running DHCPv6 over IPv4 should use a CRA.