Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-stateful-issues-02.txt

From: [email-masked]
Date: Mon, 22 Oct 2012 08:48:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

	Title           : Issues with multiple stateful DHCPv6 options
	Author(s)       : Ole Troan
                          Bernie Volz
	Filename        : draft-ietf-dhc-dhcpv6-stateful-issues-02.txt
	Pages           : 10
	Date            : 2012-10-22

Abstract:
   Dynamic Host Configuration Protocol for IPv6 (DHCPv6) was not written
   with the expectation that additional stateful DHCPv6 options would be
   developed.  IPv6 Prefix Options for Dynamic Host Configuration
   Protocol (DHCP) version 6 shoe-horned the new options for Prefix
   Delegation into DHCPv6.  Implementation experience of the CPE model
   described in has shown multiple issues with the DHCPv6 protocol in
   supporting multiple stateful options.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-stateful-issues

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-stateful-issues-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-stateful-issues-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 22 Oct 2012 15:57:57 +0000

I just submitted the 02 version of this draft.

The only change is the following paragraph was added to Section 4.2.  Placement of Status codes:

   To clarify further: the expected Advertise message from a server when
   a client requests both address assignment (IA_NA) and prefix
   delegation (IA_PD) and the server can only delegate prefixes, is a
   Status Code Option with the NoAddrsAvail status code, no IA_NA
   option(s), and the IA_PD option(s) with IAPREFIX option(s).

This was discussed recently (based on a message posted by David Miles on 10/5 with subject "DHCPv6 NoAddrAvailable"). I didn't address that particular case (where both address and prefix delegation failed), but described what I thought was a more likely case. If there is a desire to expand the clarification to cover the NoAddrsAvail/NoPrefixAvail case, I could add text for that too.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, October 22, 2012 11:49 AM
To: [email-masked]
Cc: [email-masked]
Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-stateful-issues-02.txt

Abstract:

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Mon, 22 Oct 2012 16:36:14 +0000

>   option(s), and the IA_PD option(s) with IAPREFIX option(s).

Difficult to parse.   How about:

To clarify further: when a client requests both IA_NA and IA_PD, and the server can offer IA_PD but not IA_NA, the server should send a response containing no IA_NA, a status code of NoAddrsAvail, and one or more IA_PD options containing IA_PREFIX options.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 23 Oct 2012 02:22:09 +0000

I will update, but will revise to make it clear this is for Solicit/Advertise. Reply semantics aren't the same. How about:

To clarify further: when a client requests both IA_NA and IA_PD, and the server can offer IA_PD but not IA_NA, the server sends an Advertise response containing no IA_NA option, a status code option of NoAddrsAvail, and one or more IA_PD options containing IAPREFIX options.

- Bernie

---

From: Stephen Jacob <[email-masked]>
Date: Tue, 23 Oct 2012 00:19:58 -0700

I like this wording. It definitely adds clarity.

Regards,
Stephen

-- 
 Stephen Jacob | [email-masked] | +1 650 381 6051
 Nominum, Inc. |  http://www.nominum.com/  | +1 650 381 6000

---

From: David Miles <[email-masked]>
Date: Tue, 23 Oct 2012 00:21:41 -0700

Agreed, thanks Bernie

-- 
David Miles

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 24 Oct 2012 19:18:56 +0000

I missed the submission deadline so this will have to wait until things open up again.

I will not be at the IETF 85 meeting (will be away on vacation).

Doesn't look like Ole submitted a request for time on the agenda; not sure if it is needed - hopefully document can go to last call with the 03 version after submissions reopen.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Monday, October 22, 2012 10:22 PM
To: Ted Lemon
Cc: [email-masked]
Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-stateful-issues-02.txt

- Bernie

---

From: Ole Trøan <[email-masked]>
Date: Thu, 25 Oct 2012 09:20:55 +0200

> Doesn't look like Ole submitted a request for time on the agenda; not sure if it is needed - hopefully document can go to last call with the 03 version after submissions reopen.

that was my sentiment too.
unless the chairs think there are issues with this document that would benefit some face time?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Thu, 25 Oct 2012 11:36:09 +0000

> unless the chairs think there are issues with this document that would benefit some face time?

It's up to you guys.   We have time on the agenda at the moment if you want it, but no pressure.