Subject: [dhcwg] DHCP Question

From: Patrick Malik Tousgaard <[email-masked]>
Date: Tue, 27 Sep 2016 08:38:07 +0000

Hi there,

We're a group of 5 people studying IT Technology in Aalborg, Denmark and got an assignment about DHCP.
One of the questions we got was "Who made DHCP" and after long time researching we couldn't find anything that specifies who actually made it except for acronyms and groups...
We somehow found your e-mail address and thought that you actually could answer that for us?
It will really help us out

Kind Regards,
The group from Aalborg studying IT Technology

---

From: Simon Hobson <[email-masked]>
Date: Tue, 27 Sep 2016 18:06:16 +0100

> We're a group of 5 people studying IT Technology in Aalborg, Denmark and got an assignment about DHCP.

Ah, you want us to do your homework for you ;-)

> We somehow found your e-mail address and thought that you actually could answer that for us?

Your question is as simple to answer as "who made the internet" !

To start with, no ONE person, group, organisation, or company made DHCP - there have been a lot of people involved in one way or another, though a few stand out as particularly involved.

What I'd suggest first is that you buy, beg, borrow, whatever a copy of "The DHCP Handbook" by Ted Lemon and Ralph Droms which is considered "the bible of DHCP". There is a second edition, but the first will do to answer your question - the second edition mostly adds details on the failover protocol and isn't relevant to what you are trying to find out. This books starts off with something of a history lesson, and explains not only what DHCP is, but how it came about and why some of the apparently strange design choices (such as piggy-backing on BOOTP) were made.

Also, you can look at the RFCs and see who were the authors - though the authors aren't the only ones involved since many others will have commented and submitted ideas.
So those authors, together with people who provided comments, people who reviewed the drafts, users/admins who provided input into what the protocol should do - they created DHCP as a protocol. Acting under the umbrella of the IETF.

But of course, a protocol spec is nothing without an implementation. There have been a few implementations of servers, relay agents, and clients. Many commercial outfits have written them, others use FOSS implementations of which there are several. Of particular note - and relevant to this list since this is the support list for it - the ISC (the same people that bring us BIND) wrote a server, relay agent, and client package which was designed to be as pure and clean an implementation of the protocol as written as is possible.
So those are the people who "made" DHCP as a "thing you can use".

If, after having read the first few chapters of the above mentioned book, and looked up the RFCs that are relevant, and looked a bit at the implementations available and who wrote them ...
If there's anything still unclear, feel free to come back and ask.

---

From: Simon Hobson <[email-masked]>
Date: Wed, 28 Sep 2016 08:09:49 +0100

I wrote:

> Of particular note - and relevant to this list since this is the support list for it - the ISC (the same people that bring us BIND) wrote a server, relay agent, and client package which was designed to be as pure and clean an implementation of the protocol as written as is possible.

Just testing ;-)
I see no-one picked up on the fact that I was responding to the DHC WG list and not the ISC DHCP list :-/

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Sep 2016 10:54:37 -0400

TBH, I don't really agree that the code I wrote is the most pure and
complete implementation--that's probably Tomek's code.   Of course,
there's a lot of new code in the ISC server now, but you were talking
about the past... I was aware that you had send this to dhcwg--it
didn't seem like a problem that you mentioned the ISC server, since
it's a good choice for someone who's curious about DHCP but isn't an
operator to take a look at.

On Wed, Sep 28, 2016 at 3:09 AM, Simon Hobson <[email-masked]> wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg