Subject: [dhcwg] IETF-97 (Seoul) DHC WG Session - Agenda Requests - DEADLINE 9/26

From: "Bernie Volz (volz)" <[email-masked]>
Date: Sun, 11 Sep 2016 15:08:36 +0000

Reminder to submit session agenda requests.

At present, the only session request we have is to potentially review 3315bis WGLC issues (if not resolved prior to the meeting or consensus building needs higher bandwidth discussion). See https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda.

At present, we'll either have a short (1 hour meeting is shortest available slot) or none at all unless we get some items to add to the agenda.

The current WG drafts in progress are:

draft-ietf-dhc-dhcpv4-forcerenew-extensions-00, Forcerenew Reconfiguration Extensions for DHCPv4
Appears to be stalled as several attempts to reach the authors have failed. Unless someone speaks up that has interest in this work, we plan to let it die. Expires: November 13, 2016 (just before Seoul).

draft-ietf-dhc-dhcpv6-failover-protocol-02, DHCPv6 Failover Protocol
Presently in WGLC (scheduled to end 9/12)

draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03, DHCPv6 Prefix Length Hint Issues
Presently scheduled to be WGLC after failover-protocol document finished.

draft-ietf-dhc-dhcpv6-yang-03, YANG Data Model for DHCPv6 Configuration
No apparent progress since just before Berlin. Not sure if there are any outstanding issues to discuss? There were some comments raised in Berlin, especially about options. See https://www.ietf.org/proceedings/96/minutes/minutes-96-dhc.

draft-ietf-dhc-rfc3315bis-05, Dynamic Host Configuration Protocol for IPv6 (DHCPv6) bis
WGLC ended. Issues being worked by co-authors. Awaiting WGLC status report from Ralph Droms.

draft-ietf-dhc-sedhcpv6-13, Secure DHCPv6
No apparent progress since just before Berlin. Only comment during Berlin IETF was to update sequence number to 64-bits.

Also, draft-li-dhc-secure-dhcpv6-deployment has expired and I think it needed some work (moving text from sedhcpv6 into this document to keep this one focused on all deployment issues)?

For the Related Internet-Drafts:

draft-liu-dhc-dhcp-yang-model-05, Yang Data Model for DHCP Protocol
WG may consider after DHCPv6 model (almost) complete.

draft-shen-dhc-client-port-03, Generalized Source UDP Port of DHCP Relay
Likely to have adoption call shortly

draft-templin-dhc-authonly-sedhcpv6-02, Authentication-only Mode for Secure DHCPv6
New.

draft-volz-dhc-relay-server-security-02, Security of Messages Exchanged Between Servers and Relay Agents
Adoption call pending issuance by Tomek.

-          Tomek & Bernie

From: dhcwg [mailto:[email-masked]] On Behalf Of Bernie Volz (volz)
Sent: Tuesday, August 16, 2016 2:03 PM
To: [email-masked]
Subject: [dhcwg] IETF-97 (Seoul) DHC WG Session - Agenda Requests

Hi:

Please submit agenda requests as soon as you can if you do plan to present at the DHC WG session in Seoul (requests must be submitted by September 26; Tomek or I need to submit the session request by September 30th).

As in the past, please provide:

Title Of Session:
Presenter:
Related Drafts:
Time Required:
Purpose of Session:

We do want to remind those requesting time that you should focus on discussing key issues that need resolution to move a draft forward.

You can view the working agenda at https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda.

While we are still 3 months from that meeting, the session requests have opened up and we need to know approximately how much time to request.

We have the following WG documents active:

-          draft-ietf-dhc-dhcpv4-forcerenew-extensions-00, Forcerenew Reconfiguration Extensions for DHCPv4

No presentation in Berlin or update to DHC WG about status since update published 2016-05-13

-          draft-ietf-dhc-dhcpv6-failover-protocol-02, DHCPv6 Failover Protocol

Expecting to start WGLC 8/22

-          draft-ietf-dhc-dhcpv6-prefix-length-hint-issue-03, DHCPv6 Prefix Length Hint Issues

Likely to start WGLC soon

-          draft-ietf-dhc-dhcpv6-yang-03, YANG Data Model for DHCPv6 Configuration

Also (related draft list), draft-li-dhc-secure-dhcpv6-deployment-03 , secure DHCPv6 deployment

No update since Berlin (last updated 2016-06-18)

-          draft-ietf-dhc-rfc3315bis-05, Dynamic Host Configuration Protocol for IPv6 (DHCPv6) bis

WGLC in progress (ends 8/22)

-          draft-ietf-dhc-sedhcpv6-13 , Secure DHCPv6

Discussed in Berlin, no update yet

And, the following related drafts:

-          draft-shen-dhc-client-port-02, Generalized Source UDP Port of DHCP Relay

Pending call for option?

-          draft-volz-dhc-relay-server-security-01, Security of Messages Exchanged Between Servers and Relay Agents
Minor update pending, then call for adoption.

Thanks!

-          Tomek & Bernie

---

From: Ian Farrer <[email-masked]>
Date: Wed, 14 Sep 2016 18:09:02 +0200

Hi,

Please can I request the following presentation slot for Seoul:

Title Of Session: lw4over6-dynamic-provisioning
Presenter: Ian Farrer
Related Drafts: draft-fsc-softwire-dhcp4o6-saddr-opt-05
Time Required: 10 mins
Purpose of Session: This draft has been in Softwire as a non-WG item for some time, but as it’s contents specifies DHCPv4o6 client/server functional extensions, it may be better suited to be worked on by the DHC workgroup. The aim of the presentation is to find out if DHC is willing to take on the draft.

I would also welcome any comments/reviews/discussion on the draft from the WG in advance of the meeting.

Thanks,
Ian

> On 11 Sep 2016, at 17:08, Bernie Volz (volz) <[email-masked]> wrote:
> 
> At present, the only session request we have is to potentially review 3315bis WGLC issues (if not resolved prior to the meeting or consensus building needs higher bandwidth discussion). See https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda <https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda>.
>  
> At present, we’ll either have a short (1 hour meeting is shortest available slot) or none at all unless we get some items to add to the agenda.
>  
> No apparent progress since just before Berlin. Not sure if there are any outstanding issues to discuss? There were some comments raised in Berlin, especially about options. See https://www.ietf.org/proceedings/96/minutes/minutes-96-dhc <https://www.ietf.org/proceedings/96/minutes/minutes-96-dhc>.
>  
> From: dhcwg [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Bernie Volz (volz)
> To: [email-masked] <mailto:[email-masked]>
> You can view the working agenda at https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda <https://github.com/dhcwg/wg/wiki/IETF-97-(Seoul)-DHC-WG-Agenda>.
>  
> _______________________________________________
> dhcwg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dhcwg <https://www.ietf.org/mailman/listinfo/dhcwg>