Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-05.txt

From: [email-masked]
Date: Sat, 23 Dec 2017 03:01:58 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Linhui Sun
                          Ian Farrer
                          Sladjana Zechlin
                          Zihao He
	Filename        : draft-ietf-dhc-dhcpv6-yang-05.txt
	Pages           : 102
	Date            : 2017-12-23

Abstract:
   This document describes a YANG data model [RFC6020] for the
   configuration and management of DHCPv6 servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-05
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: hezihao <[email-masked]>
Date: Sat, 23 Dec 2017 19:10:25 +0800

Hi
everyone,

We
have posted a new version of draft-dhc-dhcpv6-yang. The main changes (including
the changes that Ian posted on github on 2017-11-24) from version04 are:

1)
Split
the monolithic module into four modules - ietf-dhcpv6-server, ietf-dhcpv6-client,
ietf-dhcpv6-relay and ietf-dhcpv6-options.

2)
Reworked
the ‘option-sets’ definition and ‘use’ mechanism throughout.

3)
Removed
duplication of options between the server (rw) and client (ro) option
definitions. Clients now imports the server options with ‘config false’.

4)
Added
the IANA allocated name/code in the description and the source RFC in the
reference in the option definition. This makes it a lot easier to check for
completeness and validate their structure.

5)
Re-modelled
some options and split some containers that include multiple options.

6)
Separated
Configuration and State trees.

7)
Implemented
the use of ‘presence’ statement to replace ‘enable’ node under each option.

8)
Implemented
the use of ‘feature’ to indicate support for each option and deleted ‘supported-options’
under client.

9)
Added
a ‘duid-invalid’ type as discussed in the mailing list.

10)
Re-worked
address/pool utilization. Now ‘max-address/prefix-utilization-ratio’ is a
configurable threshold value, and ‘address/prefix-utilization-ratio’ is under
the state tree indicating current utilization ratio. These are used by
notifications.

11)
Added a list ‘address-prefix-assign-param’ node under state data of server. This
might be a way to define the logic for the server to assign addresses/prefixes.

Please
feel free to review and comment. Your precious suggestions are always welcome.

Thanks,

Zihao

On 12/23/2017 19:02，<[email-masked]> wrote：

Authors         : Yong Cui

Linhui Sun

Ian Farrer

Sladjana Zechlin

Zihao He

Pages           : 102

Date            : 2017-12-23

Abstract:

_______________________________________________

dhcwg mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/dhcwg