Subject: [dhcwg] [Editorial Errata Reported] RFC3315 (5450)

From: RFC Errata System <[email-masked]>
Date: Fri, 3 Aug 2018 06:47:39 -0700 (PDT)

The following errata report has been submitted for RFC3315,
"Dynamic Host Configuration Protocol for IPv6 (DHCPv6)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5450

--------------------------------------
Type: Editorial
Reported by: Nikolai Malykh <[email-masked]>

Section: 18.2.5

Original Text
-------------
   The server MUST include a Server Identifier option containing the
   server's DUID in the Reply message.  If the client included a Client
   Identification option in the Information-request message, the server
   copies that option to the Reply message.

Corrected Text
--------------
   The server MUST include a Server Identifier option containing the
   server's DUID in the Reply message.  If the client included a Client
   Identifier option in the Information-request message, the server
   copies that option to the Reply message.

Notes
-----
Incorrect option name

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3315 (draft-ietf-dhc-dhcpv6-28)
--------------------------------------
Title               : Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Publication Date    : July 2003
Author(s)           : R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney
Category            : PROPOSED STANDARD
Source              : Dynamic Host Configuration
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 3 Aug 2018 14:05:02 +0000

This does seem to be a valid issue (though it is minor).

And, it does not exist in draft-ietf-dhc-rfc3315bis-13, which is replacing RFC 3315.

Note to RFC Editor  (Lynne)... given that draft-ietf-dhc-rfc3315bis-13 lists the errata included in the document, perhaps this one should be added to the list. See Appendix A, #26.

Note: Updated a few email addresses and removed Jim Bound's.

- Bernie

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Friday, August 3, 2018 9:48 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Bernie Volz (volz) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC3315 (5450)

Section: 18.2.5

Original Text
-------------

Corrected Text
--------------

Notes
-----
Incorrect option name

Instructions:
-------------