Subject: [Dime] Application ID, Session Id and message flows

From: "Bartosz Baranowski" <[email-masked]>
Date: Fri, 26 Sep 2008 17:15:25 +0200

Hi
Im trying to figure few things out for some time now and up until now I have
been hearing contradicting voices wherever I turn myself.
I would like to know what are values of ApplicationID set in messages - Base
messages used in context of Sh interface to Authanticate/Authorize user?

Lets consider flow like follows (not sure if its valid or not):

CLIENT                               SERVER(HSS ?)
     | -------------    UDR -----------------> |
SesssionId_1, AppId_1 ==Sh
                           X
     | <-----------    RAR ------------------- |
SessionId_2, AppId_2= Base
     | -------------    RAA -----------------> |
SessionId_2, AppId_2= Base
     | -------------    UDR -----------------> |
SesssionId_1, AppId_1 ==Sh
     | <-----------   UDA -------------------- |
SesssionId_1, AppId_1 ==Sh

Does X indicates UDA denying access?
Is SessionId_1 equal to SessionId_2?
Is AppId_2== Base or is it equal to AppId_2 ?

Thanks
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Gowda, Avinash" <[email-masked]>
Date: Fri, 26 Sep 2008 20:53:08 +0530

Hi Bartosz,

>> Yes.

>> Yes. Always Re-Auth Request is sent on the existing session. If the
session-id is not available then Result-Code in RAA will be sent as
DIAMETER_UNKNOWN_SESSION_ID (5002).

>> In credit-control application we use Application-Id 4. The same
Application-Id will be used in RAR/RAA also. I am not sure about Sh
interface.

Please anybody comment on this answer.

Thanks,

Avinash Gowda

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Bartosz Baranowski
Sent: Friday, September 26, 2008 8:45 PM
To: [email-masked]
Subject: [Dime] Application ID, Session Id and message flows

Hi
Im trying to figure few things out for some time now and up until now I
have been hearing contradicting voices wherever I turn myself.
I would like to know what are values of ApplicationID set in messages -
Base messages used in context of Sh interface to Authanticate/Authorize
user?

CLIENT                        

       SERVER(HSS ?)

Thanks

---

From: Vipul2 Aggarwal <[email-masked]>
Date: Fri, 26 Sep 2008 20:59:36 +0530

Hi,

As far as I know, there is no RAR message in Sh Interface.
The messages supported in Sh Interface are
UDR/UDA
PUR/PUA
SNR/SNA
PNR/PNA

All these messages use the application ID of Sh.

Can you please elaborate more on the context of RAR in the Sh interface?

Regds,
Vipul Aggarwal

Senior Software Engineer

A R I C E N T

The Presidency Tower-A

351/2, Sector 14, M.G Road

Gurgaon, 122001,  Haryana, India

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bartosz Baranowski
Sent: Friday, September 26, 2008 8:45 PM
To: [email-masked]
Subject: [Dime] Application ID, Session Id and message flows

Hi
Im trying to figure few things out for some time now and up until now I have been hearing contradicting voices wherever I turn myself.
I would like to know what are values of ApplicationID set in messages - Base messages used in context of Sh interface to Authanticate/Authorize user?

CLIENT
       SERVER(HSS ?)
     | -------------    UDR -----------------> |                             SesssionId_1, AppId_1 ==Sh
                           X
     | <-----------    RAR ------------------- |                             SessionId_2, AppId_2= Base
     | -------------    RAA -----------------> |                             SessionId_2, AppId_2= Base
     | -------------    UDR -----------------> |                             SesssionId_1, AppId_1 ==Sh
     | <-----------   UDA -------------------- |                             SesssionId_1, AppId_1 ==Sh

Thanks

________________________________
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Bartosz Baranowski" <[email-masked]>
Date: Fri, 26 Sep 2008 17:44:25 +0200

Hi
Thanks for such quick answer.
See inline

> As far as I know, there is no RAR message in Sh Interface.
Yes I know, there is no such message in Sh defined

> All these messages use the application ID of Sh.
Someone just threw example of Sh scenario where server reqeust
authentication - I didnt find anything about that in TS, rfc or google,
neither I was able to find any example scenarios (of any kind, not regardign
this particular case), so I have decided to post here.
Up until now I was sure that there is not authentication in Sh scenarios, or
is there?
Is there any case of application that uses base messages? I mean there is no
app id in Base, this would indicate that all aplication have to support
those?

> *Vipul Aggarwal*
> *A R I C E N T*
>  ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *Bartosz Baranowski
> *Sent:* Friday, September 26, 2008 8:45 PM
> *To:* [email-masked]
> *Subject:* [Dime] Application ID, Session Id and message flows
>
>
>
> Hi
>
> ------------------------------
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely
> for the use of the individual to whom it is addressed. It may contain
> privileged or confidential information and should not be circulated or used
> for any purpose other than for what it is intended. If you have received
> this message in error,please notify the originator immediately. If you are
> not the intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of this
> message. Aricent accepts no responsibility for loss or damage arising from
> the use of the information transmitted by this email including damage from
> virus."
>

-- 
Bartosz Baranowski
JBoss R & D
==================================
Word of criticism meant to improve is always step forward.
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Vipul2 Aggarwal <[email-masked]>
Date: Fri, 26 Sep 2008 21:33:32 +0530

Hi,

You are right. There is no re-authentication scenario in Sh.

Yes, there are interfaces (like NASReq, EAP, Wm, Rx, that I am aware of) that use base messages. But, these interfaces use their own application ID in these messages i.e. they don't use the application ID of Base (i.e. 0) in the messages.

For e.g. NASReq interface uses the messages STR/STA, RAR/RAA, ASR/ASA. But, the application ID that goes in these messages is that of NASReq (i.e. 1).

Hope this helps.

Regds,

Vipul Aggarwal

Senior Software Engineer

A R I C E N T

The Presidency Tower-A

________________________________
From: Bartosz Baranowski [mailto:[email-masked]]
Sent: Friday, September 26, 2008 9:14 PM
To: Vipul2 Aggarwal
Cc: [email-masked]
Subject: Re: [Dime] Application ID, Session Id and message flows

Hi
Thanks for such quick answer.
See inline
On Fri, Sep 26, 2008 at 5:29 PM, Vipul2 Aggarwal <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

UDR/UDA

PUR/PUA

SNR/SNA

PNR/PNA

All these messages use the application ID of Sh.
Someone just threw example of Sh scenario where server reqeust authentication - I didnt find anything about that in TS, rfc or google, neither I was able to find any example scenarios (of any kind, not regardign this particular case), so I have decided to post here.
Up until now I was sure that there is not authentication in Sh scenarios, or is there?
Is there any case of application that uses base messages? I mean there is no app id in Base, this would indicate that all aplication have to support those?

Regds,

Vipul Aggarwal

Senior Software Engineer

A R I C E N T

The Presidency Tower-A

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Bartosz Baranowski
Sent: Friday, September 26, 2008 8:45 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dime] Application ID, Session Id and message flows

Hi

CLIENT

       SERVER(HSS ?)

Thanks

_______________________________________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime

---

From: "Bartosz Baranowski" <[email-masked]>
Date: Fri, 26 Sep 2008 19:48:31 +0200

Hi
Thanks, this clears my mind - should be mentioned in TS or rfc.

On Fri, Sep 26, 2008 at 6:03 PM, Vipul2 Aggarwal <
[email-masked]> wrote:

> Yes, there are interfaces (like NASReq, EAP, Wm, Rx, that I am aware of)
> that use base messages. But, these interfaces use their own application ID
> in these messages i.e. they don't use the application ID of Base (i.e. 0) in
> the messages.
>
>
>
> For e.g. NASReq interface uses the messages STR/STA, RAR/RAA, ASR/ASA. But,
> the application ID that goes in these messages is that of NASReq (i.e. 1).
>
>
>
> Hope this helps.
>
> Regds,
>
> *Vipul Aggarwal*
>
> Senior Software Engineer
>
>
>
> *A R I C E N T*
>
>
>
> The Presidency Tower-A
>
> *From:* Bartosz Baranowski [mailto:[email-masked]]
> *Sent:* Friday, September 26, 2008 9:14 PM
> *To:* Vipul2 Aggarwal
> *Cc:* [email-masked]
> *Subject:* Re: [Dime] Application ID, Session Id and message flows
>
>
>
> Hi
> Is there any case of application that uses base messages? I mean there is
> no app id in Base, this would indicate that all aplication have to support
> those?
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 26 Sep 2008 21:25:33 +0300

A well written IETF document must describe the Application ID setting 
for the messages an application uses.

Bartosz Baranowski wrote:
> On Fri, Sep 26, 2008 at 6:03 PM, Vipul2 Aggarwal 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>      
>
>     Yes, there are interfaces (like NASReq, EAP, Wm, Rx, that I am
>     aware of) that use base messages. But, these interfaces use their
>     own application ID in these messages i.e. they don't use the
>     application ID of Base (i.e. 0) in the messages.
>
>      
>
>     For e.g. NASReq interface uses the messages STR/STA, RAR/RAA,
>     ASR/ASA. But, the application ID that goes in these messages is
>     that of NASReq (i.e. 1).
>
>      
>
>     Hope this helps.
>
>     Regds,
>
>     *Vipul Aggarwal*
>
>     Senior Software Engineer
>
>      
>
>     *A R I C E N T*
>
>      
>
>     The Presidency Tower-A
>
>     ------------------------------------------------------------------------
>
>     *From:* Bartosz Baranowski [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     *Cc:* [email-masked] <mailto:[email-masked]>
>     On Fri, Sep 26, 2008 at 5:29 PM, Vipul2 Aggarwal
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>
>     Hi,
>
>      
>
>     authentication - I didnt find anything about that in TS, rfc or
>     google, neither I was able to find any example scenarios (of any
>     kind, not regardign this particular case), so I have decided to
>     post here.
>     Is there any case of application that uses base messages? I mean
>     there is no app id in Base, this would indicate that all
>     aplication have to support those?
>
>         ------------------------------------------------------------------------
>
>         *From:* [email-masked] <mailto:[email-masked]>
>         [mailto:[email-masked] <mailto:[email-masked]>]
>         *On Behalf Of *Bartosz Baranowski
>         *To:* [email-masked] <mailto:[email-masked]>
>         Im trying to figure few things out for some time now and up
>         until now I have been hearing contradicting voices wherever I
>         turn myself.
>         I would like to know what are values of ApplicationID set in
>         messages - Base messages used in context of Sh interface to
>         Authanticate/Authorize user?
>
>         ------------------------------------------------------------------------
>
>         "DISCLAIMER: This message is proprietary to Aricent and is
>         intended solely for the use of the individual to whom it is
>         addressed. It may contain privileged or confidential
>         information and should not be circulated or used for any
>         purpose other than for what it is intended. If you have
>         received this message in error,please notify the originator
>         immediately. If you are not the intended recipient, you are
>         notified that you are strictly prohibited from using, copying,
>         altering, or disclosing the contents of this message. Aricent
>         accepts no responsibility for loss or damage arising from the
>         use of the information transmitted by this email including
>         damage from virus."
>
>
>         [email-masked] <mailto:[email-masked]>
>     ------------------------------------------------------------------------
>     "DISCLAIMER: This message is proprietary to Aricent and is
>     intended solely for the use of the individual to whom it is
>     addressed. It may contain privileged or confidential information
>     and should not be circulated or used for any purpose other than
>     for what it is intended. If you have received this message in
>     error,please notify the originator immediately. If you are not the
>     intended recipient, you are notified that you are strictly
>     prohibited from using, copying, altering, or disclosing the
>     contents of this message. Aricent accepts no responsibility for
>     loss or damage arising from the use of the information transmitted
>     by this email including damage from virus."
>
>
>
>
> -- 
> Bartosz Baranowski
> JBoss R & D
> ------------------------------------------------------------------------
>