Subject: [Dime] Shall a diameter node validate Host-IP-Address in CER?

From: "Jianjun Zhang" <[email-masked]>
Date: Wed, 5 Nov 2008 12:18:44 +0800

Hi,

In CER, the Host-IP-Address should be the ip of the sender.
In some scenario, Eg. if it is in an internal network and NAT to external, it might fill the internal ip in the CER.
Shall the diameter peer node validate the Host-IP-Address in CER?

I didn't find in RFC. Does anyone know?

Thanks
2008-11-05 

Jianjun Zhang 
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 6 Nov 2008 13:34:35 +0200

What do you mean by "validate an IP address"? 
 
Ciao
Hannes

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Jianjun Zhang
	Sent: 05 November, 2008 06:19
	To: DiME
	Subject: [Dime] Shall a diameter node validate Host-IP-Address
in CER?

	Hi,
	 
	In CER, the Host-IP-Address should be the ip of the sender.
	In some scenario, Eg. if it is in an internal network and NAT to
external, it might fill the internal ip in the CER.
	Shall the diameter peer node validate the Host-IP-Address in
CER?

	Thanks
	2008-11-05 
	________________________________

	Jianjun Zhang

---

From: "Jianjun Zhang" <[email-masked]>
Date: Thu, 6 Nov 2008 19:48:19 +0800

Sorry, verify.

If in CER, the host-ip-addr is different to the source ip of TCP. 
Shall the peer(who recv the CER) reject the connection?

Thanks
2008-11-06 

Jianjun Zhang 

发件人： Tschofenig, Hannes (NSN - FI/Espoo) 
发送时间： 2008-11-06  19:34:54 
收件人： ext Jianjun Zhang; DiME 
抄送： 
主题： RE: [Dime] Shall a diameter node validate Host-IP-Address in CER? 

Ciao
Hannes

Thanks
2008-11-05