Subject: [Dime] 3588bis-13: Redirect-Host usage contradiction

From: Mark Jones <[email-masked]>
Date: Thu, 13 Nov 2008 02:01:23 -0500

Hi,

I believe there is a contradiction in the description of Redirect-Host usage in 3588 and 3588bis-13. The last sentence in section 6.12 states that:

   The server contained in the selected Redirect-Host AVP SHOULD be used
   for all messages pertaining to this session.

However, section 6.13 states that the default usage behaviour is DONT_CACHE unless it is overridden by a Redirect-Host-Usage.

I think the most useful redirect behaviour is caching the redirect host for the duration of the Diameter session so this should be the default if Redirect-Host-Usage is absent, i.e. section 6.13 in 3588bis should be updated to state that ALL_SESSION is the default value of Redirect-Host-Usage.

Any concerns?

Regards
Mark
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Victor Fajardo <[email-masked]>
Date: Thu, 13 Nov 2008 10:34:47 -0500

Hi Mark,

> However, section 6.13 states that the default usage behaviour is DONT_CACHE unless it is overridden by a Redirect-Host-Usage.

I agree.

> I think the most useful redirect behaviour is caching the redirect host for the duration of the Diameter session so this should be the default if Redirect-Host-Usage is absent, i.e. section 6.13 in…

I have no strong opinion on this but to maybe ALL_SESSION as default 
just looks good on paper. For routing performance, always tracking the 
state of a session is more work than necessary. If DONT_CACHE is a 
default, basic redirection is simple. Anyway, having DONT_CACHE as a 
default does not take away any functionality from ALL_SESSION.

regards,
victor

---

From: Mark Jones <[email-masked]>
Date: Fri, 14 Nov 2008 00:27:15 -0500

Hi Victor,

> -----Original Message-----
> From: Victor Fajardo [mailto:[email-masked]]
> Sent: November 13, 2008 23:35
> To: Mark Jones
> Cc: [email-masked]
> Subject: Re: [Dime] 3588bis-13: Redirect-Host usage contradiction
>
> Hi Mark,
>
> > I believe there is a contradiction in the description of
> Redirect-Host usage in 3588 and 3588bis-13. The last sentence
> in section 6.12 states that:
> >
> > However, section 6.13 states that the default usage
> behaviour is DONT_CACHE unless it is overridden by a
> Redirect-Host-Usage.
> >
>
> I agree.
>
> > I think the most useful redirect behaviour is caching the
> redirect host for the duration of the Diameter session so
> this should be the default if Redirect-Host-Usage is absent,
> i.e. section 6.13 in 3588bis should be updated to state that
> ALL_SESSION is the default value of Redirect-Host-Usage.
> >
>

I was thinking of alignment with the default value of Auth-Session-State which is STATE_MAINTAINED. If maintaining session state is required then the client must send the STR to the Origin-Host in the answer message which would be the Redirect-Host in the redirect message.

What do others think? Given the contradiction in 3588, any fix means code changes may be required in existing implementations albeit minor ones.

Regards
Mark

---

From: Victor Fajardo <[email-masked]>
Date: Fri, 14 Nov 2008 01:29:42 -0500

Hi Mark,

>>>    The server contained in the selected Redirect-Host AVP
>>>       
>> SHOULD be used
>>     

Hmmm ... should'nt the Origin-Host be the actual server the client is 
talking to ? A client that gets redirected simply resends the original 
request to the alternate server which responds with an answer containing 
its origin host.

-- victor

---

From: Victor Fajardo <[email-masked]>
Date: Fri, 14 Nov 2008 02:33:58 -0500

Hi Mark,

>>>
>>>     
>>
>> I was thinking of alignment with the default value of 
>> Auth-Session-State which is STATE_MAINTAINED. If maintaining session 
>> state is required then the client must send the STR to the 
>> Origin-Host in the answer message which would be the Redirect-Host in 
>> the redirect message.
>>   
>
> request to the alternate server which responds with an answer 
> containing its origin host.

Pls disregard my comment above ... mis-interpreted your last sentence 
from Redirect-Host to Redirect agent.

-- victor

---

From: Mark Jones <[email-masked]>
Date: Thu, 20 Nov 2008 09:36:23 -0500

> Auth-Session-State which is STATE_MAINTAINED. If maintaining
> session state is required then the client must send the STR
> to the Origin-Host in the answer message which would be the
> Redirect-Host in the redirect message.
>
> What do others think? Given the contradiction in 3588, any
> fix means code changes may be required in existing
> implementations albeit minor ones.

Anyone? Anyone? Bueller?

This contradiction does need a fix. If you have a Diameter stack, please check the Redirect-Host caching behaviour when there is no Redirect-Host-Usage AVP and weigh in on this issue so we can get a fix into 3588bis. My preference is defaulting to ALL_SESSION for the reason given above.

Thanks
Mark

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Mark Jones
> Sent: November 14, 2008 00:27
> To: Victor Fajardo
> Cc: [email-masked]
> Auth-Session-State which is STATE_MAINTAINED. If maintaining
> session state is required then the client must send the STR
> to the Origin-Host in the answer message which would be the
> Redirect-Host in the redirect message.
>
> What do others think? Given the contradiction in 3588, any
> fix means code changes may be required in existing
> implementations albeit minor ones.
>
> Regards
> Mark
>

---

From: Victor Fajardo <[email-masked]>
Date: Thu, 20 Nov 2008 08:42:08 -0600

Hi Mark,

> This contradiction does need a fix. If you have a Diameter stack, please check the Redirect-Host caching behaviour when there is no Redirect-Host-Usage AVP and weigh in on this issue so we can get…

Just a quick question. Even if the Auth-Session-State is set to 
STATE_MAINTAINED and redirect is DONT_CACHE, is any functionality really 
broken ? STRs (or any other request for the session) will still be 
redirected.

regards,
victor