Subject: Re: [Dime] M-bit - draft-ietf-dime-rfc3588bis-12.txt

From: "Hannes Tschofenig" <[email-masked]>
Date: Sat, 1 Nov 2008 21:11:03 +0200

Hi Jan, 

The terminology is a bit challenging, I know. 

We cannot change the term "Mandatory AVP" anymore since everyone is pretty
much used to it already. 

For the required AVP we still have the chance to pick whatever we want but
it is important to have a different name for the two as they are very
different concepts. 

So, what name would you suggest instead of "Required AVP"?

Ciao
Hannes

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Jan Engelhardt
>Sent: 01 November, 2008 06:23
>To: Tschofenig, Hannes (NSN - FI/Espoo)
>Cc: [email-masked]
>Subject: Re: [Dime] M-bit - draft-ietf-dime-rfc3588bis-12.txt
>
>
>>I should have been more precise: "... MUST parse and understand the 
>>semantic of the AVP including its content".
>
>I would not call it Mandatory AVP then, because mandatory is 
>close to required, if you look that up in a thesaurus, but 
>required-to-be-present is different from required-to-be-understood.
>_______________________________________________
>DiME mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dime
>

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Jan Engelhardt <[email-masked]>
Date: Sun, 2 Nov 2008 19:43:07 +0100 (CET)

>So, what name would you suggest instead of "Required AVP"?

Too hard when Mandatory is fixated. Something along the lines of
"Required-Presence AVP" maybe? (sounds odd though.)
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime