Subject: Re: [Dime] Diameter Peer Discovery - A/AAAA vs. SRV

From: Victor Fajardo <[email-masked]>
Date: Wed, 19 Nov 2008 18:56:21 -0600

Hi Stefan,

Sorry for missing this query. Comments inline:

> 3588 and -bis define a peer lookup mechanism that first looks for NAPTR
> records for a realm, and if that fails use an underscore construct in
> conjunction with A and AAAA records:
>
> "If no NAPTR records are found, the requester queries for those
>
>        address records for the destination address,
>        '_diameter._sctp'.realm or '_diameter._tcp'.realm.  Address
>        records include A RR's, AAAA RR's or other similar records,
>        chosen according to the requester's network protocol
>        capabilities."
>
> When looking into the same issue for RadSec, I received some (IMHO justified) off-list opposition. It appears to be seen as a very bad practice by a lot of DNS people to use underscore constructs in A or AAAA records.
>   

I agree.

> The question had been raised why the lookup mechanism does not use SRV records as fallback after NAPTR - these were specifically designed for service discovery with underscores. The SRV RR RFC is also older than 3588, so the option to use it existed back then.
>   

I think this sounds reasonable as well.

> I wonder if there is a reason and/or actual deployed experience with this bit of the Diameter spec, and whether it is maybe about time to introduce SRV record lookups in 3588bis (and RadSec).
>   

I'm not sure about deployment experience but the practice you mentioned 
seems a common and way for other protocols that perform discovery (i.e. 
SIP). Its probably good to do the same for diameter.

regads,
victor

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Jonathan Cumming <[email-masked]>
Date: Mon, 24 Nov 2008 14:34:10 +0000

Hi Victor,

Regarding you point:
        "I'm not sure about deployment experience but the practice you mentioned seems a common and way for other protocols that perform discovery (i.e. SIP). Its probably good to do the same for diameter."

I may be mistaken, but I do not believe that SIP defines the use of _sip for A or AAAA records.  _sip... and _sips... are used to create the default SRV record queries when no NAPTR records are present, according to RFC 3263.

Regards,
Jonathan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Victor Fajardo
Sent: 20 November 2008 00:56
To: Stefan Winter
Cc: [email-masked]
Subject: Re: [Dime] Diameter Peer Discovery - A/AAAA vs. SRV

Hi Stefan,

Sorry for missing this query. Comments inline:

> 3588 and -bis define a peer lookup mechanism that first looks for
> NAPTR records for a realm, and if that fails use an underscore
> construct in conjunction with A and AAAA records:
>

I agree.

> I wonder if there is a reason and/or actual deployed experience with this bit of the Diameter spec, and whether it is maybe about time to introduce SRV record lookups in 3588bis (and RadSec).

I'm not sure about deployment experience but the practice you mentioned seems a common and way for other protocols that perform discovery (i.e.
SIP). Its probably good to do the same for diameter.

regads,
victor

---

From: Victor Fajardo <[email-masked]>
Date: Mon, 24 Nov 2008 10:15:42 -0500

Hi Jonathan,

> I may be mistaken, but I do not believe that SIP defines the use of _sip for A or AAAA records.  _sip... and _sips... are used to create the default SRV record queries when no NAPTR records are pre…

Sorry if thread was not clear but I was actually pointing to the fact 
you mentioned; i.e. other protocols DO NOT commonly use underscores for 
address records.

-- victor

---

From: Jonathan Cumming <[email-masked]>
Date: Mon, 24 Nov 2008 16:07:17 +0000

Hi Victor,

Many thanks for the clarification - I am very pleased we agree.

Jonathan

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]]
Sent: 24 November 2008 15:16
To: Jonathan Cumming
Cc: [email-masked]; Stefan Winter
Subject: Re: [Dime] Diameter Peer Discovery - A/AAAA vs. SRV

Hi Jonathan,

> I may be mistaken, but I do not believe that SIP defines the use of _sip for A or AAAA records.  _sip... and _sips... are used to create the default SRV record queries when no NAPTR records are pre…

Sorry if thread was not clear but I was actually pointing to the fact you mentioned; i.e. other protocols DO NOT commonly use underscores for address records.

-- victor